Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

when typing in "?" into the url bar how do you stop everything from being converted to lowercase? like "/watch?v=XxXx" becomes invalid "/watch?v=xxxx". thanks.

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

firefox converts links to lowercase that have "?".

windows cant have filenames that contain ":" "/" "?". so i put japanese ":" "/" "?" in filenames to replace.

so metadata for a youtube download can have the link.

example; "" can be written as; ""

if i enter "", into firefox it works fine. but if i enter "", the question marks causes everything to go lowercase. so it becomes "".

so requesting firefox to keep letters as they are. even after converting "?" to "?" in links.

please help, anyone.

All Replies (2)

more options

Are those valid characters in a URL in other parts of the world?

I can't figure out what feature of firefox is figuring out that com/watch?v= should be interpreted as com/watch?v=. Perhaps it has something to do with internationalized domain support??

Also, if you need to change a Windows file name, why do you also need to change the URL (shortcut target) associated with the name? Can't you leave that in its original form?

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).