X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do I delete a tab group or stop it from opening all tabs eveytime I start firefox?

Posted

I never set up a tab group but somehow I have one with three tabs in it and I have gone to the group and clicked on the X in the top right corner but it continues to open every tab in the group every time I open a browser. I don't want ANY of these opened, I don't even want a tab group, how do I delete this group thing and how do I make it stop opening these web pages?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Facebook Video Calling Plugin
  • Shockwave Flash 11.1 r102
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • 5.0.61118.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • NPWLPG
  • Office Live Update v1.5

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

I had never even heard of tab groups until this one started opening on it's own, I don't want it. I want to delete it.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Hi schrader,

What do you have Firefox set to do when it starts? Did you tell it to restore your last session or go to a specific home page?

You should take a look at the Knowledge Base article How to set the home page. There are steps in that article to reset your homepage preferences to default. Then be sure you've set Firefox to show your home page on startup and restart it. I would try that first to clear out any strangeness. If that works, you can try setting your homepage again to your personal preference.

If that doesn't work you should look at the article How to fix preferences that won't save.

Hopefully this helps!

ajdominguez55 1 solutions 5 answers

Tools tab (on the top left of the Firefox browser) > options > general > When Firefox starts... > show my home page >

Home page...> set as google.com or another default website you would like to have at startup

Helpful Reply

Thank-you for your response however, I have NO IDEA what you are talking about. I don't know how to check to see what Firefox is set at upon opening, I didn't change anything, when I click on the Firefox it opens three tabs, none of which are my home page, if I click on it again it will open just one, my home page but I can't get this tab group to go away. I never set any tab group and didn't even know they existed until I tried to open a browser and got the three open tabs, that is when I started looking at the help topics to see what the hell....

So I ask again, how do I delete A tab group?

Question owner

Sorry, this didn't work either..... My home page has never changed, it is still set, I need to know how to DELETE a tab group.

ajdominguez55 1 solutions 5 answers

I think this might do it. However, there may be consequences and be harmful to the stability of the browser.

Type about:config in the address bar and press enter.

Agree that you will be careful. Type in the filter browser.tabs.insertRelatedAfterCurrent in the filter field. You should see a single setting of type boolean. Double-click the browser.tabs.insertRelatedAfterCurrent setting so it toggles and shows false

This should disable not necessarily delete tab grouping.

Modified by ajdominguez55

Question owner

ok, causing more problems is not an option, I need this computer to run my business, thanks anyway.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Hi schrader,

Did you reset the home page as I suggested and then restart Firefox? Also, did you check to see if have told Firefox is set to restore your last session or show your homepage? The reason I ask is that it sounds like you might have a stored session with that tab group that just won't go away. You could try deleting Sessionstore.js from your Profile Folder.

You could also try starting Firefox in Troubleshoot Firefox issues using Safe Mode. Don't worry, NEITHER of these suggestions will hurt your business computer. Just don't delete anything else from the profile folder ;)

Hopefully this helps!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

See also:

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Also reset the browser.panorama.experienced_first_run pref on the about:config page via the right-click context menu.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access the about:config page.

  • Use the Filter bar at the top of the about:config page to locate a preference more easily.

Question owner

Again, I have NOT stored anything, hell I didn't even save these tabs as a group, yes, I looked at the home page, it is still set as it has always been, you keep saying to start it in safe mode, I am not a computer geek and have no idea what that means.

I do NOT need to tell it what my homepage is, I NEED to delete the freaking TABS GROUP! THAT'S ALL!

Question owner

NO there was no session restore chosen, I didn't do this! ALL I NEED IS TO FIND OUT HOW TO DELETE A TAB GROUP!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

The data for App tabs and Tab groups is stored in the sessionstore.js file, so if you want to remove Tab groups then you can remove that file.

Jodelle 0 solutions 3 answers

After spending too many hours trying to resolve this issue and get rid of Groups, I found a very workable answer at link text where cth1 wrote:

"Go to Customise Toolbar and drag group tab back onto list of toolbar icons."

Customise Toolbar is found by right-clicking on the Group icon.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can reset the browser.panorama.* prefs on the about:config page to remove the "Move to Group" entry in the right-click context menu of the Tab bar.

Jodelle 0 solutions 3 answers

I restored the Groups tab, found 'browser.panorama.* prefs on the about:config page', right-clicked each of the three entries there and changed to False. Restarted Firefox and the groups are still there. Please do say if I've misunderstood your suggestion, until then, I'm removing the pesky Groups tab! I'm actually not sure I understand your ""Move to Group" entry in the right-click context menu of the Tab bar.". Thanks for trying to help.

OMG now I find that the buttons that should be to the right of my tabs (like listing all open tabs) have disappeared! I've also lost track of what the defaults are for panorama in about:config!!

Modified by Jodelle

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Delete the sessionstore.js file to get rid of the Tab Groups data stored in that file.