X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to disable GPU acceleration, really?

Posted

I disabled GPU acceleration from settings menu but it is not effective. I did it from "about:config" menu "gfx.direct2d.disabled -true" but also not working. I did disable for all extension to check them but still have problem.

The problem is firefox using my GPU on maximum clocks even for a simple page scrolling. It causes GPU clocks go up and down continuously, and VGA cooler also speeds up and goes down which creates cooler noise fluctuation. It is really irritating.

Only thing I can do is to run firefox in windows xp compatibility mode. But this is just an interim solution.

Now I updated version 11 and this still not fixed. I wrote about this problem a few times but still nothing.

Additional System Details

This happened

Every time Firefox opened

This started when...

Update to version 10.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Alkalmazás alapadatai
Név
Firefox
Verzió
11.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Profilkönyvtár
A profilkönyvtárt tartalmazó mappa megnyitása
Engedélyezett bővítmények
about:plugins
Build konfiguráció
about:buildconfig
Összeomlás-bejelentés
about:crashes
Memóriahasználat
about:memory
Kiterjesztések
Név
Verzió
Engedélyezve
Azonosító
Flash Video Downloader Youtube Downloader
3.5.3
true
artur.dubovoy@gmail.com
AVG Safe Search
12.0.0.1912
false
{1E73965B-8B48-48be-9C8D-68B920ABC1C4}
AVG Security Toolbar
10.0.0.7
false
avg@toolbar
Módosított beállítások
Név
Érték
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20120312181643
browser.startup.homepage_override.mstone
rv:11.0
extensions.lastAppVersion
11.0
general.autoScroll
false
gfx.blacklist.layers.opengl
5
gfx.blacklist.suggested-driver-version
10.6
gfx.blacklist.webgl.opengl
5
gfx.direct2d.disabled
true
gfx.font_rendering.directwrite.enabled
true
keyword.URL
http://isearch.avg.com/search?cid=%7Baf7bd087-f01d-4e70-945e-117e051cf302%7D&mid=f1e1a546502247d19242d151a2ee5ca3-4c482d...
layers.acceleration.disabled
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1331311076
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
webgl.force-enabled
true
Grafika
Adapter leírása
AMD Radeon HD 6800 Series
Gyártóazonosító
1002
Eszközazonosító
6738
Adapter memóriája
1024
Adapter illesztőprogramjai
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Illesztőprogram verziója
8.930.0.0
Illesztőprogram dátuma
12-5-2011
Direct2D engedélyezve
false
DirectWrite engedélyezve
true (6.1.7601.17776)
ClearType-paraméterek
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
WebGL-megjelenítő
Google Inc. -- ANGLE (AMD Radeon HD 6800 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)
GPU segítségével gyorsított ablakok
0

Vivek 310 solutions 2084 answers

Hi,

Please also see this.

Question owner

Hi

No luck, this could not help. Even I open any txt file, I get maximum GPU clocks during scroll. So I think this poblem comes by firefox itself, not from any page acceleration.

I wanted to check whether, reason is browser or vga hardware or software. But I do not have this problem with other browser.

Vivek 310 solutions 2084 answers

You can check if Firefox is still using hardware acceleration in Help (Alt + T) > Troubleshooting Information, Graphics towards the bottom. Please also see this for the two types of acceleration Firefox does. You can also try the Hardware Acceleration Stress Test linked on the page.

Question owner

Ohh, I copied the Troubleshooting Information on my language. So this is it, GPU accelerated pages=0

I also checked Hardware Acceleration Stress Test. If I enable gpu acceleration in the menu I got 60+fps with maximum gpu clocks. If gpu acceleration is disabled the result is 12fps and GPU clocks is fluctuating between basics and maximum clocks.

Vivek 310 solutions 2084 answers

Helpful Reply

GPU accelerated pages=0 means Firefox is not using acceleration. The spike in the GPU clock when scrolling could be the Windows graphics acceleration. You can also try to file a detailed report here.

Question owner

I do not have this issue with iexplorer or chrome. If GPU acceleration is enabled, it is on default clocks with this 2 browser.

Windows desktop composition is enabled and GPU can hadle it on default clocks.

Thanx for trying to help me, but it seems we will not find solution for it.

Vivek 310 solutions 2084 answers

No problem. I'm sure there would be a better explanation from our users and contributors here who may be very familiar with the hardware acceleration troubleshooting tools.

Question owner

I do not have this issue if firefox running with disabled desktop composition. Also there is not problem if running windows server 2003 compatibility mode or lower. Problem comes with higher compatibility mode, windows 2008 or vista. So i use it in win 2003 compatibility mode until solution. But in this case the design is poorer.

Anyway I do not think for displaying firefox, full clock (power) of my 6870 vga is needed.

Vivek 310 solutions 2084 answers

You may have a valid point regarding Aero and Firefox. You can file a detailed report @ bugzilla. The Mozilla developers would be able to sort this out. Filing a detailed report would also be helpful in the ongoing development of Firefox.

Before that you can also try to check this in a new new profile. This would ensure the default settings. If the new profile is okay, you can later copy the needed personal data from the old profile. Firefox stores your personal data and settings in another location separate from its files/folder. A new profile would have the default Firefox settings (Tools (Alt + T) > Options, and about:config ), and usually would also be empty of any Extensions and themes (Appearance) in Tools > Add-ons) and their settings. Also, a new profile would have no previous stored website data/settings etc., (Tools > Clear Recent History).

Profiles Howto

Profile Folder & Files

about:config Entries

Question owner

I was not using firefox during this 4 month. Now I tried again new Firefox 14.01 and new amd catalyst version but the problem still same. Unbeliveable.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

How do you monitor GPU usage? What impact does it have on your browsing experience (I understand that the processor is busy, but does this impact your use of Firefox)?

Please note that the Flash plugin will use hardware acceleration independently of the Firefox setting. Turning that off involves a different procedure: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

Question owner

Hi I use a gadget (GPU observer) for this and I see GPU clock, voltage and cooler rotation is fluctuating. I do not have problem with browsing experience my problem is this cooler noise fluctuation. I hear it and it is irritation. I have amd 6870 vga and I do not think for browsing it has to work on full GPU clock. Of course flash hardware acceleration is disabled. As it was figured out in previous posts windows 7 aero and firefox together are responsible for this fluctuation. When desktop composition is disabled or firefox running in windows server 2003 mode this problem does not exist.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Thanks for your reply. I was running XP previously so I wasn't aware of the meaning of the "Desktop Composition" checkbox on the Compatibility tab (right-click Firefox desktop icon > Properties > Compatibility). I've seen a couple of other posts on "fan noise" so this might be worth a try for those users, too.