X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Document Expired when hitting back button! Very annoying This has been ongoing intermittently for years Why cant this be fixed? Is anything being done about it?

Posted

Document Expired when hitting back button! Very annoying This has been ongoing intermittently for years Why cant this be fixed? Is anything being done about it?

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to current version 10.0.2

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

This has been ongoing on & off for years! It's very sad cos once again I have abandoned Firefox. What cant someone sort this out to never happen again or come up with a fix that works?

terrace 2 solutions 108 answers

I tried the about config and will have to wait to see any difference. This Document Expired nuisance has only appeared on my computer in the last 2 months. before that it didn`t exist. Actually i think Mozilla doesn`t care what problems we have.

Question owner

I agree Terrance. Mozilla have obviously seen this forum chat and just can't be bothered with it. I no longer use Firefox and Chrome has also just recently started to be a pain. You have to click below any eBay buttons for them to work. Clicking on a button does not work at all & trying to highlight and copy text is a nightmare. It's incredible that such massive companies can't get it right and do nothing to put it right. it's a case of too big for them to care. I wonder if their shareholders know about this ongoing problem that has been ignored for years. It's time for Opera to take over! It's now the best browser. Eventually the big boys will have to listen. Until then Opera is the best internet browser. August 2012 Lets help this string get to the top of Google search results by stating our favorite browser! I'll say it again. Compared to Opera browser Firefox is no longer the best browser.

terrace 2 solutions 108 answers

Yes The Other Jon i agree with all your comments. I suppose if i go to Opera browser i would have to import bookmarks etc., Also does Opera accept Google search?

Question owner

Yep. I imported all my bookmarks into Opera no problem. The only problem is that it scrolls a bit fast so you may need to adjust your mouse settings. Other than that I can't fault it. It's also much faster.

terrace 2 solutions 108 answers

Thanks. Any particular site to download Opera?

Question owner

From Opera here http://www.opera.com/download/

terrace 2 solutions 108 answers

Thanks, Opera downloaded on my computer, so i look forward to avoiding the ridiculous "document expired" F`Fox and urge others to do the same. Cheers

BlohoJo 0 solutions 3 answers

Could you please stop the derailing off topic comments. It's not nice. :\

In my case, I had this problem on a recent install of Firefox 14.0.1. I was on LiveLeak.com and found that when I viewed a video, then hit the back button to the main page, I would get the "Document Expired" message.

When I changed browser.sessionstore.postdata to -1, the problem went away.

If your browser was working OK then started with this problem, that might point to some kind of glitch or corruption in your cache, profile, or install.

What I would try is, close ALL tabs and windows. Do about:config, make sure browser.sessionstore.postdata is at -1. Then do a "Clear Recent History." Make sure ALL checkboxes are selected. Then close the browser.

Next, completely delete your cache folder. On Windows XP, this is under C:\Documents and Settings\[USER NAME]\Local Settings\Application Data\Mozilla\Firefox\Profiles by default. Just open that folder and delete all of its contents. (In Windows 7, I believe it's under C:\Users\[USER NAME]\AppData\Local\Mozilla\Firefox\Profiles). Note that this is the cache, not the profile folder, so it should be safe to delete.

Restart Firefox and try your navigation again, see if the "document expired" is gone now.

If it still isn't, if it were me, I would uninstall and reinstall Firefox, and reconfigure it from scratch, making sure browser.sessionstore.postdata is set to -1 in about:config. Yeah, I know it's a PITA, but that's what I would do if I was determined to fix this annoying problem.

JScuderi 0 solutions 4 answers

LIMITED SOLUTION FOUND: Sounded promising, but it was still no deal using FF 14.0.1 with browser.sessionstore.postdata set to -1, cleared all history, deleted cache, restarted, on my own Apache server on a PHP page I wrote, I still get "This document is no longer available." ...

Then I messed around with PHP and GOT IT! If you are a webmaster, this actually works!

Add this to the top of your PHP page and now you can go BACK without the extra clicks:


<?php session_cache_limiter('private_no_expire'); // must go before session start session_start(); ?>


For details, see http://php.net/manual/en/function.session-cache-limiter.php

I reverted browser.sessionstore.postdata to the default of 0 and, awesomely, my page still works. So, I'm sticking with Firefox instead of Chrome. ;-)

Modified by JScuderi

Question owner

Hi JScuderi, I'm sorry but I don't know what you mean. I'm not much of a techno wizard. Just a novice on a mission to find help which is why I started this session 4 months ago. What is the PHP page and where is it located? Can you give step by step instructions to help us novices please? Best Regards, Jon

Modified by TheOtherJon

terrace 2 solutions 108 answers

I`m not sure either.

JScuderi 0 solutions 4 answers

A web page is something you get with your browser from a server. Unless you have access *to make changes on that web server*, you can not change the web page, and therefore, you can not fix the problem with my fix.

PHP is a language used to create some dynamic web pages. If those pages connect to databases, when the web page submits a form using a method called POST (even a hidden one in the background) you will see the Firefox message telling you to re-submit when you use the Back button.

If you are a programmer and you want to fix your own PHP based web page so it will not cause this FF problem, use my solution above to fix the code on your page.

If you can not change the code yourself, try contacting the owners of the web site.

The Moz programmers still need to fix Firefox so this workaround is not needed on every web site. I'll repeat that I found no other fix for this that worked based only on Firefox changes. I could *only* get rid of this problem on my own web pages by changing my code.

Modified by JScuderi

Question owner

This is not a fix. It's techno nerdism.The problem is with most websites. You think eBay are going to let me change their coding? Definitely not. You said SOLUTION FOUND: But it's not actually a solution to the problem we are all experiencing is it. So I don't understand why you would say that you have found a solution. Nobody is going to change their website coding to please Firefox users.

Modified by TheOtherJon

JScuderi 0 solutions 4 answers

My techno nerdism fixed it with FF on my site. It is now completely fixed on that one site. I no longer have the problem on the only site I cared about. So, for me, SOLUTION FOUND. I realize this does not help you with eBay, and so on. It is a real solution, however, for web developers who want to override this new annoying FireFox behavior. I'd be happy to change my wording to LIMITED SOLUTION FOUND. :-)

Question owner

It is not really a solution until it works for everyone with the same problem. You have sorted a problem out for your own website which is tweaked by you. It's great news for you but since I requested for help with a different problem I reckon you've gone a little bit off topic but never mind. Any addition to this string of complaints will help it up search results and promote the problem..... hopefully. Firefox have ignored this particular request for 4 months now.

Modified by TheOtherJon

terrace 2 solutions 108 answers

I tried BloHoJos fix>>Fix>

go to about:config in location bar (i.e. type about:config in the address bar)

search for browser.sessionstore.postdata

set value to -1 and for two days now i haven`t been troubled by nuisance "Document Expired".. Here`s hoping it stays that way. My computer is Windows XP and i`m using Firefox 10. I have downloaded Opera and find that OK except that the bookmarks don`t scroll like Firefox.

Question owner

The latest Firefox is 14. 10 used to work OK for me but I'm using Vista. It must pretty be slow browsing if you are using such an old version. You will have problems with XP eventually as Microsoft no longer support it.

Modified by TheOtherJon

terrace 2 solutions 108 answers

No, Firefox 10 is fast enough for me. XP is working great, but the main issue is>>Fix:

go to about:config in location bar

search for browser.sessionstore.postdata

set value to -1

Modified by terrace