X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How do i disable the download button timer when trying to download files. It takes 5 seconds before the button becomes available and not grayed out and I dont need it to be that long.

Posted

I Know its a setting to help prevent malicious software from downloading But I don't need it. Please tell me how to disable it.

I Know its a setting to help prevent malicious software from downloading But I don't need it. Please tell me how to disable it.

Chosen solution

The window content of that dialog should appear immediately, but there is a counter to set a two second timeout before enabling the OK button (security.dialog_enable_delay).


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Since forever

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • 5.0.61118.0
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • IE Tab Plug-in for Mozilla/Firefox
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

Borian 6 solutions 35 answers

Yes, there is a way to solve this.

Type about:config in your tab and search for

---> browser.download.manager.scanWhenDone

In default that is set as true in boolean, you should set it to false.


Now save the settings and restart firefox.

Yes, there is a way to solve this. Type '''about:config''' in your tab and search for ---> '''browser.download.manager.scanWhenDone''' In default that is set as true in boolean, you should set it to false. Now save the settings and restart firefox.

Modified by Borian

Question owner

OK I tried it and now the entire dialog box remains empty and unrendered with just the file name in the top for the 5 seconds; but when the box finally finishes rendering the button is available. still needs fixed.

OK I tried it and now the '''entire dialog box''' remains empty and unrendered with just the file name in the top for the 5 seconds; but when the box finally finishes rendering the button is available. still needs fixed.
cor-el
  • Top 10 Contributor
  • Moderator
17103 solutions 154430 answers

Chosen Solution

The window content of that dialog should appear immediately, but there is a counter to set a two second timeout before enabling the OK button (security.dialog_enable_delay).


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

The window content of that dialog should appear immediately, but there is a counter to set a two second timeout before enabling the OK button (security.dialog_enable_delay). *http://www.squarefree.com/2004/07/01/race-conditions-in-security-dialogs/ ---- Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode

Question owner

THANK FIREFOX FOR COR-EL!!! I undid Abyssal's advice and everything went back to the 5 sec delay and then Changed security.dialog_enable_delay from 2000 to 0 and it pops right up! I will Mark his post as helpfull and then do a moz backup so i never need to see this again.

THANK FIREFOX FOR COR-EL!!! I undid Abyssal's advice and everything went back to the 5 sec delay and then Changed security.dialog_enable_delay from 2000 to 0 and it pops right up! I will Mark his post as helpfull and then do a moz backup so i never need to see this again.