X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can't seem to get firefox to stop opening clicked links in new tabs, I want them to open in the same window - how do i fix this?

Posted

I reinstalled firefox recently and now every time I click a link it opens in a new tab instead of in the same tab. I would rather change it so it opens in a new tab only if I tell it to but for some reason that option is no longer in the options tab. How do I disable this function in the newer firefox?

Additional System Details

This happened

A few times a week

This started when...

I reinstalled firefox a few days ago

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.1 r102
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

More Information

Latest version of firefox, windows 7

mluna
  • Administrator
  • Moderator
66 solutions 461 answers

Hi,

Does this happen for all links? Some links require a new window, so you could set Firefox to change to the new tab immediately after it opens. But, for regular links it should stay in the same tab. If you can provide some more info, it would help us to advise you.

Thanks, Michelle

Ibai
  • Administrator
123 solutions 709 answers

Hi!

Make sure that in the Options Window, in the Tabs section, you have selected the options you want.

As far as I know, if the target of the link is a new window, you can't force it to open in the same tab.

Perhaps the TabMixPlus add-on offers that type of capability. It has been a long time since I don't use it.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You can inspect and adjust the browser.link.open_newwindow prefs on the about:config page.


Davec33 1 solutions 17 answers

I seemed that the default behavior before 10.0.1 was to open links in the same tab. 10.0.1 & 10.0.2 opens links in a new tab most of the time, but seemed to be a bit random ? Setting browser.link.open_newwindow to 1 (instead of 3) fixes it so that links open in the same tab, unless you right click the link and click "open in new tab".

Shouldn't there be a setup option that would select this function instead of having to modify "config".

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

If you had the option to open links in the same tab in previous Firefox versions then it must have been added by an extension. It a long time ago that Firefox had such a setting in its options (probably a Firefox 1 version).

Davec33 1 solutions 17 answers

Helpful Reply

I always used the default configuration of Firefox. I'm not saying I ever had an 'option' or an 'extension' to open links in the same tab - that's just the way it worked for me. Something changed in the past week, and I could only assume it was the Firefox update.

Davec33 1 solutions 17 answers

Very strange - today I reset "browser.link.open_newwindow " back to 3 , and all links still open in the same tab (which is the same default behavior that I had for years).

I also checked another computer running 10.0.2 and that one also opens links in the same tab.

So a bit of a mystery why suddenly links were opening in a new tab ??

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

browser.link.open_newwindow only affects links that specify a target window to open in.
You can use the pref to divert such links to the current tab or a new tab.
browser.link.open_newwindow.restriction does the same for JavaScript window.open() (onclick) links.
Normal links always open in the current tab unless you override that with a middle-click or Ctrl left-click (new tab) or Shift left-click (new window).

Davec33 1 solutions 17 answers

Something strange going on. Today links on webpage started again opening in a new tab. I have set browser.link.open_newwindow to 1 ( and will leave it set to that !). Browser was OK for 2 weeks (see my posts above) and I have made no changes to the system, so I have no idea what may be triggering that behavior.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

It is possible that the website has changed the code and is now specifying a target and in that case Firefox might open the link in a new tab. You can try to inspect the page code, but it is possible that it is a JavaScript link.

Davec33 1 solutions 17 answers

Thanks cor-el for the suggestion, but Firefox was opening a new tab for every link I clicked on in several different websites.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

jamie1963 0 solutions 2 answers

Helpful Reply

I agree with Dave33 entirely.... I have been using Firefox for years and know when it is acting up. The exact same thing happened to me. Thankfully changing to browser.link.open_new window to 1 instead of the default setting of 3 is the only thing that will correct the issue.

I have noticed that since Firefox is updating very quickly these days I think things are getting changed out so that the defaults we are used to are suddenly not defaults at all. To me this is a big time waster. I started my new version of 10 which seemed pretty stable and with auto updates selected in the options (I believe was by default) I soon got version 11 and now 12. I could not believe how fast the versions are changing. Is it just me or are these versions being pumped out before they are fully tested?

I am going to remove the auto update feature right now and just try to stay with what I have set in version 12 the way I am used to my browser working. Hopefully that will give me some peace of mind.

Another really bad thing that happened in version 12 that has never ever happened going all the way back to version 3. was the loss of all my last browsing session and no offer to restore. This has never happened until now. I lost 10 windows with at least 50 tabs. So from know on I will back it up to a folder just in case.

Rebeccarochelle22 0 solutions 1 answers

HELP!!!!!!!!!!!! The last week or so, Firefox has been opening everything in new tabs...search results, facebook games, pages, people, messages, etc. I have tried going to about:config and changed the numbers to 1, 2, and 3. Nothing has worked!!! This is getting very frustrating. I have tried re-downloading Firefox with NO help.

HELP ME PLEASE!!!!!!!!!

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Did you try Safe mode?

  • Help > Restart with Add-ons Disabled

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")