X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

After the update, pressing Enter no longer works to go to a URL, nor does it work in the Google Search bar thing.

Posted

Pretty much what the question says. I updated to the latest Firefox, and now this really irritating thing happens.... It happens lots of places too. Some specific things:

  • Clicking on the address bar at all does not bring up the little flashing cursor thing, and generally gives me no indication that I've actually clicked on the URL. Same with that little google search thing in the upper right.
  • Most frustratingly, when I press enter after putting in a URL, it won't even go to the site.
  • After getting annoyed at both of those things, I try to type in something on a website, and though the URL stays the same, it starts dropping down a lot of suggestions from my history.
  • Lastly, when I'm doing my crosswords on Washington Post and I switch to a different tab to type something on there, it doesn't switch my typing thing over - it stays on the crossword, typing things into that rather than into the typing field I clicked on to start typing in.

So, yeah, this is highly annoying, and I'd love for any help for these issues...

I did look at the FAQs, and they said something about the AVG SafeSearch thing causing one of my problems, but I don't have that extension, so it's definitely not that!

Chosen solution

You may be experiencing this bug that will be fixed in Firefox 10.0.1, possibly released later this week.

  • bug 718939 - Java applet causes text entry fields to become semi-unresponsive
Read this answer in context 1

Additional System Details

This happened

A few times a week

This started when...

I updated to the latest Firefox (Version 10.0)

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • Sling Player Plug-In for Mozilla
  • DivX VOD Helper Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.6
  • DivX Web Player version 2.0.3.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:10.0) Gecko/20100101 Firefox/10.0

More Information

Hasan 477 solutions 5600 answers

Perform the suggestions mentioned in the following articles:

Check and tell if its working.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

Chosen Solution

You may be experiencing this bug that will be fixed in Firefox 10.0.1, possibly released later this week.

  • bug 718939 - Java applet causes text entry fields to become semi-unresponsive

Modified by cor-el

mlzarathustra 0 solutions 11 answers

Not solved.

"Help/About" tells me version 10.0.1 but Enter just STOPPED working in my URL bar, after the automatic update. It was working before. It also fails to load items in the dropdown history.

There is no java applet on the page: it is a blank page.

The arrow key to the right still works, thankfully. Also, Enter still works in the search field.

Thanks,

 -= miles =-
Hasan 477 solutions 5600 answers

Helpful Reply

Check and tell if its working.

mlzarathustra 0 solutions 11 answers

I tried disabling extensions and it started working again. I don't have time to isolate which extension is causing the problem right now, but should be able to sometime in the next few days.

Thanks!

 -= miles =-
cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96651 answers

Helpful Reply

The AVG Safe Search extension can cause problems with the Enter key not working in the location bar.

mlzarathustra 0 solutions 11 answers

Yes, disabling AVG Safe Search re-enabled the Enter key for me too.

Thank you !

 -= miles =-
dharmendar22 0 solutions 2 answers

Follow these steps for the controls to start working:


  1. Start > Programs > Mozilla Firefox > Mozilla Firefox
  2. Find the “Tools” menu at the top of the browser window and select “Add-ons”.
  3. Click on the “Extensions” icon to make sure you’re in the correct option menu.
  4. Locate “AVG Safe Search” and click on the containing line to highlight and select the add-on.
  5. Click the “Disable” button and close the Add-ons window.
  6. Close down any Firefox windows you may have open.
  7. That’s It – You’re Done!