X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 10/11 often not responding, scripts taking too long, error log FULL

Ron
Posted

I use Firefox constantly. I'm now on version 11 but not much has changed. I've been forced to disable most every plugin and extension trying to troubleshoot my issues and I still have the same problems. No matter what site(s) I'm on after 2 or 3 clicks I get the running circle and the browser freezes. If I click again, I get the "Not Responding" message in the top bar. Most of the time it recovers within 30 seconds to 2 minutes and I can continue. Very often the whole thing freezes with no message but before long I get : Script: resource://gre/modules/XPCOMUtils.jsm:331 or Script: resource:///components/nsPrompter.js:466 and neither seems to be attached to any plugin or extension. No matter which version I've used and no matter what site I'm on this happens. I've decreased my allowed scripts to run time to "20" and disabled everything including hardware acceleration. ALSO, about 50% of the time when I'm editing my own site, all of a sudden it becomes VERY sluggish and takes too much time to do anything. When this happens I've switched right over to IE9 and have none of these issues. I also have an error log as long as your arm. Troubleshooting information is below. Please help!

Chosen solution

dom.max_script_run_time = 20 - is the default setting
But that isn't going to cause a "not responding" message due to a slow script.

My advice is to try a new Profile (don't delete your current Profile) and see if there is any improvement.

http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

Read this answer in context 3

Additional System Details

This happened

A few times a week

This started when...

Since the beginning when I switched to Firefox

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Application Basics
Name
Firefox
Version
11.0
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
ShowIP
1.0
true
{3e9bb2a7-62ca-4efa-a4e6-f6f6168a652d}
Swoosty SEO Tools
2.0.2
true
{23ad39a3-36e7-4d8e-92d2-ba116ee32c45}
Vertical Toolbar
0.2.6
true
verticaltoolbar@xuldev.org
Web Developer
1.1.9
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
AVG Safe Search
12.0.0.1912
false
{1E73965B-8B48-48be-9C8D-68B920ABC1C4}
CodeBurner for Firebug
1.6
false
firebug@tools.sitepoint.com
Firebug
1.9.1
false
firebug@software.joehewitt.com
Html Validator
0.9.5.1
false
{3b56bcc7-54e5-44a2-9b44-66c3ef58c13e}
Page Speed
1.12.0.2
false
{e3f6c2cc-d8db-498c-af6c-499fb211db97}
Pixel Perfect
1.7.1
false
pixelperfectplugin@openhouseconcepts.com
Roboform Toolbar for Firefox
7.7.0
false
{22119944-ED35-4ab1-910B-E619EA06A115}
socialmonkee
2.0
false
sm@submitter.net
Test Pilot
1.2
false
testpilot@labs.mozilla.com
Thunderbird Biff
2.3.3
false
{aee74dd0-6dc9-11db-9fe1-0800200c9a66}
YSlow
3.0.9
false
yslow@yahoo-inc.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
www.optimum.net
browser.startup.homepage_override.buildID
20120201153158
browser.startup.homepage_override.mstone
rv:11.0
dom.max_script_run_time
20
extensions.lastAppVersion
11.0
general.autoScroll
false
network.cookie.prefsMigrated
true
network.protocol-handler.warn-external.dnupdate
false
places.database.lastMaintenance
1328325634
places.history.expiration.transient_current_max_pages
26558
places.history.expiration.transient_optimal_database_size
42492558
privacy.clearOnShutdown.offlineApps
true
privacy.clearOnShutdown.siteSettings
true
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.sanitizeOnShutdown
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Graphics Media Accelerator 3150
Vendor ID
0x8086
Device ID
0xa011
Adapter RAM
Unknown
Adapter Drivers
igdumdx32
Driver Version
8.14.10.2230
Driver Date
10-24-2010
Direct2D Enabled
Blocked for your graphics driver version.
DirectWrite Enabled
false (6.1.7601.17563)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator 3150) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)
GPU Accelerated Windows
0

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24440 answers

Chosen Solution

dom.max_script_run_time = 20 - is the default setting
But that isn't going to cause a "not responding" message due to a slow script.

My advice is to try a new Profile (don't delete your current Profile) and see if there is any improvement.

http://kb.mozillazine.org/Creating_a_new_Firefox_profile_on_Windows

Question owner

Thank you so much for your detailed reply. I did exactly what you said and now we'll see how it goes.

I'm going to go ahead and click "Solved" and if I still have trouble I'll re-post but hopefully it won't be necessary. Thanks again! Ron

wuerstchen 0 solutions 1 answers

>Firefox 10/11 often not responding, scripts taking too long, error log FULL< It's the same as thunderbird!