X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to use Translate This! 1.8

Posted

I installed Translate This! 1.8, but no icon has appeared in my add-ons toolbar and there is no entry in the Tools menu after restarting Firefox. If I select text and right click, the menu does not list translate either. Under View>Toolbars>Customize, there is no icon shown for the add-on. So how do I use this add-on? Where is it? I am using Firefox 10.

Chosen solution

Ok, this is weird. I rebooted again and now it is working. Why I had to reboot twice and reopen Firefox yet again before Translate 1.8 would work is a mystery. Must be the phase of the moon or something.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Autofill Engine for Gecko and Webkit-based web browsers
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • Google Updater pluginhttp://pack.google.com/
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Shockwave Flash 10.3 r183
  • 4.0.60831.0
  • CouponNetwork Coupon Activator
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0

More Information

Translate This!1.8truejid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack

JayGarcia
  • Moderator
30 solutions 273 answers

Helpful Reply

Hilite a word, sentence or paragraph(s), then right-click and select "Translate Selection" in the context menu.

Helpful Reply

As I mentioned in the original post, when I select text and right click, there is no "translate" in the menu.

JayGarcia
  • Moderator
30 solutions 273 answers

Running FF 10 and Translate 1.8 and at the bottom of the right-click context menu is "Translate This - Selection". It only appears in the menu if something is hilited. No idea at the moment why this isn't working for you. Try it on the text in one of the replies here.

Chosen Solution

Ok, this is weird. I rebooted again and now it is working. Why I had to reboot twice and reopen Firefox yet again before Translate 1.8 would work is a mystery. Must be the phase of the moon or something.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96738 answers

Try to uninstall and reinstall the extension.

You may also have other extension interfering, so you can try to disable all other extensions to see if that helps.