Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with youtube and other video websites

  • 21 replies
  • 127 have this problem
  • 586 views
  • Last reply by agrash

more options

I have a problem with youtube and other video websites:

Everything is up to date (flash, FF, my plug ins..) but i keep getting freezes when the video loads. I can hear sound but i can only see the first frame of the video.

I've reinstalled flash/firefox or tried updating them again for about 4 times now and my cookies/cache has also been errased which i usually don't do. If i enter FF's safe mode it also freezes.

I hope someone could help out, i've searched for answer on google before and tried everything i saw but it didn't helped.

grts, agrash

Chosen solution

I had the same problem, I uninstalled the flash player plug-in (Adobe Flash Player 11.0.1. 152) and the problem is solved. I installed the plug-in again and the problem came back. So at this moment I haven't got flas Player plu-in, but I haven't got problem too. I hope I will not find other problem, but it seems everything is OK.

Read this answer in context 👍 2

All Replies (20)

more options

Hello agrash, take a look on this: https://support.mozilla.org/en-US/questions/912044#answer-298068 If it works, please warn us :) Gmgomess

more options

Hmm, so that person had a conflicting plug in. Problem is that whenever i enter firefoxes safe mode which disables every plug in, i still have the youtube freeze/crash

more options

A possible cause is security software (firewall) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

more options

Thanks for the help so far but my avg firewall did not restrict anything up untill now, but i added firefox and i followed those steps for my built in regular firewall and it did not help either.

In all these years that i've been using firefox, i've never encountered any problems up untill now :/

more options

sry for double posting

I don't know if this is helpfull or not, but i reinstalled IE (damn, its slow & ugly ^^), then i needed to reinstall my flash and afterworks youtube worked just fine with IE

Modified by agrash

more options

I am having exactly same problem. First I had problems with adobe reader because all pdf's did hang up firefox. After updating reader to v.10 and plugins for firefox it started to work. I dont know what to do to make youtube videos to work...

more options

I noticed something on my own.

When i uninstalled flash with a program ("uninstall_flash_player_64bit.exe") & reinstall the "latest" flash from the website, i can play video's again on youtube and other websites.

However, on some websites i don't get a video but a message instead that i don't have the latest update and that i have to update it, but when i do that i get the same problem again. At least now the youtube video's work even though i get a message below the video saying something that an update for flash player 10 could result in beter quality and the firefox missing plug-in installer above is begging me to update it constantly


So bassicly according to my experience, its flash which is causing the problem.

Modified by agrash

more options

Did anyone found a solution yet?

more options

Yeah I've just got same problem ... worst of all I've reinstalled everything but still having the same prob.

Modified by milejuric67

more options

Chosen Solution

I had the same problem, I uninstalled the flash player plug-in (Adobe Flash Player 11.0.1. 152) and the problem is solved. I installed the plug-in again and the problem came back. So at this moment I haven't got flas Player plu-in, but I haven't got problem too. I hope I will not find other problem, but it seems everything is OK.

more options

Thanks, I guess your "solution" works for now. Youtube worked fine even without the flash player which i first thought it wouldn't.

I hope an update will come for this in the future because i think some website will require flash to play their formats.

more options

Flash player has an uninstall procedure http://kb2.adobe.com/cps/141/tn_14157.html. Is this what you did to uninstall?

I have tried uninstalling and reinstalling to no avail but don't see how Flash videos play without it?

more options

You have to download the 32/64 bit uninstaller but you are right:

Yesterday, i only tested out youtube and that seemed to work, but most other website like gamespot doesn't want to load the video's so i reinstalled flash again and to watch youtube video's i use "internet explorer".


At least some websites that i dailly watch work now when flash is installed (like gametrailers, cinemassacre, escapist)

more options

I download the Adobe Flash Player 10 and everything is working well. The other video homepage working too. http://kb2.adobe.com/cps/142/tn_14266.html

more options

Really? Which one? I tried downloading the "Flash Player 10 (157 MB)" that seemed to be an archive file containing several version which a few i also tried but with the same results

more options

Do you use Avira or Ask toolbar? They may be involved in breaking plugins.

more options

Nope, a couple of months ago, i had ask toolbar installed for some reason and i immediatly uninstalled it because it was useless to me

more options

I don't know what or why but so far everything seems to be in order again. I should have the latest updates en everythings working fine again. This has made my day ^^

Thanks to everyone for helping me out

more options

I would not say this problem has been solved ...

  1. 1
  2. 2