Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop Firefox from creating desktop icon every time it starts

  • 6 replies
  • 4 have this problem
  • 6 views
  • Last reply by Nuncio

more options

Why does Firefox create a desktop icon every time it starts and then ask if you want it to be the default browser? Every time I answer "Yes" but it keeps asking anyway. How can I stop this behavior?

Why does Firefox create a desktop icon every time it starts and then ask if you want it to be the default browser? Every time I answer "Yes" but it keeps asking anyway. How can I stop this behavior?

All Replies (6)

more options

See:

Are the profiles.ini file and the Firefox profile folder still present?

Which security software (firewall, anti-virus) do you have?
Does it has virtualization features?

more options

This is a fresh install. No changes made. Every time I open Firefox it asks to be made the default browser, even though it already is. I don't want to turn off the check because other programs will make a different browser the default without asking (e.g. MS Office will make IE the default).

more options

My company uses McAffee antivirus. I know nothing about virtualization, which implies it doesnt have it since I've been through all the settings.

Also note - I've seen this behavior since Firefox 7.0 on every computer (Windows and Linux) regardless of what anti-virus is running (or not).

more options

After a complete uninstall and then a clean install, it's still happening. Firefox just can't seem to remember that it's the default browser and it keeps writing icons to the desktop.

Modified by Nuncio

more options

What registry setting is Firefox checking to find it's not the default browser? I've searched the registry, but there seems to be no "default browser" setting. BTW - Firefox already *is* the default browser because it's the program that gets opened when I double-click on an .htm or .html file.

Deleting profile.ini from AppData/Mozilla won't work because then Firefox will create a new profile on startup (not what I want)

There is no User.js file to edit

Modified by Nuncio

more options

.....

Modified by Nuncio