X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why are web pages in firefox incomplete with missing photos, text and symbols?

Posted

I am using firefox as it came (without making any changes). I have no add ons' either. Web pages are incomplete.(1) Specially where photos are concerned, only some of them appear and the rest are blank. The blank ones display the text only, that come at the bottom of the photo. (2) Sometimes all photos in the web page are missing but the text under each photo appears! (3) When using e-mail, the font tool bar is a ribbon of blank boxes, with the symbols (for 'underline', 'bold' etc) all missing. Some other boxes on the e-mail page, like 'delete' 'spam' etc are empty boxes with the words inside them missing. This is severely restricting my use of Firefox which is my favorite one. Anxiously awaiting advice. - Regards---- (4) I just noticed this. Even here on this very page that I am posting this question, right above where I am typing, the font tool bar is blank (completely empty). When I hover the mouse pointer in that empty space above this box, screen tips (such as 'bold', 'italic' etc.) appear next to the mouse pointer. When the pointer is moved away from the empty area on top of the box, where the font tool bar usually is, the screen tips disappear. This happens on the e-mail pages as well. (5) In the text that often appear on the left or right of a web page, as you see on the right of this question box, the lines overlap on top of one another. Only part of the message can be read.

Modified by Christine

Chosen solution

You're welcome.

If you have increased the minimum font size then try the default setting "none" as a (too) high value can cause issues.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.

Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

From the first day that I downloaded firefox

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_30 for Mozilla browsers
  • Shockwave Flash 11.1 r102
  • 5.0.61118.0
  • Google Update
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

More Information

No such information. I have not tried to do anything.

FunKing 0 solutions 2 answers

If no images were loading at all, I'd suggest you to see if in Tools -> Options -> Content the "Load images automatically" is checked.

Have you tried refreshing the pages with problems (by pressing F5)? Does it help at all?

Just to be sure that the problem is with the browser, have you tried to use another one (Google Chrome, Safari, Opera, etc.)?

Question owner

Hello FunKing, Thank you for your post.

  • "load images automatically" has always been selected.
  • Yes I have tried refreshing the page but it does not change anything.
  • Along with firefox I have Google Chrome and IE both and there is absolutely no problem with either of them.

I forgot to mention that my OS is Windows 7 Home Premium.

I am using the firefox browser to post this reply. I just opened this page also on Google Chrome while I am typing this and it opened with everything, including the font tool bar (ribbon) which is missing here in firefox. For me Firefox is the best browser. If Only I can solve this problem! About a month ago I completely reinstalled firefox because of this but the problem still remains.

Regards

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Helpful Reply

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

You can use these steps to check if images are blocked:

  • Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
  • Go to the Media tab of the "Tools > Page Info" window.
  • Select the first image link and scroll down through the list with the Down arrow key.
  • If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

See also:

Helpful Reply

Hello cor-el,

I allowed "pages to choose their own colours" and that helped to load images and it also restored the missing  Font Tool Bar. Many thanks for that.

(1) The problem of some of the text (usually a few lines at the top of the page) overlapping on to another text group nearby (above or below), remains. (2) Also on top of the page, some letters and symbols tend to go partially under a photo or an image, just below the letters or symbols. (3) In the links that appear on the right of the page, in a vertical band, A line or two is missing from every caption(from the end of the short sentence). Therefore only the first few words of the link can be read.

Hope you can solve this too. Then my browser will be perfect!

Thank you, Best regards.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Chosen Solution

You're welcome.

If you have increased the minimum font size then try the default setting "none" as a (too) high value can cause issues.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow websites to choose their fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but use an extension to set the default page zoom to prevent issues with overlapping text.

Question owner

Hello cor-el,

That did it. Thank you for helping me in this. It was both those things.

The fonts selected were 'Serif', 'Times New Roman', 'Arial', and 'Courier New'. I think they are Firefox default selections that come with the browser. The moment I allowed pages to chose their own fonts the overlapping vanished.

I had selected a minimum font size. When it was de-selected as you advised, the text became very clear. Before I did that, the text-specially small letters-seemed some what raggedy. 

Now I have a beautiful Firefox! Thank you and best wishes.

SkipRinPerth 0 solutions 3 answers

Windows XP solution:

  • If this page looks like attached image then proceed (note the toolbar missing bits and the black box to the left)
  • Open control panel, select Accessibility Options, select Display tab, ensure "Use High Contrast" option is NOT TICKED. If it was ticked select "apply", wait for Windows message "please wait" to disappear, refresh page in browser, and the problem disappears. (If it was not on try turning it on, press apply, wait, then untick to turn "off" again and reapply. This is harmless and will make sure it is really "off".)

Explanation:

  • The issue described is EXACTLY what you would seen if you enabled the Windows XP Accessibility "High contrast" option and your went into Control Panel, Display setting and reapplied your windows theme. The latter will turn off most of the Disability features changes but it is actually on giving you a shading issue (=missing "images") around the tool bar on this page (as mentioned by the orig poster) as well as shading done typically near or in menu options in other parts of web pages. It is not obvious for example other browsers like Opera will display this page correctly and this makes you think it is a Firefox a browser issue. This should be the first thing on your check list as it is a system wide Operating system setting.


  • Adjustments to use large fonts, and/or change the DPI settings in "Display" settings in control panel may be a factor as I was doing that too when I came across this but I am not going to retest that too. Switch them back to the original settings if you were playing with them :-)
  • Poster "cor-el" mentions "High Contrast" and link describes the same solution in [http://kb.mozillazine.org/Website_colors_are_wrong] but readers may miss that which is why I wrote this reply, with an image attached, to help other Win XP platform users.

Modified by SkipRinPerth