Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not saving one of my email addresses and password (it is saving three of four). It isn't asking me if I want to save it, and there's no "Save" command under tools. I have a Mac OS10.4.11.

  • 4 replies
  • 5 have this problem
  • 791 views
  • Last reply by cor-el

more options

I have four accounts with btes.tv (served by WorldClient). Firefox asked if I wanted to save my password with three of the accounts, but it hasn't asked with the fourth. I have re-done preferences/security/save passwords several times to no avail. I don 't know what else to do.

Chosen solution

Saving the name and password to log in to a server doesn't always work. For instance it doesn't work with Hotmail (live.com) because Hotmail uses JavaScript to generate the login form.

Websites may also be using autocomplete=off to prevent Firefox from saving the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.

Read this answer in context 👍 0

All Replies (4)

more options

Make sure that you do not run Firefox in permanent Private Browsing mode.

To see all History and Cookie settings, choose:

  • Firefox > Preferences > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Automatically start Firefox in a private browsing session"

See also:

more options

I'm running Windows XP Am using Mozilla Firefox to get emails. I want to save my email address and password and the system will not let me do it. I want to avoid typing my email address and password. HELP

more options

Chosen Solution

Saving the name and password to log in to a server doesn't always work. For instance it doesn't work with Hotmail (live.com) because Hotmail uses JavaScript to generate the login form.

Websites may also be using autocomplete=off to prevent Firefox from saving the name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.