Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I downloaded Firefox, but on main page is another website.

  • 2 replies
  • 19 have this problem
  • 3 views
  • Last reply by Judy0417

more options

When I downloaded Firefox , it went to AVG. I deleted that, now it goes to SweetIM Search. I set up AT&T as my homepage, but whenI click the icon on my desktop, it goes to SweetIm Search instead of AT&T.

How do I correct that?

Chosen solution

Look in Add/Remove Programs from Control Panel to remove the program and related elements if it is there.

If you have SweetIM toolbar in extensions select-it and unistall-it

Go to your search engines and delete the SweetIm search engine from the list.

type in the address bar about:config

then press the button i'll be careful i promise

then type in the bar SweetIM

on each and every SweetIM appear, click reset

exit firefox and restart-it.


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Read this answer in context 👍 3

All Replies (2)

more options

Chosen Solution

Look in Add/Remove Programs from Control Panel to remove the program and related elements if it is there.

If you have SweetIM toolbar in extensions select-it and unistall-it

Go to your search engines and delete the SweetIm search engine from the list.

type in the address bar about:config

then press the button i'll be careful i promise

then type in the bar SweetIM

on each and every SweetIM appear, click reset

exit firefox and restart-it.


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

more options

Thanks. That worked.