X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why zooming in Windows 7 changed also the font size in Firefox?

Posted

I have win7 and I tried to change the text/icon size from the windows to 125%. It also affected everything in firefox (text in tabs, address bar etc., not the text on the pages which you can change with ctrl +/-).I changed it back to 100% and everything became really tiny. How can I make it standard size no matter what zoom I use in windows itself.

Have you had experience from this kind of problem before?

Sincerely Antti

Chosen solution

You can try this:

  1. Open the Properties of the Firefox desktop shortcut (right-click: Properties)
  2. Go to the Compatibilities tab
  3. Put a mark before "Disable display scaling on high DPI settings" to see if that has effect.

You can use an extension to set a default font size and page zoom on web pages.

Use this for the user interface:

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

25.11.2011

Installed Plug-ins

  • Google Update
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 4.0.60831.0
  • NPWLPG
  • Zeon PDF Plugin For Mozilla
  • Shockwave Flash 10.0 r32

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

Application Basics
Name
Firefox
Version
8.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Extensions
Name
Version
Enabled
ID
Suomen kielen oikoluku
2.0
true
fi@dictionaries.addons.mozilla.org
Norton Toolbar
2011.7.2.3
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Symantec IPS
3.2
false
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Vuze Remote Community Toolbar
3.8.1.0
false
{ba14329e-9550-4989-b3f2-9732e92d17cc}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20111120135848
browser.startup.homepage_override.mstone
rv:8.0.1
browser.tabs.warnOnClose
false
extensions.lastAppVersion
8.0.1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1322164429
places.history.expiration.transient_current_max_pages
256979
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTX 560M
Vendor ID
10de
Device ID
1251
Adapter RAM
2048
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.8562
Driver Date
10-15-2011
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
Unknown
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows
1/1 Direct3D 10

finitarry 157 solutions 2178 answers

How did you zoom the entire interface along with the contents?

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Chosen Solution

You can try this:

  1. Open the Properties of the Firefox desktop shortcut (right-click: Properties)
  2. Go to the Compatibilities tab
  3. Put a mark before "Disable display scaling on high DPI settings" to see if that has effect.

You can use an extension to set a default font size and page zoom on web pages.

Use this for the user interface:

Question owner

I got it as I wished with Theme Font & Size Changer. Other ides that cor-el introduced didn't help for this problem.

Question owner

finitarry: I used windows own zoom ability for the text and icons in windows desktop. Firefox was only unwanted victim of the effect. Problem was that I could not reverse it to the original size.

You can see in those pictures the top bar/text size as it was before the solution.

Modified by Adian

JosephusFlavius 0 solutions 4 answers

I just had the VERY same experience, also caused by the Win 7 font size change, which was subsequently restored to its original settings, and here, too, only FF 11 was affected by the change...

I'm reluctant to add yet another add-on. Are there no settings in the about:config page that can be changed to control this?

Following an advice on this forum, I tried changing the following on the about:config --

layout.css.devPixelsPerPx

from 1.0 to larger. This changes the spacing of the *areas* of the tool-bars and the Bookmarks column, but not the font size. Is there no settings that controls font size???