X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Starting Firefox, this message appears (I have a screen shot available) Java Script Application Exc in ev handl: TypeError: this.o.root.enable is not a function

Posted

26 Sept. 2011 I get the dialog box mentioned in the Question when I click to open Firefox. I click OK button in dialog box and Firefox opens/launches. I installed Java around the same time I installed Firefox. I installed Firefox and Java within the last seven days. I have a screen shot of the dialog box.

Chosen solution

This issue can be caused by the McAfee Site Advisor extension


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

I began using Firefox.

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Bing Bar
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • BlackBerry WebSL Browser Plug-In
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Chosen Solution

This issue can be caused by the McAfee Site Advisor extension


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

Firstly I disabled McAfee SiteAdvisor extension found in Extensions in the Add-ons tab. This was a solution to the issue. Problem solved!

Next, I disabled the McAfee ScriptScan for Firefox 14.4.0 as well. Just for the heck of it.

Thank you for the help!

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

You're welcome