X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox check compatiblity of add-ons every time I open it? Why am I then directed to Mozilla home page? Why did you not answer this question the last time I asked it?

Posted

This is annoying. Iwant to start using a less troublesome browser but I like Firefox otherwise.

Chosen solution

Have you tried Reset Firefox preferences to troubleshoot and fix problems and deleting the extensions.<*> files (extensions.sqlite, extensions.ini,etc.) in the Firefox profile folder as cor-el suggested?

If you want to try "dynamite", try steps 7-8 of the Troubleshoot and diagnose Firefox problems article: a clean reinstall of Firefox (remove the Firefox.app from the Applications folder and download (with Safari or another browser and install the latest Firefox version from www.mozilla.com ) and finally create a new Firefox profile . If a new Firefox profile fixes it, you can then transfer your old profile data to the new profile.

Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox upgraded to the newest version.

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • 4.0.60531.0
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

I'm, sorry no one answered your question from last week, https://support.mozilla.com/en-US/questions/875786

Maybe no one had an answer? I'm not sure what is happening but maybe this will help:

Re-enable add-ons that were disabled when updating Firefox has information about add-on compatibility checking after updating Firefox. I'm not sure why this check would happen every time you open Firefox. What extensions do you have installed and are they disabled or enabled?

You can check by clicking the orange Firefox button, clicking Add-ons and looking in the Extensions list. You can also open the Firefox Help menu and select Troubleshooting Information . Your extensions will be listed and you can copy that information here.

Modified by AliceWyman

Question owner

Hi, Alice,

My enabled ad-ons are AdBan2.1.0, Invisible Hand 3.3.0, IO bit toolbar 4.6, Last Pass 1.74.0, McAfee Script Scan for Firefox 14.4.0.

Disabled are WOT 20110704, Java Console, McAfee Site Advisor, Skype extension for Firefox 4.4.0.5198, Widgi Toolbar Platform 4.6

No other Firefox update has done this, and it happens every time I open the browser. I searched "Help" and could find no solutions. Thanks for your assistance. Kathy

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Hi, Kathy,

Try disabling your enabled extensions one by one, starting with McAfee Script Scan for Firefox 14.4.0 and restart Firefox, to see if one of them is causing the problem.

Does that help?

Question owner

Hi, Alice,

I disabled every one of them, but Firefox keeps checking and sending me to the homepage. What next? Thanks, Kathy

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

See:

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (extensions.sqlite, extensions.ini, extensions.cache, extensions.rdf) and compatibility.ini in the Firefox profile folder to reset the extensions registry.
New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update.

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

In case it helps, you could open the Troubleshooting Information page from the Help menu and copy the contents here. See Use the Troubleshooting Information page to help fix Firefox issues.

I'm not really sure what is happening. Do you see a Firefox Updated tab, in addition to your normal home page tab, each time you start Firefox? That could mean a corrupt or locked preferences file (see How to fix preferences that won't save and Reset Firefox preferences to troubleshoot and fix problems).

Before taking any more shots in the dark, though, I think you should go through the steps outlined in the Troubleshoot and diagnose Firefox problems article.

Sorry, I didn't notice cor-el's post before replying. Try his suggestions first.

Modified by AliceWyman

Question owner

Hello, Cor-el (and Alice,)

I disabled the extensions as directed. Firefox continues to check add-ons when I start it. It also opens the Mozilla page along with my homepage. Should I consider dynamite? Thanks. Kathy

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Chosen Solution

Have you tried Reset Firefox preferences to troubleshoot and fix problems and deleting the extensions.<*> files (extensions.sqlite, extensions.ini,etc.) in the Firefox profile folder as cor-el suggested?

If you want to try "dynamite", try steps 7-8 of the Troubleshoot and diagnose Firefox problems article: a clean reinstall of Firefox (remove the Firefox.app from the Applications folder and download (with Safari or another browser and install the latest Firefox version from www.mozilla.com ) and finally create a new Firefox profile . If a new Firefox profile fixes it, you can then transfer your old profile data to the new profile.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Did you try the solutions for Preferences not saved by deleting the file(s) prefs.js and possible numbered files prefs-##.js ?



(I hadn't noticed the last post by Alice, so follow her advice first to avoid confusion)

Modified by cor-el

Question owner

Thanks, Alice,

I reinstalled Firefox, but that didn't work. However, when I created a new profile and deleted the old one the problem was gone. Your dynamite worked!

So glad to be rid of that annoyance. Thanks again. Kathy-the-Grateful

AliceWyman
  • Top 25 Contributor
  • Moderator
191 solutions 1967 answers

Hey, that's great! Thanks for posting back. I marked my solution as solving it.

A new Firefox profile fixes lots of problems. It starts you off with a clean slate by "blowing away" the old Firefox extensions, user data, and preference settings ... so that would have fixed problems caused by the associated files.

By the way, if you deleted your old Firefox profile in the Profile Manager and chose the option that doesn't delete the files, you can recover some of that old profile data, like bookmarks and history or passwords, to the new profile by following these instructions: Recovering important data from an old profile.

Modified by AliceWyman

Question owner

Alice is a genius! Hi. I didn't save any of my old bookmarks, or anything, because I never use them. As things come up I'll re-mark them. Thank again for solving this.

                                                                       Forever in your debt,  Kathy
V3King 0 solutions 3 answers

Helpful Reply

It's Problem With Your Profile.. Just Visit http://www.maherhackers.com/solved-firefox-checking-add-on-compatibility-every-time/ For Solution.