X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

dont wont yahoo search engine

Posted

After installing yahoo messenger it installed its search engine as default! how ever i have removed this add on and the Google search engine is now displayed on starting up firefox, but when i do a search it puts me back on to the yahoo web site search engine is there a way to fix this???

Chosen solution

keyword.URL in your about:config is case sensitive. Refer to the Location Bar external search link for 3 different values that were supplied for Firefox.
 

You could could make up your own modified keyword.URL or use a different search engine.
 

Read this answer in context 1

Additional System Details

Sites Affected

http://yahoo.com.au

Installed Plug-ins

  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r183
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

David McRitchie 321 solutions 3089 answers

Helpful Reply

When you do a search from where

  1. search bar
  2. location bar
  3. default home page -- 'about:home

Remove the Yahoo Toolbar

  1. "Ctrl+Shift+A" (Add-ons Manager)
  2. Select Puzzle piece on left-side for Extensions List
  3. Find "Yahoo Toolbar" and click on "Uninstall" button, and restart Firefox. (if you really need to keep the Yahoo toolbar, you can hide the toolbar instead with customize, and still change all the search defaults as below)

Then to fix the default search engine used at the Location Bar, change the value of keyword.URL in about:config to one of the values shown in Location Bar search at MozillaZine.

  1. type in about:config into the location bar (in a new tab)
  2. if the warning message nonsense comes up uncheck the box before dismissing the dialog message
  3. filter on keyword
  4. right-click on keyword.URL and choose "modify" then paste in the Google search engine string of your choice.
  5. filter on defaulturl
  6. right-click on browser.search.defaulturl (if it exists)and again choose "modify" then paste in the Google search engine string of your choice.
  7. filter on ytff
  8. right-click on yahoo.ytff.search.popup_src (if it exists) and again choose "modify" then paste in the Google search engine string of your choice, if adventurous might see if "reset" would remove and see if gone in next session (well not for those keeping the extension).

--used in https://support.mozilla.com/en-US/questions/850287

Avoiding the problems: Many software installations contain additional baggage known as crapware. The Yahoo Toolbar is packaged with Java picture

More information on ask.com, Yahoo Toolbars which involve extensions, not just changes to the home page.


Please mark "Solved" one answer that will best help others with a similar problem -- hope this was it.


You can make Firefox 6.0.2 look like Firefox 3.6.*, see numbered items 1-10 in the following topic Fix Firefox 4.0 toolbar user interface, problems (Make Firefox 4.0 thru 8.0, look like 3.6). Whether or not you make changes, you should be aware of what has changed and what you have to do to use changed or missing features.

Elvis1967 0 solutions 1 answers

Helpful Reply

I have tried this numerous times but as soon as I shut Firefox Yahoo re-appears. I will not use it out of principle now, they are bullies. I am close to removing Firefox & using Chrome just to get away from Yahoo search crap.

Modified by Elvis1967

krwebb 0 solutions 1 answers

I tried this & got rid of yahoo (yay) but I put in the search text http://www.google.com/search?ie=UTF-8&oe=UTF-8&q= and now it goes to google search without searching for the text I have typed in the location bar. Can someone please paste the text to use? Thanks!

the confused guy 0 solutions 1 answers

http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=

put that instead for the keyord.url option, should work out fine now

David McRitchie 321 solutions 3089 answers

Chosen Solution

keyword.URL in your about:config is case sensitive. Refer to the Location Bar external search link for 3 different values that were supplied for Firefox.
 

You could could make up your own modified keyword.URL or use a different search engine.
 

ron525 0 solutions 1 answers

Have tried this numerous times and still have yahoo controling my firefox start page

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

MontyDawg 0 solutions 2 answers

Thanks dmcritchie. Your solution appears to be working for me. Much appreciated! Dave