Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On clearing recent history, active logins are cleared too , but I have this box unticked

  • 8 replies
  • 10 have this problem
  • Last reply by annem

more options

When I go to tools - clear recent history, browsing, forms, cache and cookies are all ticked. I deliberately unticked the active logins box because I did not want these cleared, but they are cleared anyway which is a real nuisance. This did not happen with previous versions of Firefox

All Replies (8)

more options

Active Logins are connections to servers that use (basic) authentication. That is usually the case if you connect to a secure FTP server. A regular secure connection to a server uses cookies to authenticate you. You need to exclude cookies from clearing to make sites remember you, but make an allow exception for those sites and let the other cookies expire if you close Firefox.

more options

Use only the Clear Cache option in the Recent Clear History feature if you want websites to keep your settings.

more options

Thank you for your help, excluding cookies did solve the problem, but I have searched in vain for a way to keep just the cookies I want, and so be able to delete the rest. Could you help further and tell me how to do this?

more options

Deleting Cookies

Check and tell if its working.

more options

Thank you, I know how to delete cookies, I would like to know how to keep the ones I want

more options

-> click Firefox button and click Options -> Privacy -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> click Exceptions... button -> type the addresses of the websites on which you want to Allow Cookies to be stored e.g. , , , , , , , , , , etc. -> click Allow for each, One by One 4a) Accept Third-party Cookies -> Keep Until : select They Expire


-> Click OK on Options window -> Restart Firefox

Check and tell if its working.

-> When you use Clear Recent History feature, DO NOT select Cookies, Forms and Search History, Active Logins, Site Preferences

-> If you use Privacy Cleanup softwares like CCleaner, DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

more options

Let all cookies expire when you close Firefox.

  • Tools > Options > Privacy > Cookies: "Keep until": "I close Firefox"

Make an Allow exception for the ones that you want to keep.

  • Tools > Options > Privacy > Cookies: "Exceptions"

You can inspect and modify the permissions for the domain in the current tab in "Tools > Page Info > Permissions"

Make sure that you do not use Delete browsing, search and download history on Firefox to clear the "Cookies" and the "Site Preferences" (Site Preferences includes the cookie exceptions)

Clearing cookies (e.g. via Clear Recent History) will remove all specified (selected) cookies including cookies that have an allow exception.

See also:

more options

Thanks for your help, I think I'll use CC Cleaner to clear out the dross.

I do not understand why there is an option to uncheck active logins, if it does not actually work - yes I know it is to do with the cookies, which I have supposedly saved from extinction