X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When opening Youtube, I get a window with message "Error: Div is null". How can this be solved?

Posted

I don't know when it happend first, but when I open a video on youtube with Firefox 6.xx, I always get a window (title "Javascript Application") with the message "Error: Div is null".

I tried upgrading to FF 7.xx beta, and also 'downgrading' to FF 5.xx again, but the error still appears. When I disable Javascript, the error doesn't appear, but this workaround can't be the solution.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Google Update
  • 4.0.60531.0
  • Picasa plugin
  • CANON iMAGE GATEWAY Mycamera Plugin
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0

More Information

kguz111593 0 solutions 1 answers

The fix is to uninstall Firefox completely [First, back up your bookmarks]. The error is caused by an add-on. If you get the Div Null you're unlikely able to open your add-on manager to remove any. When you uninstall the program, make sure to check to delete all your bookmarks and personal data. Then reinstall Firefox and the problem is fixed :)

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
jasper85 0 solutions 1 answers

Start in Safe mode with all add-ons & extensions disabled. Try youtube, if ok check for a Youtube download helper or mp3 helper. I removed this and Youtube then worked fine.

jaronbarends 0 solutions 1 answers

Helpful Reply

I fixed this by disabling the YouTube MP3 Downloadhelper plugin.

LeonNicanor 0 solutions 1 answers

I had the same issue, removed that addon and problem solved. No need to uninstall

ehoagland66 0 solutions 1 answers

Helpful Reply

I got rid of this problem by disabling the addon:

Easy YouTube MP3 Downloader 1.7 by Kaaj

Link to the addon page: http://tinyurl.com/77k6j7u

There are several GOOD YouTube downloaders available. Make sure this is the one you have before you disable it.

running: CometBird 7.0.1 alternative to Firefox (but is uses the same engine--in fact everything is the same as Firefox, but with a different name, and built-in support for the BitComet client without using an addon after they stopped development on the addon itself--I guess they did this to start pimping their own web browser. Whatever... it does seem to eat up less RAM, though.)

Modified by ehoagland66