X
Tap here to go to the mobile version of the site.

Support Forum

Key to the left of the URL does not bring back the save password feature.

Posted

I have read a lot of threads and pages on Firefox not saving passwords. I do not have "Private Browsing" on. I have cookies and history saved "until they expire". I have "save passwords" checked. I have no exceptions.

When I go to enter a password, no little window pops up to ask me to save it. However, a little key _does_ appear. But the key is greyed out and clicking it does nothing. It doesn't "un-hide" the password saver.

I have disabled all add-ons, restarted and tried it again. It was still the same. The sites are all ones that function perfectly well on my desktop computer, but not on my laptop. The laptop is the one that will not save passwords.

It is a Samsung running Windows 7.

I have read a lot of threads and pages on Firefox not saving passwords. I do not have "Private Browsing" on. I have cookies and history saved "until they expire". I have "save passwords" checked. I have no exceptions. When I go to enter a password, no little window pops up to ask me to save it. However, a little key _does_ appear. But the key is greyed out and clicking it does nothing. It doesn't "un-hide" the password saver. I have disabled all add-ons, restarted and tried it again. It was still the same. The sites are all ones that function perfectly well on my desktop computer, but not on my laptop. The laptop is the one that will not save passwords. It is a Samsung running Windows 7.

Chosen solution

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • npdnu
  • npdnupdater2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r181
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • NPWLPG
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

See above.

cor-el
  • Top 10 Contributor
  • Moderator
17532 solutions 158532 answers

Do you see any saved passwords in the Password Manager?

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

See also the Troubleshooting section:

Do you see any saved passwords in the Password Manager? *Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords" See also the Troubleshooting section: *http://kb.mozillazine.org/Password_Manager

Question owner

No. I have no saved passwords, as it never has asked me to save a password. The prompt does not come up, and clicking the "key" that is suppose to "un-hide" it, does nothing.

No. I have no saved passwords, as it never has asked me to save a password. The prompt does not come up, and clicking the "key" that is suppose to "un-hide" it, does nothing.
cor-el
  • Top 10 Contributor
  • Moderator
17532 solutions 158532 answers

See "Troubleshooting":

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

See "Troubleshooting": * http://kb.mozillazine.org/Password_Manager Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode

Modified by cor-el

Question owner

The safe mode worked. When in safe mode the pop up asking to save the password came up.

However, if I disable all the plugins manually, that doesn't work. And if I disable all the extensions manually, that doesn't work either. Nor does disabling both together, manually.

So then, what else occurs in Safe Mode, aside from Plugins and Add-Ons being disabled that could cause it?

The safe mode worked. When in safe mode the pop up asking to save the password came up. However, if I disable all the plugins manually, that doesn't work. And if I disable all the extensions manually, that doesn't work either. Nor does disabling both together, manually. So then, what else occurs in Safe Mode, aside from Plugins and Add-Ons being disabled that could cause it?

Modified by Eoko

cor-el
  • Top 10 Contributor
  • Moderator
17532 solutions 158532 answers

Are you using the default theme (Tools > Add-ons > Appearance/Themes)?

See:

Are you using the default theme (Tools > Add-ons > Appearance/Themes)? See: *https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

Question owner

Yes I am. I have no additional themes downloaded at all.

Yes I am. I have no additional themes downloaded at all.
cor-el
  • Top 10 Contributor
  • Moderator
17532 solutions 158532 answers

Which extensions do you have?

Maybe some component is still active if all extensions are disabled or some prefs get changed.


Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Which extensions do you have? Maybe some component is still active if all extensions are disabled or some prefs get changed. *https://support.mozilla.com/kb/Resetting+preferences ---- Create a new profile as a test to check if your current profile is causing the problems. See Basic Troubleshooting: Make a new profile: *https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems. If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files) See: *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

Resetting the preferences did not resolve it.

Creating a new profile did not resolve it.

These are the extensions I have: Adblock Plus 1.3.9 Globefish 1.3.2 iMacros for Firefox 7.3.0.0 Multirow Bookmarks Toolbar Plus 1.0 New Tab Homepage 0.4.3 Norton Toolbar 2011.7.1.3 Screenshot Pimp 3.3.51 Symantec IPS 3.1

Resetting the preferences did not resolve it. Creating a new profile did not resolve it. These are the extensions I have: Adblock Plus 1.3.9 Globefish 1.3.2 iMacros for Firefox 7.3.0.0 Multirow Bookmarks Toolbar Plus 1.0 New Tab Homepage 0.4.3 Norton Toolbar 2011.7.1.3 Screenshot Pimp 3.3.51 Symantec IPS 3.1
EasternBattleGroup 0 solutions 1 answers

I am having the same issue, I am running on a 64 bit system, does that have any impact?

I am having the same issue, I am running on a 64 bit system, does that have any impact?
cor-el
  • Top 10 Contributor
  • Moderator
17532 solutions 158532 answers

Make sure that Norton isn't blocking it.

Make sure that Norton isn't blocking it.

Question owner

Well, it worked in safe mode with no change to Norton. So it can't really be anything with the main Norton. And it doesn't work with the Norton add-ons disabled.

Well, it worked in safe mode with no change to Norton. So it can't really be anything with the main Norton. And it doesn't work with the Norton add-ons disabled.

Modified by Eoko

cor-el
  • Top 10 Contributor
  • Moderator
17532 solutions 158532 answers

Chosen Solution

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears. *Use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions. * Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") *https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

Modified by cor-el

Question owner

"Reset toolbars and controls" seems to have made it work, with no change to the extensions.

"Reset toolbars and controls" seems to have made it work, with no change to the extensions.