X
Tap here to go to the mobile version of the site.

Support Forum

Toolbars, Babylon toolbar will not uninstall. What sould i do?

Posted

I tried to install daemon tools on my computer and in the installation process i also got Babylon toolbar and engine search as a default, witch i don´t want. I uninstalled it via the control panel but it won´t disappear from Firefox. How can i uninstall the toolbar so that it disappears from Firefox? Is there a way to delete the toolbar via Firefox?

I tried to install daemon tools on my computer and in the installation process i also got Babylon toolbar and engine search as a default, witch i don´t want. I uninstalled it via the control panel but it won´t disappear from Firefox. How can i uninstall the toolbar so that it disappears from Firefox? Is there a way to delete the toolbar via Firefox?

Chosen solution

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. Now do this:

-> go to View Menu -> Toolbars -> select Menu Bar and Navigation ToolBar -> unselect All Unwanted toolbars

-> go Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache, Site Preferences -> click "Clear Now"

-> go to Tools Menu -> Options -> General -> When Firefox starts : select "Show My Home Page" -> Type the address of the website which you want to be your HomePage e.g. http://www.google.com

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> Click OK on Options window

-> click the Favicon (small drop down menu icon) on Firefox SearchBar (its position is on the Right side of the Address Bar) -> click "Manage Search Engines" -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.

Read this answer in context 42

Additional System Details

This happened

Just once or twice

This started when...

2011-07-18

Installed Plug-ins

  • DivX Web Player version 1.5.0.52
  • Shockwave Flash 10.3 r181

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Hasan 469 solutions 5600 answers

Chosen Solution

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. Now do this:

-> go to View Menu -> Toolbars -> select Menu Bar and Navigation ToolBar -> unselect All Unwanted toolbars

-> go Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache, Site Preferences -> click "Clear Now"

-> go to Tools Menu -> Options -> General -> When Firefox starts : select "Show My Home Page" -> Type the address of the website which you want to be your HomePage e.g. http://www.google.com

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> Click OK on Options window

-> click the Favicon (small drop down menu icon) on Firefox SearchBar (its position is on the Right side of the Address Bar) -> click "Manage Search Engines" -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.

-> Tap ALT key or press F10 to show the Menu Bar -> go to Help Menu -> select "Restart with Add-ons Disabled" Firefox will close then it will open up with just basic Firefox. Now do this: -> go to View Menu -> Toolbars -> select Menu Bar and Navigation ToolBar -> unselect All Unwanted toolbars -> go Tools Menu -> Clear Recent History -> '''Time range to clear: select EVERYTHING''' -> click Details (small arrow) button -> place Checkmarks on '''Cookies, Cache, Site Preferences''' -> click "Clear Now" -> go to Tools Menu -> Options -> General -> '''When Firefox starts : select "Show My Home Page"''' -> Type the address of the website which you want to be your HomePage e.g. http://www.google.com -> go to Tools Menu -> Options -> Content -> place Checkmarks on: 1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript -> go to Tools Menu -> Options -> Security -> place Checkmarks on: 1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites -> Click OK on Options window -> click the Favicon (small drop down menu icon) on Firefox SearchBar (its position is on the Right side of the Address Bar) -> click "Manage Search Engines" -> select all Unwanted Search Engines and click Remove -> click OK -> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.
cooltx 0 solutions 1 answers

Helpful Reply

First, I disabled and removed BABYLON toolbar from toolbar menu and control panel. ==> it removed the toolbar search. but it still remained in search dialog box and in address bar search

Second, I removed BABYLON search engine and related search.conduit.com entries from Firefox ==> it removed BABYLON from showing up on search dialog box. but it still remained in the address bar search.

Third, in About:config, I tried to remove or change entries with "babylon" filter string. ==> But this did not work.

Lastly, I uninstalled Mozilla Firefox from Control Panel. And removed all customization settings.

I just had to reinstall the latest version of Mozilla Firefox. ==> This worked very well.

I hope Mozilla Firefox provides users to better manage the search engine choices in future.

cooltx

First, I disabled and removed BABYLON toolbar from toolbar menu and control panel. ==> it removed the toolbar search. but it still remained in search dialog box and in address bar search Second, I removed BABYLON search engine and related search.conduit.com entries from Firefox ==> it removed BABYLON from showing up on search dialog box. but it still remained in the address bar search. Third, in About:config, I tried to remove or change entries with "babylon" filter string. ==> But this did not work. Lastly, I uninstalled Mozilla Firefox from Control Panel. And removed all customization settings. I just had to reinstall the latest version of Mozilla Firefox. ==> This worked very well. I hope Mozilla Firefox provides users to better manage the search engine choices in future. cooltx
CutiePie0094 0 solutions 1 answers

I don't trust Babylon, DON'T INSTALL IT!

I don't trust Babylon, '' '''DON'T INSTALL IT!'''''
vgsystem 0 solutions 1 answers

mha007

Thank you for your answer. It took me sometime to follow your instruction but now Babylon is out of sight.

mha007 Thank you for your answer. It took me sometime to follow your instruction but now Babylon is out of sight.
moondance263 0 solutions 1 answers

UNINSTALL FIREFOX - THIS WILL SOLVE THE PROBLEM. THEN REINSTALL. They have a new "Browser Protect" thing - download it upon reinstallation. It will pop up a window which will show Babylon. "BLOCK" it. DONE. NO MORE FREAKIN' BABYLON! YAY!!! MAN, I'M GLAD THAT'S OVER!

UNINSTALL FIREFOX - THIS WILL SOLVE THE PROBLEM. THEN REINSTALL. They have a new "Browser Protect" thing - download it upon reinstallation. It will pop up a window which will show Babylon. "BLOCK" it. DONE. NO MORE FREAKIN' BABYLON! YAY!!! MAN, I'M GLAD THAT'S OVER!
sundar.seshan 0 solutions 1 answers

thanks friend. i have successfully uninstall babylon tool bar and search engine which automatically opnes in fire box

thanks friend. i have successfully uninstall babylon tool bar and search engine which automatically opnes in fire box
vatsal 0 solutions 1 answers

from the manage addon option, remove the babylon search ! Its done voila !!!

from the manage addon option, remove the babylon search ! Its done voila !!!