X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox closes multiple tabs without warning me

Posted

FF 4.0.1 (up to date) Windows 7 home premium (eng)

When browsing using multiple tabs, FF doesn't warm me if i accidentally close the whole window from the upper right corner X. All tabs are closed at once.

Here are the things I have already tried (with help):


about:config browser.warnOnQuit default boolean true

browser.tabs.warnOnClose default boolean true

browser.tabs.warnOnQuit user set boolean true (this was missing, I added it)

Then I tried (with help): browser.showQuitWarning ---> true browser.warnOnRestart ----> true

Won't work.


But then I realized something odd. If I have only one browser window open, all tabs are closed at once by clickin the X (upper corner). But when I have at least two separate browser windows open, then FF gives me the following warning message if Im trying to close the window with multiple tabs: "Confirm close... You are about to close [number of open tabs] tabs. Are you sure you want to continues? [x] Warm me when I attempt to close multiple tabs ... [close tabs] [cancel]"

And this works only when I have at least two separate browser windows open. How can I get it to work when Im using only one window with multiple tabs? This is making me crazy because I always accidentally click the X instead of closing the tab only and I lost all the other tabs.

Edit. Same with FF 9 and now FF 12.0a1 (64bit). Reseting settings wont work no more! Could you please do something to make it work!?

Modified by mreni

Chosen solution

I had the exact same problem. To solve this you'll have to reset the Firefox settings. To do this click the Firefox button, go to help, and select Restart without add-on. A prompt window will show up. Check the reset Firefox settings box and continue. The warning dialog should now work.

P.S. It seems to be a problem with your profile, not Firefox itself. I tried another profile in Firefox (a profile with all settings default) and encounters no problem.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

David McRitchie 321 solutions 3089 answers

Changes you make may apply to new windows only. Try restarting Firefox.

browser.tabs.warnOnClose default boolean true

Question owner

Restarting FF? Like closing the browser and opening it again? Done that everytime I have changed something.

mit2nil 0 solutions 2 answers

Helpful Reply

I am also facing exactly the same problem. Warning is only working when there are multiple windows opened. This is a serious bug. Please solve as soon as possible. I have installed FF5 installed for windows 7.

Question owner

Yes, still the same problem with FF 5 (in 64bit Win7).

farmeunit 0 solutions 2 answers

I'm experiencing the same issue as mit2nil and mreni.

FF5 64-bit Win7

envutec 1 solutions 2 answers

Chosen Solution

I had the exact same problem. To solve this you'll have to reset the Firefox settings. To do this click the Firefox button, go to help, and select Restart without add-on. A prompt window will show up. Check the reset Firefox settings box and continue. The warning dialog should now work.

P.S. It seems to be a problem with your profile, not Firefox itself. I tried another profile in Firefox (a profile with all settings default) and encounters no problem.

cwb.bra 0 solutions 2 answers

Solution:

  1. At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options.
  2. Select the General panel.
  3. In Startup, "When Firefox starts:" don´t select "Show my windows and tabs from last time".
  4. Click "OK" to close the Options window.

Modified by cwb.bra

ifasmile 0 solutions 3 answers

Hey You People ! :-)

the "cwb.bra" solution (dated 2011/7/13) is The Solution !

so simple I couldn't believe it... :-)

Half a second time it took me to try it : it perfectly works out !

Finally ! the Solution...

Incredible though too that I never paid attention to this tiny details, because in my Firefox's basic configuration on closing,

all cookies and history are supposed ot be cleared...

So Thanks a lot to "cwb.bra"  :-)

mit2nil 0 solutions 2 answers

Helpful Reply

I am totally disagree with the solution selected for this issue.

I tried the solution when I upgraded to firefox 5 but after using it for a month or so now again the same problem have started occurring !!!!

This really sucks :(

I can't reset my profile each and every time because by doing that I have to redo all my settings and customizations !

I would like to urge the developer's to figure out the better way to this problem because even when people say that it's not working it is actually working when the multiple windows are also opened with multiple tabs ! So there must be something wrong with the browser !

Modified by mit2nil