Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The "warm me when closing multiple tabs" option doesn't work?

  • 2 replies
  • 21 have this problem
  • 12 views
  • Last reply by bltay

more options

I am using the latest beta version (Firefox 4.0.1) of Mozila browser. I would like to ask, how should I do the make the browser warm me an alert when I am closing multiple tabs. For previous version of Mozila browser, it will warm the user an alert asking that whether the user wish to save, quit, or cancel before close the multiple tabs. I already click the "warm me when closing multiple tabs" in the Options menu, but it doesn't work, the browser closed directly without warm me when the Close button hit.

I am using the latest beta version (Firefox 4.0.1) of Mozila browser. I would like to ask, how should I do the make the browser warm me an alert when I am closing multiple tabs. For previous version of Mozila browser, it will warm the user an alert asking that whether the user wish to save, quit, or cancel before close the multiple tabs. I already click the "warm me when closing multiple tabs" in the Options menu, but it doesn't work, the browser closed directly without warm me when the Close button hit.

All Replies (2)

more options

Firefox now always stores the old session, and you can access it by going to the History menu and selecting "Restore Previous Session"

If you want Firefox to display the message to save the session, it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 3 preferences browser.warnOnQuit, browser.warnOnRestart and browser.showQuitWarning

If you always open the last set of tabs, an alternative approach is this:

  1. Click the orange Firefox button, then select options to open the options window
  2. Go to the General panel
  3. Change the setting "When Firefox starts" to "Show my windows and tabs from last time"
more options

Thank you very much TonyE, it is work now!! Thanks man.