X
Tap here to go to the mobile version of the site.

Support Forum

No pop up on closing FireFox

Posted

Since I updated to FF 5.0 and now FF 6.0 yesterday, I still do not receive the pop up notice/warming that "you are about to close several tabs, do you want to?" I've had this setting for a couple years now, I think. Probably since it was offered.

I looked at this article on FF help:

http://support.mozilla.com/en-US/kb/Firefox%20does%20not%20ask%20to%20save%20tabs%20and%20windows%20on%20exit

I do not want to restore any session. I just want the pop up notice that asks "Are you sure you want to close all these tabs?"

Windows XP, SP3 Settings in FF: Tools | Options | Tabs (These are all checked) Open new windows in a new tab instead Warn me when closing multiple tabs Warn me when opening multiple tabs might slow down FF Always show the tab bar

I did find an article and did the following (the first one was set to True already, but the second one was set to False and thus changed it) Type about:config in the address bar and press enter. Click on I'll be careful, I promise Enter browser.warnOnQuit in the filter field at top Double click (toggle) on it to change the boolean value to true. Now enter browser.showQuitWarning in the filter field Double click on it to change it to true Now restart Firefox

Still no pop up when I shut down with multiple tabs open.

Since I updated to FF 5.0 and now FF 6.0 yesterday, I still do not receive the pop up notice/warming that "you are about to close several tabs, do you want to?" I've had this setting for a couple years now, I think. Probably since it was offered. I looked at this article on FF help: http://support.mozilla.com/en-US/kb/Firefox%20does%20not%20ask%20to%20save%20tabs%20and%20windows%20on%20exit I do not want to restore any session. I just want the pop up notice that asks "Are you sure you want to close all these tabs?" Windows XP, SP3 Settings in FF: Tools | Options | Tabs (These are all checked) Open new windows in a new tab instead Warn me when closing multiple tabs Warn me when opening multiple tabs might slow down FF Always show the tab bar I did find an article and did the following (the first one was set to True already, but the second one was set to False and thus changed it) Type about:config in the address bar and press enter. Click on I'll be careful, I promise Enter browser.warnOnQuit in the filter field at top Double click (toggle) on it to change the boolean value to true. Now enter browser.showQuitWarning in the filter field Double click on it to change it to true Now restart Firefox Still no pop up when I shut down with multiple tabs open.

Modified by VerveWeb

Chosen solution

oh yes sorry i forgot that when you use Firefox Safe Mode and close the window by clicking 'X' button, it won't ask for your confirmation..

-> Create a New Profile as a test to check if your current profile is causing the problems.

-> Basic Troubleshooting: Make a New Profile

-> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile.

-> Recovering important data from an old profile

Check and tell if its working.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • npdnu
  • npdnupdater2
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • npmnqmp 989898989877
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

Matt Brubeck 145 solutions 1390 answers

Helpful Reply

I'm not sure why this warning is no longer appearing, but you can turn it back on like this:

  1. Open the Firefox options, preferences and settings
  2. Click on the "Tabs" section
  3. Click the checkbox next to "Warn me when closing multiple tabs"
I'm not sure why this warning is no longer appearing, but you can turn it back on like this: # Open the [[Options window]] # Click on the "Tabs" section # Click the checkbox next to "Warn me when closing multiple tabs"

Question owner

Thanks, but my original post states that I already have that option checked. Also, have unchecked. Closed FF. Opened FF. Rechecked it and still does not work.

Thanks, but my original post states that I already have that option checked. Also, have unchecked. Closed FF. Opened FF. Rechecked it and still does not work.
Matt Brubeck 145 solutions 1390 answers

Helpful Reply

Oops, sorry! I guess I didn't read your message closely enough.

And in fact, I just tried enabling that option myself, and it doesn't seem to work. I'll see if I can figure out why not...

Oops, sorry! I guess I didn't read your message closely enough. And in fact, I just tried enabling that option myself, and it doesn't seem to work. I'll see if I can figure out why not...
Matt Brubeck 145 solutions 1390 answers

It turns out that Firefox will not prompt before closing if it is configured to restore your previous tabs on startup (I guess because the tabs are still there when you re-open Firefox).

If you'd like it to prompt anyway, you can install the Always Ask add-on.

It turns out that Firefox will not prompt before closing if it is configured to restore your previous tabs on startup (I guess because the tabs are still there when you re-open Firefox). If you'd like it to prompt anyway, you can install the '''[https://addons.mozilla.org/en-US/firefox/addon/always-ask/ Always Ask add-on]'''.

Question owner

Actually, Mozilla did not post the second half of my message and I updated, so it was actually not there when you viewed. You missed nothing.  ;)

However, I have a machine running Windows 7 with FF 6.0 also with the same exact settings and it "does" have the prompt upon closing.

I don't have that Restore Session or whatever when I open FF. I have it set to a blank page. Nothing restores. Really hate to add any Apps to FF, but I'll go take a look at the one you suggested. Thank you.

Actually, Mozilla did not post the second half of my message and I updated, so it was actually not there when you viewed. You missed nothing. ;) However, I have a machine running Windows 7 with FF 6.0 also with the same exact settings and it "does" have the prompt upon closing. I don't have that Restore Session or whatever when I open FF. I have it set to a blank page. Nothing restores. Really hate to add any Apps to FF, but I'll go take a look at the one you suggested. Thank you.

Question owner

If I open FF and some Tabs and then open another instance of FF (Open in New Window) - then I get the below pop up when I try to close that newly opened window.

If I open FF and some Tabs and then open another instance of FF (Open in New Window) - then I get the below pop up when I try to close that newly opened window.
SallySews 0 solutions 1 answers

Am getting the same thing on mine too. My Win7 is ok, but not XP.

Am getting the same thing on mine too. My Win7 is ok, but not XP.
Hasan 469 solutions 5600 answers

-> Start Firefox in Safe Mode by holding down SHIFT key while starting Firefox. As an alternative method, select "Start -> Run" (on Windows 7/Vista, use Win + R key combination) and enter one of the following in the Windows Run box:

  • firefox -safe-mode
  • "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -safe-mode

-> Firefox Safe Mode window will appear -> DON'T SELECT ANY OPTIONS, just click Continue in Safe Mode

Check and tell if its working with ONE Window containing Multiple Tabs while you are browsing in Firefox Safe Mode.

-> Start Firefox in Safe Mode by holding down SHIFT key while starting Firefox. As an alternative method, select "Start -> Run" (on Windows 7/Vista, use '''Win''' + '''R''' key combination) and enter one of the following in the Windows Run box: * firefox -safe-mode * "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode * "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -safe-mode -> Firefox Safe Mode window will appear -> DON'T SELECT ANY OPTIONS, just click '''Continue in Safe Mode''' Check and tell if its working with ONE Window containing Multiple Tabs while you are browsing in Firefox Safe Mode.

Question owner

I followed your instructions mha007 above, opening only one window and FB.Com, Google.Com and Yahoo.Com in Tabs.... still did not give any notice.

I followed your instructions mha007 above, opening only one window and FB.Com, Google.Com and Yahoo.Com in Tabs.... still did not give any notice.
Hasan 469 solutions 5600 answers

Chosen Solution

oh yes sorry i forgot that when you use Firefox Safe Mode and close the window by clicking 'X' button, it won't ask for your confirmation..

-> Create a New Profile as a test to check if your current profile is causing the problems.

-> Basic Troubleshooting: Make a New Profile

-> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile.

-> Recovering important data from an old profile

Check and tell if its working.

oh yes sorry i forgot that when you use Firefox Safe Mode and close the window by clicking 'X' button, it won't ask for your confirmation.. -> Create a New Profile as a test to check if your current profile is causing the problems. -> Basic Troubleshooting: Make a New Profile * https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile -> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile. -> Recovering important data from an old profile * https://support.mozilla.com/en-US/kb/Recovering%20important%20data%20from%20an%20old%20profile Check and tell if its working.

Question owner

WOOOO HOOOO! Worked. Just have to read through all the instructions on moving my junk over to the new profile.

THANKS, mha007!

WOOOO HOOOO! Worked. Just have to read through all the instructions on moving my junk over to the new profile. THANKS, mha007!

Question owner

OOOPSIE! I found the culprit! After I made the FF profile, all I did was manually backup my Bookmarks to a new location and then open up the NEW profile and imported them in. All was well. When I closed FF, it gave me the pop up about closing FF with Tabs open. Great. Then I started changing other Options like starting with a blank page and not saving any passwords, etc. A little while later I opened FF and closed with Tabs opened. NO POP UP WARNING! What? So, I made yet a third new profile. But THIS time I thought it had to be in another Option I was choosing. So I checked this third profile before changing anything. Yep, got the pop up at close. Next I copied over my Bookmarks. Yep, still gives me the pop up warning. Then I changed the options ONE by ONE and checked each time by closing FF with open Tabs. One by one they I kept getting the pop up warning after each change. THEN..... I got to Tools | Options | Privacy | History and changed the drop down to "Never remember history." BINGO! No warning on closing FF. I remember in my original FF profile I had checked "Use custom settings for history." So you can't have the pop up warning if you choose not to save your history? Only the drop down option of Remember History, brings up the pop up warning at close.

OOOPSIE! I found the culprit! After I made the FF profile, all I did was manually backup my Bookmarks to a new location and then open up the NEW profile and imported them in. All was well. When I closed FF, it gave me the pop up about closing FF with Tabs open. Great. Then I started changing other Options like starting with a blank page and not saving any passwords, etc. A little while later I opened FF and closed with Tabs opened. NO POP UP WARNING! What? So, I made yet a third new profile. But THIS time I thought it had to be in another Option I was choosing. So I checked this third profile before changing anything. Yep, got the pop up at close. Next I copied over my Bookmarks. Yep, still gives me the pop up warning. Then I changed the options ONE by ONE and checked each time by closing FF with open Tabs. One by one they I kept getting the pop up warning after each change. THEN..... I got to '''Tools | Options | Privacy | History''' and changed the drop down to '''"Never remember history." '''BINGO! No warning on closing FF. I remember in my original FF profile I had checked "Use custom settings for history." So you can't have the pop up warning if you choose not to save your history? Only the drop down option of Remember History, brings up the pop up warning at close.

Modified by VerveWeb

Question owner

I deleted out all the FF profiles I made and went back to the original one I had when I started this post.

After tweeking the Tools | Options | Privacy, I was able to get rid of all my history and cookies, etc on FF close, yet STILL receive the pop up warning when closing with Tabs open. Below are my settings now with the pop up working once again.

I deleted out all the FF profiles I made and went back to the original one I had when I started this post. After tweeking the Tools | Options | Privacy, I was able to get rid of all my history and cookies, etc on FF close, yet STILL receive the pop up warning when closing with Tabs open. Below are my settings now with the pop up working once again.
Hasan 469 solutions 5600 answers

Glad to hear you were able to catch the culprit. I'll also remember that for future posts like this one..

Glad to hear you were able to catch the culprit. I'll also remember that for future posts like this one..