Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Every time I open firefox browser a very ANNOYING "Plugin Check Window" pops up. My plugins are up to date. I don't want this reminder....PLEASE let me know how to disable it...thanks

  • 4 replies
  • 54 have this problem
  • 341 views
  • Last reply by iamvictoria

more options

Every time I open firefox browser a very ANNOYING "Plugin Check Window" pops up. My plugins are up to date. I don't want this reminder....PLEASE let me know how to disable it...thanks

All Replies (4)

more options

Modified by mikeclark

more options

Try this:

  1. Open URL about:config
  2. in the filter box write: plugins.update
  3. then set: plugins.update.notifyUser = false

Modified by Carlo Tafuro

more options

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.)

Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled.

For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

more options

I did the same thing, and it worked! Thank you