X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the "Plug-In Check" window from popping up everytime I open my firefox browser? It is totally annoying...thanks

Posted

Every time I open firefox browser a very ANNOYING "Plugin Check Window" pops up. My plugins are up to date. I don't want this reminder....PLEASE let me know how to disable it...thanks

Chosen solution

In the address bar, type about:config

Click the "I'll be careful, I promise!" button if it appears.

Type "plugin" into the filter box.

Find the entry plugin.scan.plid.all and set it to false.

You're done!

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Mozilla ActiveX control and plugin module
  • np-mswmp
  • MetaStream 3 Plugin r4
  • 1.7.0069.3
  • npsnapfish
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • Google Updater pluginhttp://pack.google.com/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET CLR 3.5.30729)

More Information

kpatz 1 solutions 3 answers

Chosen Solution

In the address bar, type about:config

Click the "I'll be careful, I promise!" button if it appears.

Type "plugin" into the filter box.

Find the entry plugin.scan.plid.all and set it to false.

You're done!

dosso 0 solutions 3 answers

i've the problem since today. i tried this about:config modification...but the problem is still unsolved.

Question owner

Thanks for the quick response....it definitely worked. What's up with the "I'll be careful, I promise" button? Kinda funny!

kpatz 1 solutions 3 answers

Helpful Reply

I discovered that Flash gets disabled after making this about:config change. Firefox claims that Flash is "out of date" when the latest version is installed. So if you use Flash, this tweak won't work.

I don't really need my browser telling me what I can and can't run...

dosso 0 solutions 3 answers

it's true. it seems you have to choice if have the page annying popup or the flash plugin enables. i suppose it will be a temporary problem of firefox...i hope this.

Teddington 0 solutions 4 answers

Helpful Reply

Same problem here.

plugin.scan.plid.all, did not work

Question owner

Same here, I had to go back and click on true. Sometimes we just can't win!

mikeclark 3 solutions 35 answers

Vote for https://support.mozilla.com/en-US/questions/832793

Modified by mikeclark

johnsn 0 solutions 2 answers

I would have loved it to work - the checking is sooo anoying. But : Sorry. Absolutely no luck doing as written above :-(

Other suggestions ?

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

Pref = plugins.update.notifyUser if it shows as True, double-click that pref to toggle it to False

If that pref was already set to False, try disabling the QuickTime Plugin and then restart Firefox, to see if that is the culprit.

Modified by the-edmeister

johnsn 0 solutions 2 answers

Tried disabling the QuickTime plugin - still no luck :-(

iamvictoria 0 solutions 4 answers

I have the same problem. I did notice though that people who are complaining about it (me included) have something in common. We are all using Firefox 3.6. Hmmm...is this their way of forcing us to switch to Firefox 4? Well, i don't have any plans of doing so anytime soon, especially that reviews are really bad

mikeclark 3 solutions 35 answers

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.)

Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled.

For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

David Spalding 0 solutions 14 answers

Mike that only eradicates the problem for someone with that plug-in problem. Others are getting the page for different plug-ins. ;)

Question owner

I uninstalled "Viewpoint Media Player" and that solved my problem. I don't get that annoying page anymore.....WOO HOO!!!

Modified by Freethink

tps5352 0 solutions 7 answers

Freethink, that does not work (for me). The "code" returns to the page. Make sure you are completely out of Firefox entirely when you exit. If you have more than one Firefox copy running simultaneously, then the Plugin Check page does not appear when you re-start one of them. But when all copies of FF are exited completely, the page does reappear (for me).

The-edmeister, none of your suggestions work (for me). The line Pref = plugins.update.notifyUser was already "false" for me (it was the default). In fact, when I made it "true," then exited and re-entered FF, it was back to being false. Something is wrong.

I then disabled the QuickTime Plugin and _all_ other plugins. When re-started the Plugin Check page still appeared _and_ the Quicktime plugin was enabled again (as was the Java plugin). Something is definitely wrong.

I updated Java no problem. But in order to update Quicktime you MUST update iTunes. That I am not willing to do.

This whole thing sucks. I have a good PC and software I am happy with that is working great for months, then some company decides it is not making enough $$$ and screws everything up. (I am not necessarily blaming Mozilla, unless the shoe fits.) I think that this security excuse is just that, an excuse. Updates should not be forced on people! Give us options!

Sorry, it is late and I'm grumpy.

kpatz 1 solutions 3 answers

I uninstalled Viewpoint Media Player and the annoying plugin page went away! Woo-hoo!

That also explains why only 1 of 3 computers in my house had the issue. The others don't have Viewpoint.

tps5352 0 solutions 7 answers

kpatz, AFAIK I do _not_ have Viewpoint Media Player (VMP) on my PC but am still having the problem. So that cannot be the problem for everyone, right?

I checked the Start-Program list in Windows XP, the Tools-Add-Ons list on Firefox, and the Settings-Control Panel-"Add or Remove Programs" list on Windows XP and saw no evidence of VMP. Where did you go to uninstall it?

BTW, I use Windows XP (SP-3) on a powerful Dell XPS desktop with Firefox (FF) 3.6.17. The "plugins.update.notifyUser" line on the FF configuration page “about:config” is set to "false."

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

This problem is caused by an incorrect update to the blocklist.xml file.
https://bugzilla.mozilla.org/show_bug.cgi?id=663722
(Please don't comment in that Bug report, posted for viewing only.)

More information here. - https://bugzilla.mozilla.org/show_bug.cgi?id=663676

dosso 0 solutions 3 answers

my pc is on my workplace. this morning the problem was still on, but the pc said that quicktime plugins was not safe and disabled it to protect my pc. immediately the plugin page problem disappear. so maybe uploading the plugins maybe on some pc the problem could be solved...