X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to disable plugin check on Firefox? I updated all my plugins but there are some showing as gray "Research?"

Posted

I have been using Firefox for some time now. I love the browser. I really really hate this plugin check page that opens every time I open Firefox. It is just annoying.

I updated all the plugins that were vulnerable, but there are some other plugins that it doesn't seem to recognize or whatever, and it asks me to research those. Is this the reason why the plugin check continuously pops up?

I don't know why Mozilla designed this page to be so annoying. I know it's as simple as closing out of it, but it is just buggy to me and a constant reminder that I don't know something about these plugins LOL it drives me crazy...

Please help. Thanks.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • VLC media player Web Plugin 2.0.2
  • Happy Cloud Web Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • 5.1.10411.0
  • Nexon Game Controller
  • Pando Web Plugin
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • npdnupdater2
  • npdnu

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello, please Update Firefox to the latest version (that's firefox 18.0.2 at the moment) - this should already fix the problem.

NCGrandma 0 solutions 4 answers

Helpful Reply

This page reminds me why I left microsux products. If I want to update my plugins etc I will but I do not need to be reminded like an imbecile. I don't need firefox to think or anticipate for me. I want one freakin tab to open when I open firefox and that is MY HOMEPAGE I don't want to have to deal with closing a tab I didnt ask for. so Mozilla firefox HOW DO I STOP IT FROM HAPPENING?? OR DO I LEAVE YOU LIKE MICROSUX????

jscher2000
  • Top 10 Contributor
2361 solutions 20909 answers

Hi NCGrandma, which version of Firefox are you running? You can check the current version under Help > About Firefox. This was supposed to have been turned off in Firefox 18, so some time ago.

NCGrandma 0 solutions 4 answers

Helpful Reply

Never mind, I have left firefox and its bs for chrome. If firefox ever goes back to unobtrusive not thinking for me browser I may retry it but for now I have moved on and I suggest to anyone else having the same problem try google chrome.

NCGrandma 0 solutions 4 answers

oh and btw I was using the latest version of firefox 19 and it was doing this i went back to version 8 it did it too. Just to clarify that I answered that question and didn't refuse help although after many years of using firefox it is too late I am off to google chrome

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

if this is happening in firefox 19 then you probably just have to set the right homepage.

How to set the home page

NCGrandma 0 solutions 4 answers

No my homepage was opening along with the plugin check in a second tab. Since all this happened I researched and google chrome requires less hard drive space and less memory than firefox without all the hassles. It also allows me to do private browsing, not accept third party cookies, stop pop ups etc. It is well worth looking into as it runs faster with less hard drive space less memory and less bs its a clean easy to use web browser without a bunch of buttons and bars.

jscher2000
  • Top 10 Contributor
2361 solutions 20909 answers

Hi NCGrandma, the problem you have with the plugincheck page opening on its own is extremely rare and doesn't affect most users.

To clarify the above reference to the home page, Firefox allows you to set multiple tabs to open as your home page. The suggestion was to check or update your home page in case the plugincheck page was set as a second home tab.

You are free to use the browser you like best. I'll be curious to hear how you compare Chrome and Firefox after 6 months.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96741 answers

You can get a plugin check on startup if you have plugins (Tools > Add-ons > Plugins) that are blocklisted by Mozilla, either because of security vulnerabilities or by causing excessive crashes and thus are disabled.

pcbest 0 solutions 3 answers

No problem. You have to rename/move some files AFTER unchecking the auto-update feature in tools-options-advanced-updates. For Win7 they are here:

C:\Users\AWK\AppData\Local\Mozilla\Firefox\Mozilla Firefox\updates\0 (I just renamed the parent folder from updates to this) C:\Users\AWK\AppData\Local\Mozilla\Firefox\Mozilla Firefox\00_updates\0

and

C:\Program Files\Mozilla Firefox I just moved these files to another folder

   maintenanceservice.exe
   maintenanceservice.exe_installer

I am using Firefox 21 because Firefox 22 will not allow some plugins to work, specifically "Plain Old Favorites" which is MISSION-CRIITICAL for me and mine. "Bookmarks" is lame. When Mozilla releases a version that works, I will download it, but I own this PC. Not Mozilla. Not Microsoft. Me.

jscher2000
  • Top 10 Contributor
2361 solutions 20909 answers

Hi pcbest, I believe you are thinking of extensions and themes, which update from addons.mozilla.org. The Plugin Check page is something users can visit on demand here: https://www.mozilla.org/plugincheck/

pcbest 0 solutions 3 answers

OOPS - You are so right. I answered the wrong post. LOL. I was having problems with the AUTO update - even after disabling it. After searching for an answer here I gave up and tracked down the offending files and dealt with them. Then I decided to go back to the support forum and share the knowledge. Oh well...at least someone with this issue should be able to find my reply by searching.

makgrs2 0 solutions 1 answers

To stop the plugincheck in firefox type in URL: "about:config" (without quotes), find the line "plugin.scan.plid.all" and doubleclick it to become false. That should fix the problem!

jscher2000
  • Top 10 Contributor
2361 solutions 20909 answers

Hi makgrs2, you suggested setting "plugin.scan.plid.all" to false. However, I think you are confusing two different scans. This preference determines whether Firefox will look for updated plugin listings in the Windows registry so that it can detect plugins installed by new programs. This preference is not related to the plugincheck website.

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Your version of Firefox that you are running is out of date. Try updating to Firefox 22.0.

Also try checking to see your homepage is set to the plug-in checker page.

pcbest 0 solutions 3 answers

I WAS TALKING ABOUT FIREFOX UPDATE. I originally posted to this thread by mistake - too many tabs open LOL - I refuse to use Firefox 22. I am using Firefox 21 because the add-on "Plain Old Favorites" will not work in 22. It has worked since I started using it in ver 10. In TOOLS...Advanced...UPDATES you can disable the updates, but it really doesn't fix it unless you also delete the maintenance service and maintenanceservice_install executables in the Mozilla folder. Also, be sure that you choose custom install so you won't have the maintenance service installed. I really like Firefox, but this is a slight hassle since I have to do this for all of my clients since we all rely on Windows Favorites instead of bookmarks. I will try ver 23 and then 24, but I will keep using 21 until they fix this issue with that particular add-on.

jscher2000
  • Top 10 Contributor
2361 solutions 20909 answers

Hi pcbest, the developer of "Plain Old Favorites" posted an update yesterday. It still is under review by the Addons team before hitting the extension's main page, but if you want to try it now, you can pick it up on the versions page here:

https://addons.mozilla.org/firefox/addon/plainoldfavorites/versions/

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Running old versions of Firefox can be unsafe because they can present security and stability issues. It is your choice to run Firefox 21, but since Firefox 22 is the most recent version I would recommend using it.