X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox suddenly not loading several web pages properly

Posted

I've had Firefox 4 since the release date, but today it's been acting up - it's not loading certain webpages properly, removing all the formatting and just putting all the text/links/etc in a list along the left hand side of the window. It's also not showing some pictures at all any more, although they're all hosted on Photobucket. This is literally ther first time there's been a problem with it since updating, and I've not changed any settings on it at all, so I have no clue why it's suddenly broken. Is anyone else getting this?

Chosen solution

I searched everywhere to find a solution to this problem; uninstalled FF; reinstalled FF; restored my computer; etc., etc., and NOTHING worked until I found this! Thanks a lot!

Read this answer in context 7

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • D'Fusion @Home Web Plug-In (2.30.10825.0)
  • np-mswmp
  • npdnu
  • npdnupdater2
  • Pando Web Installer
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • Free Realms Installer
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.2 r159
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0
  • NPWLPG
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
GameFOX
0.7.12
true
{6dd0bdba-0a02-429e-b595-87a7dfdca7a1}
StumbleUpon
3.81
true
{AE93811A-5C9A-4d34-8462-F7B864FC4696}
Text-to-Image
1.4.4
true
{f701c26a-479a-4724-b4f1-870db12f063c}
DownloadHelper
4.8.6
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Java Console
6.0.16
true
{CAFEEFAC-0016-0000-0016-ABCDEFFEDCBA}
Java Console
6.0.17
true
{CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
Java Console
6.0.19
true
{CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Adblock Plus
1.3.6
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://uk.yahoo.com/
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
dom.max_script_run_time
1800
extensions.lastAppVersion
4.0.1
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
30
network.http.proxy.pipelining
true
network.protocol-handler.warn-external.dnupdate
false
places.database.lastMaintenance
1304525679
places.history.expiration.transient_current_max_pages
104642
places.last_vacuum
1299932640
print.print_printer
HP Photosmart C5200 series
print.printer_HP_Photosmart_C5200_series.print_bgcolor
false
print.printer_HP_Photosmart_C5200_series.print_bgimages
false
print.printer_HP_Photosmart_C5200_series.print_command
print.printer_HP_Photosmart_C5200_series.print_downloadfonts
false
print.printer_HP_Photosmart_C5200_series.print_edge_bottom
0
print.printer_HP_Photosmart_C5200_series.print_edge_left
0
print.printer_HP_Photosmart_C5200_series.print_edge_right
0
print.printer_HP_Photosmart_C5200_series.print_edge_top
0
print.printer_HP_Photosmart_C5200_series.print_evenpages
true
print.printer_HP_Photosmart_C5200_series.print_footercenter
print.printer_HP_Photosmart_C5200_series.print_footerleft
&PT
print.printer_HP_Photosmart_C5200_series.print_footerright
&D
print.printer_HP_Photosmart_C5200_series.print_headercenter
print.printer_HP_Photosmart_C5200_series.print_headerleft
&T
print.printer_HP_Photosmart_C5200_series.print_headerright
&U
print.printer_HP_Photosmart_C5200_series.print_in_color
true
print.printer_HP_Photosmart_C5200_series.print_margin_bottom
0.5
print.printer_HP_Photosmart_C5200_series.print_margin_left
0.5
print.printer_HP_Photosmart_C5200_series.print_margin_right
0.5
print.printer_HP_Photosmart_C5200_series.print_margin_top
0.5
print.printer_HP_Photosmart_C5200_series.print_oddpages
true
print.printer_HP_Photosmart_C5200_series.print_orientation
0
print.printer_HP_Photosmart_C5200_series.print_pagedelay
500
print.printer_HP_Photosmart_C5200_series.print_paper_data
9
print.printer_HP_Photosmart_C5200_series.print_paper_height
11.00
print.printer_HP_Photosmart_C5200_series.print_paper_size_type
0
print.printer_HP_Photosmart_C5200_series.print_paper_size_unit
1
print.printer_HP_Photosmart_C5200_series.print_paper_width
8.50
print.printer_HP_Photosmart_C5200_series.print_reversed
false
print.printer_HP_Photosmart_C5200_series.print_scaling
1.00
print.printer_HP_Photosmart_C5200_series.print_shrink_to_fit
true
print.printer_HP_Photosmart_C5200_series.print_to_file
false
print.printer_HP_Photosmart_C5200_series.print_unwriteable_margin_bottom
0
print.printer_HP_Photosmart_C5200_series.print_unwriteable_margin_left
0
print.printer_HP_Photosmart_C5200_series.print_unwriteable_margin_right
0
print.printer_HP_Photosmart_C5200_series.print_unwriteable_margin_top
0
privacy.cpd.formdata
false
privacy.cpd.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5700 Series
Vendor ID
1002
Device ID
68b8
Adapter RAM
1024
Adapter Drivers
aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.831.2.0
Driver Date
3-8-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16763, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

If images are missing then check that you aren't blocking images from some domains.

See:

  • Check the permissions for the domain in the current tab in Tools > Page Info > Permissions
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in Tools > Options > Content: Load Images > Exceptions
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images)

There are also extensions (Tools > Add-ons > Extensions) that can block images.

Question owner

I tried everything you suggested, it still isn't working properly. I don't have the problems with IE or Chrome, just Firefox and only for the last two days.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

You can use these steps to check if images are blocked if you haven't done this yet.

  • Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
  • Go to the Media tab of the "Tools > Page Info" window.
  • Select the first image link and scroll down through the list with the Down arrow key.
  • If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
sodagreen 0 solutions 9 answers

Zozzilla, does an ebay auction page load correctly for you?

Question owner

@cor-el - I've done those steps, I'm still getting the problem...I think it's something to do with Firefox itself, not any of my extensions or plug-ins. :(

@sodagreen - No it doesn't, the buttons are all messed up, some fonts and HTML seem to be completely wonky.

Also to illustrate what I mentioned about pictures not showing, here is a screencap of one of the sites I visit. Every graphic on it is hosted by Photobucket, however if you look...the areas circled have missing images.

Question owner

As a temporary (most likely anyway) "fix" I uninstalled Firefox completely and reinstalled it. So far everything is back to normal, but I'm expecting it to mess up again within a week.

Tarkus 0 solutions 1 answers

Helpful Reply

Same issue for me suddenly began this morning (yesterday all was fine) - it's not that images aren't loading, it's quirky code errors. In some cases, CTRL-F5 fixes it... but, in others, it does not (e.g. Facebook only loads the most recent couple dozen status updates - clicking the link for more does nothing; I also did a daily check of fares on SW Airlines website - code for the reservation window won't load, and when I try manually typing it the info isn't accepted).

My short-term solution is to go back to IE8 - not happy about it, but at least all of the web pages I visit are properly working.

carnage517 0 solutions 1 answers

Helpful Reply

having the same issues as of Sunday, the Ctrl+F5 and the fresh installs work but only seem to be temp.

Any other ideas?

anniep 0 solutions 1 answers

I have started experiencing the same problem. CTRL 5 fixes it but it's a temporary fix. Have you found a permanent fix yet? Thanks

CAnderson93 0 solutions 1 answers

I just started having the problem described above recently where it appears some of the CSS isn't formatting my webpages correctly. I have tried reinstalling FF4, and even downloaded FF5 (in which the images below are taken) and the problem still persists. I have disabled all my addons and FF is essentially barebones and the problem still continues. The images below show my exact problems. On Google, the logo doesn't load; on IGN, all images don't show and the bottom half of the page looks to be in plain HTML; and CNN is just straight up HTML.

Any ideas on how to fix this? Any help is much appreciated!

Modified by CAnderson93

joonbug 0 solutions 1 answers

I am having the exact same problem in Firefox 3.6. It started happening a couple days ago. I notice it most on Yahoo mail and YouTube. Ctrl+F5 does the trick for a while but it's not permanent.

Rukia 0 solutions 1 answers

Hi, i happen to have block a web page that was not favorable for my young brother, but good for the rest. I used an advanced way of blocking it through the DOS commands, am sure there is any way of unblocking it but personnaly failed to apply it. So i really need help to unblock it. Thanks

Mikhael 0 solutions 1 answers

Hi, I was having the same issue with the lack of formatting and content. I first looked here for a solution and decided that before I uninstall and reinstall FF I would look at my computer settings. I went to change theme in control panel, clicked on a different windows theme, opened Firefox, and everything was back to normal! Hope this helps somebody!

akmueller4 1 solutions 1 answers

Chosen Solution

I searched everywhere to find a solution to this problem; uninstalled FF; reinstalled FF; restored my computer; etc., etc., and NOTHING worked until I found this! Thanks a lot!

LARRYELWOOD 0 solutions 1 answers

I just simply went into tools > ad ons and installed a new theme. This completely fixed the problem.

BertTheErt 0 solutions 1 answers

This morning, around 4am, I went to log on. Got the same issue already listed in this thread: page loads the web address for the homepage, but only brings up the info in plain text, in a list-type format, down the left-hand side of the page. It will NOT allow access to my email through that list, however. At first, I thought it was my ISP having a problem, but have since ascertained that is not the case. I'm only able to access the internet properly through IE, which makes me EXTREMELY unhappy. I've had Firefox 4.0.1 since it updated itself, and Firefox 4.0 for about the last two months. It was working flawlessly, and I was very happy with its performance, until THIS happened. Judging from the thread content here, it looks like this issue has gone on for nearly a year with other users. This would indicate to me that it's NOT my computer or its settings, but the Firefox software, itself. I have NOT blocked images or otherwise re-set any of my browser settings since installing Firefox 4.0. It worked fine just YESTERDAY. What causes this problem, and why can't Mozilla resolve it?? I'm no technician, but I've run every diagnostic available through Windows 7, Norton's Antivirus, AND Advanced System Care programs. It's not my machine....I should not have to add additional programs to make Firefox work. I haven't done anything to anything since yesterday. I have no clue about "themes", and my "Tools" option has a "Manage Add-Ons" tab, but says absolutely nothing about "themes". I have no idea what y'all are talking about. All I know, is that I liked the program while it worked, and am confused as to why it stopped. I'm running Win7 on an HP dv7t notebook computer that was BUILT for graphics/media applications. Any help would be most appreciated. Yesterday. Thanks.

jkl46 0 solutions 2 answers

I was having that problem with Twitter all day today. Got the genius idea to check it without Adblock Plus, and once I disabled it, Twitter worked perfectly. There aren't any ads on Twitter anyway, so it's not a problem.

leoSmith 0 solutions 1 answers

Simple fix for me.............

Goto

  Tools
      Options
           Content
                Make sure that  LOAD IMAGES AUTOMATICALLY  is checked.