Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Clicking firefox icon in taskbar opens up another icon


This has been bothering me for a bit now since upgrading to 4.0.1. I have a firefox icon pinned in the taskbar of windows 7 ultimate 64bit. And everytime I click on that icon another firefox icon is opened which then shows 2 different firefox icons on my taskbar. See the pic in the link. [[picture of problem|http://i53.tinypic.com/14kazo4.jpg]]. Is there any way to make it back like before where clicking on the icon just opens a firefox on that icon I clicked and nothing new?

Chosen solution

Additional System Details

This happened

Every time Firefox opened

This started when...

Upgrading to firefox 4.0.1

Installed Plug-ins

  • npdnu
  • npdnupdater2
  • Shockwave Flash 10.2 r159
  • Adobe Shockwave for Director Netscape plug-in, version
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.60310.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • BlackBerry WebSL Browser Plug-In
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

amat777 1 solutions 1 answers

Chosen Solution

http://www.ghacks.net/2010/10/12/fix-pinned-items-opening-as-new-icons-in-windows-7-taskbar/ I had the same issue, this fix worked for me, hope it works for you! :)

Question owner

While following that article exactly didn't help, pinning the new thing that spawned helped so thanks.

dm01 0 solutions 6 answers

Helpful Reply

This is my solution:

Go to C:\Users\xxxxx\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Unpin old icon, and pin Mozilla Firefox shortcut ( in quick launch folder). You can change icon too if you want.

Rose1 0 solutions 7 answers

I had the same problem. dm01 solution worked. Thanks ☺