X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to return to the same PLACE on a page after you link to another page

Posted

If you are on a long page that contains links, if you click on the link, go to the new page, read, then return to the first page, you are dropped at the top of the page, not where you left from as FF3.* did. It matters because some pages I use have hundreds of links and I have to hunt to find where I was so that I continue my process.

Chosen solution

It took me a while to find out. This issue has nothing to do with Firefox 8, I think. It is the way Google handles the page with your search results. In the top right corner of your Google home page click the settings button and change the search settings "Google Instant predictions" to OFF. Then hit SAVE and you will be able to go back to same scroll position of your Google search results page. Hope that helps !!!

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 10.2 r153
  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • Foxit Reader Plug-In For Firefox and Netscape
  • np-mswmp
  • Express View Browser Plugin
  • 1.9.0042.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • 4.0.60129.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Reader Library Helper Plugin
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

parycash 2 solutions 2 answers

Chosen Solution

It took me a while to find out. This issue has nothing to do with Firefox 8, I think. It is the way Google handles the page with your search results. In the top right corner of your Google home page click the settings button and change the search settings "Google Instant predictions" to OFF. Then hit SAVE and you will be able to go back to same scroll position of your Google search results page. Hope that helps !!!