X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google search returns to top of page 1 when back button used after visiting a search page

Posted

When searching google, page returns to top of page 1. It used to return to the last search looked at, so if you are searching on page 6 it returns to page 1 and you have to go back to 6 & scroll down to where you were. Running Firefox 3.6.17. Windows 7

Chosen solution

To resolve the issue, you need to change the search settings on the Google home page. Top right hand corner, open the search settings and turn off the "Google Instant predictions".

Hope that helps !!!

Read this answer in context 2

Additional System Details

This happened

Every time Firefox opened

This started when...

A week or so ago

Installed Plug-ins

  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17

More Information

Uninstalled & re-installed Firefox. Same thing happens on laptop running Firefox & Windows 7, but not on laptop running Vista &
Outlook

Hasan 477 solutions 5600 answers

Troubleshooting extensions and themes

Check and tell if its working.

David McRitchie 321 solutions 3089 answers

Google search returns to top of page 1 when back button used after visiting a search page

I do not have that problem, because I open the results page in a new tab, and the links from the results page into new tabs.

I can only try to tell what what I do which is to use different tabs, not put everything into one tab.

Google: click on the Gear (settings(

Search results: [x] Open search results in a new browser window

Tools > Options > Tabs

I have everything checked except for Preview, but the important one is
[x] Open new windows in a new tab instead

If you type something in the the search bar or location bar and realize you didn';t start in a new tab, press the "Alt" button to force the search or url into a new tab.

about:config changes

browser.search.openintab true
browser.tab.openinnewtab true

Additional information on tabs:


More information on configuration variables available in about:config entries and for users not familiar with the process there is about:config (How to change).

If this solves your question and is better that what you had in 3.6, please mark as solved.


Modified by David McRitchie

SixDegrees 0 solutions 3 answers

Helpful Reply

I have exactly this same problem. I believe it first appeared a week or two ago. It manifests on Firefox both at home and at work. My version at home has not been updated for several months, while my version at work is updated regularly. My home version is 3.6.13. I am not sure what version I am running at work.

This occurs with Firefox under both Windows and Linux.

I have turned off all extensions and plugins both manually and by starting Firefox in safe mode, and the problem persists.

SixDegrees 0 solutions 3 answers

(Removed - unclear)

Modified by SixDegrees

Hasan 477 solutions 5600 answers

Locked or Damaged places.sqlite

Corrupt localstore.rdf

Check and tell if its working.

Modified by Hasan

msst8dog 0 solutions 3 answers

Since updating to 5.0, I have a similar problem: My browser goes to the top of the page that I left. This happens regardless of whether I open the link in a new tab also. When I close the new tab, or go back to the old tab, it is at the top of the page.

SixDegrees 0 solutions 3 answers

Tried rebuilding the localstore and sqlite files as suggested, although this seems unrelated to the problem we're experiencing. The problem persists, without change, after the rebuild.

parycash 2 solutions 2 answers

Chosen Solution

To resolve the issue, you need to change the search settings on the Google home page. Top right hand corner, open the search settings and turn off the "Google Instant predictions".

Hope that helps !!!