X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox keep opening my last viewed page?

Posted

In options it shows that I have selected: "When Firefox Starts: open home page" and my home page is google.com. The issue is that I have it set to this, but every time I open Firefox it goes to the last page I viewed instead. Why does it do this and how can I make it stop?

Additional System Details

This happened

Every time Firefox opened

This started when...

When I updated to Firefox 4.

Installed Plug-ins

  • Cooliris embedded in a tab
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r153
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • NPWLPG
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Flagfox
4.1.1
true
{1018e4d6-728f-4b20-ad56-37578a4de76b}
ChatZilla
0.9.86.1
true
{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}
BlockSite
0.7.1.1
true
{dd3d7613-0246-469d-bc65-2a3cc1668adc}
Java Console
6.0.03
true
{CAFEEFAC-0016-0000-0003-ABCDEFFEDCBA}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
avast! WebRep
20110101
true
wrc@avast.com
Cooliris
1.12.2.44172
true
piclens@cooliris.com
Adblock Plus Pop-up Addon
0.2.3
true
adblockpopups@jessehakanen.net
Adblock Plus
1.3.5
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.link.open_newwindow
2
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110318052756
browser.startup.homepage_override.mstone
rv:2.0
browser.tabs.warnOnClose
false
dom.ipc.plugins.enabled.npcoolirisplugin.dll
false
dom.max_script_run_time
0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1301932197
places.history.expiration.transient_current_max_pages
40180
places.last_vacuum
1297360960
privacy.sanitize.migrateFx3Prefs
true
security.disable_button.openCertManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID
8086
Device ID
2a42
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2202
Driver Date
8-25-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16763, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
2/2 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that Firefox closes properly and that there are no hanging Firefox processes left. You can check that on the Processes tab in the Task Manager. Also make sure to wait a few seconds before closing down Windows after you have closed Firefox to ensure that Firefox gets enough time to finish closing.

See also "Hang at exit":