X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Despite setting a Home Page Firefox always opens in the last page viewed. How do I solve this?

Posted

I have followed the instructions for setting a Home Page. Firefox always opens in the last page I viewed. Clicking on the Home icon does take me to my Home Page once Firefox has opened.

Additional System Details

Installed Plug-ins

  • iTunes Detector Plug-in
  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • Google Update
  • Garmin Communicator Plug-In 4.0.4.0
  • Coupons, Inc. Coupon Printer Plugin
  • Motive Plugin for Mozilla Browsers
  • NPWLPG
  • Google Updater pluginhttp://pack.google.com/
  • 20-20 3D Viewer for WEB - Mozilla Plug-In v5.0.94.0
  • GEPlugin
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • 20-20 3D Viewer - WEB 5.0.94.0 (2020Player_WEB@2020Technologies.com)
  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Norton Toolbar 2013.4.3.7 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.0.0.380 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 3.1.0.20130818030116 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 2400
  • adapterDescription2:
  • adapterDeviceID: 0x94c3
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 11-9-2011
  • driverDate2:
  • driverVersion: 8.920.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 2400 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: http://www.theguardian.com/uk
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: True
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • general.useragent.extra.zencast:
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1381155896
  • places.history.expiration.transient_current_max_pages: 93913
  • places.history.expiration.transient_optimal_database_size: 85834792
  • places.last_vacuum: 1313236374
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cache: False
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1381229506

Misc

  • User JS: Yes
  • Accessibility: No
Aniello 75 solutions 633 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Vineet_Rc 10 solutions 29 answers

Apart from setting the home page, have also informed Firefox to use it?

Question owner

Thanks. I tried Safe Mode but still have the problem.

Question owner

Thanks. I did inform Firefox to use the Home Page

Aniello 75 solutions 633 answers

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Helpful Reply

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

Your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Question owner

Thanks. I think I have solved the problem by using Safe Mode and then selecting Reset. This appears to have kept Bookmarks, and other settings but has removed addons etc. Firefox now opens at my reset Home Page. Thanks for your suggestions.

Helpful Reply

Thanks. I think I have solved the problem by using Safe Mode and then selecting Reset. This appears to have kept Bookmarks, and other settings but has removed addons etc. Firefox now opens at my reset Home Page. Thanks for your suggestions.