X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4 Back, forward, refresh buttons not working

Posted

Upgraded to Firefox 4 yesterday. Had problems navigating as the back, forward, and refresh buttons would not work. URLs would also not show up at times. Reverted back to 3.6 and now no issues. Anyone else having this problem?

Additional System Details

This happened

Every time Firefox opened

This started when...

Upgraded to Firefox 4

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

More Information

HankSnow 0 solutions 1 answers

I solved this problem by deleting the preferences file and letting Firefox create a new one. I lost all my preferences, however, which was a bother but not a huge one.

To try this, close Firefox 4 and open the profile folder for Firefox. If you need help finding where your profile is located, see this link:

http://kb.mozillazine.org/Profile_folder

In that folder, send the file called prefs.js to your recycle or trash bin. Then restart Firefox. The buttons should work correctly -- at least they did for me.

If you find it is too troublesome to lose the preferences, you can restore the file from your computer's recycle or trash bin. Be sure and do this when Firefox is NOT loaded as it overwrites the pref.js file when it closes.

I keep a list of changes that I make to the preferences file for all our systems, so resetting these was not a great burden. I found it rather worse not to be able to use the BACK button.

I noticed that my preferences file was loaded with obsolete settings from uninstalled extensions that did not clean house when leaving. Perhaps it is better to fumigate the preferences to keep this from happening again.

Before discovering this, I messed around trying to change obvious settings, such as those associated with history, to no avail. I also uninstalled all the existing extensions, also to no avail. This solution got it working again. Oddly, I only had this problem on one of our six systems.

Cheers

Modified by HankSnow

MarBo 0 solutions 1 answers

Helpful Reply

I had this problem too and I solved it deleting line "user_pref("browser.sessionhistory.max_entries", 0);" in my prefs.js

Question owner

I had to back up my bookmarks and remove pretty much everything under C:\Users\<Windows login/user name>\AppData\Roaming\Mozilla\Firefox\Profiles\

It solved the problem. Now Firefox 4 runs great!

GrayGeek 0 solutions 1 answers

I tried the solutions that dealt with prefs.js, and they did not work for me; however, I found a solution on a different web site that did work. I had installed McAfee SiteAdvisor (as I always do) after installing Firefox 4, and that was causing the problem. Disabling SiteAdvisor fixed the problem on my installation of Firefox 4.

TZANETTI 0 solutions 1 answers

Create a new profile

Modified by TZANETTI