X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Blurry/ugly font-rendering in Firefox 4 RC

Posted

The font-rendering in Firefox 4 RC doesn't look quite right; the fonts are too light and seem a bit blurry. With hardware acceleration disabled, they look much better, but I'd rather not disable hardware acceleration if possible since I would lose out on the benefits of it. Here are some comparisons: Internet explorer and Firefox 4 RC font-rendering and Firefox 3.6.15 and Firefox 4 RC font-rendering You can also see how the spacing is a bit odd with Firefox 4 RC.

This is on Windows 7 SP1 64-bit with a Radeon HD5850 (latest drivers) if it makes any difference.

Is my only option to disable hardware acceleration?

Modified by misfeasor

Chosen solution

Reset the page zoom on pages that cause problems.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
NoScript
2.0.9.8
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
TinEye Reverse Image Search
1.1
true
tineye@ideeinc.com
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110303194838
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
192992
places.last_vacuum
1298747263
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5800 Series
Vendor ID
1002
Device ID
6899
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.821.0.0
Driver Date
1-26-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563, font cache 1.55 MB)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
1/1 Direct3D 10

gwmbox 1 solutions 12 answers

I find it amazing that this issue was not picked up in the RC's or Beta's, or has this only happened since the final release? Did the RC's not have this problem?

This needs a fix, any Firefox devs care to comment?

GW

simonzxcv 0 solutions 1 answers

We are a software development company and we cannot accept a fix in which we would have to tell customers to solve the problem with browser adjustments. It is unacceptable to have such an obvious flaw with this font rendering problem. You will drive our customers to chrome ...

keverineke 0 solutions 1 answers

My screen is only blurry on facebook, not on other website's.

Here a screen.

technog 0 solutions 1 answers

I am having the same problem with firefox 4. The fonts are quite horrible and actually, incorrect compared to what was being displayed with firefox 3.6.x. Eg. when using Yahoo mail, all the "have read" emails would show up in a regular font while the unread email subjects would show up in a bold font.

Now with ff 4, ALL emails show up as a very ugly bold font !!! and the rest of the page seems to not render as crisply as the previous version of ff.

I tried ms clear type tool but that didnt seem to help any. Is there a list of fonts that I could default per application, much like XWindows did ??

levymetal 0 solutions 1 answers

I can confirm that advgmni's solution worked for me. Just had to restart firefox for the fonts to become fixed. 'Tis a damn shame we need to disable direct2d though.

geminiman7 0 solutions 10 answers

So frustrating. People should NOT have to use a Microsoft font tuning tool, update graphic card drivers and mess with system preferences just to see fonts decently in Firefox 4. There's obviously something wrong in the way the way fonts work WITHIN Firefox 4.

Like everyone else, I am experiencing horrible font rendering issues. With smoothing turned on in FF4, the fonts are too blurry, thin and not easy to read. With smoothing turned off, many fonts are extremely pixelated to the point where it's difficult to read also.

How IN THE WORLD did Firefox 4 get out the cage with this affliction?

Attached is snippet of an MSNBC.com web page with font smoothing disabled...

skideh 0 solutions 1 answers

Google helped here...

http://www.manast.com/2010/09/10/how-to-fix-bad-fonts-in-firefox-4-beta-5/

Just set "gfx.direct2d.disabled" in about:config to true. Then restart firefox. This worked!!! My fonts look nice again!!!

dbajarca 0 solutions 2 answers

Odly enough, once I installed Internet Explorer 9 my problem seems to be solved. There's room improving with the cleartype tuner, but at least for me, the problem is fixed.

Have a look at the attached images (specially at the bold fonts and compare the results for yourself).

PS: The editor did not let me place this reply under my original post. You may find it on top of the second page.

Modified by dbajarca

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

See also:

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

dbajarca: The reason that installing IE9 works is that it ships (on machines that need it) a major rendering improvement to DirectWrite (which is Microsoft's native font rendering). This is what Firefox uses to accelerate font rendering since it's a lot faster than any software solution.

For some users that's all that's the problem. For others, the cleartype settings are wrong and for others, the drivers simply aren't supported by directwrite.

num_num 0 solutions 6 answers

Here are all my findings regarding FF4(now final/stable) font rendering and HA(hardware acceleration):

1. You can now find a lot of blogs preaching about the magical font fix. However, this is not a fix! When you disable HA(from the check box option or from about:config), the browser is going to feel a lot slower. Scrolling becomes very slow, all the graphic objects are going to be rendered very slow(the old way, on the CPU only).

2. You cannot use microsoft cleartype. Just do not use it! Any other application renders fonts perfectly. You just cannot adjust the fonts only for your web browser. It is going to create a totally different mess.

3. Anti-Aliasing Tuner is a very handy extension. Unfortunately, achieving better font quality than FF4 standard(with HA) is impossible. I found out that switching to ClearType - GDI Classic is almost perfect, but it comes at a very big cost: spacing between characters becomes a mess. I believe that the AA tuner has the same direct2d/write limitation that the mozilla devs are facing.

3.1 The Anisotropic Filtering option from your GPU's driver seems to affect a little the direct2d font rendering. Try to completely disable it or switch it to something like "application controlled". However, I wasn't able to achieve wonders in doing so.

There are so many reviews out there and nobody seems to mention this. It is a shame that HA becomes useless because of this issue. Using the browser without HA is like running only single threaded apps on an 8 thread machine. Unfortunately, I ended up using FF4 only with HA off. It is the only way.

Fluii.dk 0 solutions 1 answers

To fix problem: Disable Morphological Filtering in Catalyst Control Center > 3D Settings

k1darkknight 0 solutions 1 answers

Morphological Filtering was the EXACT problem! I tried SO many different things, figuring it was something new in Firefox 4 that was the issue...when it was actually something in Firefox 4 that reacted badly to a (new to me) feature of my new video card!

andri0173 0 solutions 3 answers

Is there anything like Morphological Filtering in nvidia driver settings?

ssouza 0 solutions 2 answers

Firefox 4 doesn't display Lucida Sans correctly for me, but it was working fine on everyone else's Firefox 4, at work. I uninstalled and reinstalled a few times, no change. FInally, I decided to allow the Firefox 5 download and still the same problem when in all my other browsers, Chrome, IE, Safari were displaying Lucida Sans correctly. I had to revert back to FF3.6 for now. Once I did that Lucida Sans now looks exactly like it should. Very frustrating for a web developer. Please fix

Musafir_86 1 solutions 4 answers

Hi everyone,

-It seems this issue is properly fixed now (at least in my case) after I installed hotfix/patch KB2545698 from Microsoft. It should be installed automatically by now for Windows users which have Automatic Update enabled, but you could also get it manually from http://support.microsoft.com/kb/2545698 too.

-Hope this helps. :)


Regards.

michaelsmith035 0 solutions 1 answers

To display web pages, Firefox uses the Gecko layout engine, which implements most current web standards in addition to several features that are intended to anticipate likely additions to the standards.

http://www.techyv.com/questions/firefox-3-vs-firefox-4-which-best-version

Amaury 0 solutions 2 answers

I have Firefox 8.0.1, and I also have this.

However, it was fine until I upgraded from Windows XP to Windows 7 last night.

It's really noticeable on the duration time of YouTube videos. Check the screenshot.

Also of note: The header, where it says "Last Updated", was not bold before the upgrade -- it was on Internet Explorer before and after the upgrade, but not on Mozilla.

Thanks in advance.

Not really important, but for the record, my time zone is Pacific.

- Amaury

Modified by Amaury

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

@Amaury

Do you have an extension like NoSquint?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

dm01 0 solutions 6 answers

I have similar problem. I tried hardware acc tip and safe mode tip. Nothing changes.

Here is screen shot (firefox vs IE) :