X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Blurry/ugly font-rendering in Firefox 4 RC

Posted

The font-rendering in Firefox 4 RC doesn't look quite right; the fonts are too light and seem a bit blurry. With hardware acceleration disabled, they look much better, but I'd rather not disable hardware acceleration if possible since I would lose out on the benefits of it. Here are some comparisons: Internet explorer and Firefox 4 RC font-rendering and Firefox 3.6.15 and Firefox 4 RC font-rendering You can also see how the spacing is a bit odd with Firefox 4 RC.

This is on Windows 7 SP1 64-bit with a Radeon HD5850 (latest drivers) if it makes any difference.

Is my only option to disable hardware acceleration?

Modified by misfeasor

Chosen solution

Reset the page zoom on pages that cause problems.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
NoScript
2.0.9.8
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
TinEye Reverse Image Search
1.1
true
tineye@ideeinc.com
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110303194838
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
192992
places.last_vacuum
1298747263
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5800 Series
Vendor ID
1002
Device ID
6899
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.821.0.0
Driver Date
1-26-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563, font cache 1.55 MB)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
1/1 Direct3D 10

Constantine 0 solutions 1 answers

Your rendering is SO UGLY and completely broken in comparison with 3.6 so I remove firefox. Hello chrome.

Toxxel 0 solutions 2 answers

Cleartype did nothing, I had 4.0 installed after about an hour of use my eyes started bothering me. I started having problems reading standard text, and my eyes were hurting. I'm running windows 7 Home SP1, with a radeon 4870, my video drivers are updated, and cleartype was already enabled and tweaking it did nothing.

I was going to take a screenshot to show how blurry it looked. Strangely enough after taking the shot, I was compairing and screen to the browser window and the image captured didn't display text at all how it looked on the browser. It looked normal in the screenshot. I've reverted to 3.6.16 after trying to disable hardware acceleration with 4 but it didn't really change anything.

M1cha3lK 0 solutions 1 answers

I've installed Firefox 4.0 now on 5 of my machines and all those who have a recently new graphics driver (where Direct2D is automatically Enabled) The fonts look ugly and blurry.

I have machines with both nvidia and intel gma cards.

I opted as a work around to disable the HW acceleration to get the old style which is okay...but a bit of a shame since the GPU acceleration was supposed to be this next great feature :-(

I guess many people on this thread who do not have this problem probably do not have the Direct2D enabled. So please check "about:support" before replying and saying my fonts look just fine...because they probably don't :-)

Se attached picture for a comparison between Firefox, chrome, opera and IE 9. As noted on other forums both Firefox and IE suffer from the same problem.

Modified by M1cha3lK

Wolf 0 solutions 2 answers

I just upgraded to 4, and the first thing I noticed was this same problem on some fonts-notably the ones I look at most, like stuff in Gmail, forums I frequent, etc. They look blurry, like screwed up anti-aliasing or something, and I've NEVER seen that from Firefox on Windows before. Almost looks like OS X's terrible font rendering, or how older versions of Safari on Windows used to use their own OS X-like font rendering system...except it doesn't seem to do it for ALL fonts.

I really, really want to use Firefox both because I like it and have been using Mozilla browsers since like 0.8 of the first release (years before Firefox) AND because I want to use Open Source software whenever I can...but this is really, really hard to look at. One of the big reasons I don't run OS X (besides lack of Blu Ray) is the terrible font rendering, so....this might actually get me to switch to another browser. I've never even bothered installing Chrome before, but...

Anyway if it matters I'm running Windows 7 64-bit SP-1, Nvidia's newest drivers, etc. I have ClearType *OFF* in Windows, as while I think ClearType is better than how OS X does it, I still dislike it. I've tried toggling hardware acceleration in Firefox off, but it actually looks...different, but maybe even worse to me, even blurrier.

terrrabit 0 solutions 1 answers

I had the same problem after installing firefox 4 and i fixed it by accident - i turned off cleartype in the windows 7 display options (right+click desktop, personalize, display, adjust clear type text) and suprisingly the fonts in firefox 4 are rendered ok now.

I figure firefox 3.6 was unaffected by the windows cleartype options and firefox 4 somehow is.

northlondon01 0 solutions 3 answers

Just thought I'd add I have the same problem with 4.0 and have gone back to 3.6.

I have W7 Ultimate, 32bit, SP1 and HD5670 (which also has given me issues with video rendering on MEdia Centre/WMP, but not in QT, MPC etc.

Question owner

I apologize for marking this solved. (I can't seem to undo it)

The ClearType tuner helped to turn extremely blurry fonts in Firefox 4 RC (as in my original posted images) into slightly blurry fonts and I assumed the reason for the remaining perceived blurriness was just an artifact of being used to GDI+ font-rendering. However, having now tested IE9 with hw accel on, I can say font-rendering in Firefox 4 is still significantly worse.

Here is a comparison of font-rendering in FF4 and IE9 with hw acceleration on and ClearType tuner having been used.

Modified by misfeasor

joema 0 solutions 1 answers

I confirm the previous post. Font rendering with h/w accel is significantly worse in FF4 than in IE9.

Windows 7 Home Premium SP1 64-bit EVGA P55 FTW motherboard (A72 BIOS) GPU: EVGA nVidia GeForce GTX-275 896MB, driver: 8.17.12.5896(258.96)

dbajarca 0 solutions 2 answers

I've ran into a similar problem with FF4 and an ATI Radeon 4870 running Catalyst 11.2. When GPU acceleration is enabled fonts tend to get rough edges. This is mostly notable with bold fonts. To get an idea, please have a look at the two attachments.

northlondon01 0 solutions 3 answers

Have you noticed any other issues since you installed 11.2? I think this was the version I updated to as soon as I installed my 5670, but I'm having various rendering problems in Media Player and Media Centre too and wondered if it's a windows thing or a ATI driver thing.

I installed FF4 on my netbook and it runs perfectly.

satovey 0 solutions 1 answers

I had a bigger issue than just poor font display. When I ran Firefox 4 RC and opened the menu panels, they spilled over fine, but when they covered parts of the desktop outside Firefox, the desktop did not refresh properly when those panels were subsequently closed.

The end result was that text was left on the task bar.

This did not happen with IE 9, nor does it happen with Chrome.

Firefox's hardware accelerator takes up to much of the GPU's resources. It needs to be refined and stream lined so that it does not require slow down the GPU.

FYI, I am not going to go through a bunch of hoops upgrading and fine tuning my system just so that your browser works properly on my system. I will instead, just simply using Firefox.

As it is, I'm staying with 3.6. By the way, I tweeted that Firefox 4 was ready, however, when I seen how poorly it performed on my computer, I tweeted a retraction and told followers to wait.

If you want me to promote your browser, it's quality must be "no less than the best."

      NOT

" that will do for now. "

Scott A Tovey

solarisomnium 0 solutions 1 answers

Same problem in Windows Vista. My solution: set "gfx.direct2d.disabled" to "true" in "about:config". After that fonts work fine in my system.

advgmni 0 solutions 1 answers

Same problem: Win 7 (no service pack yet). ATI Video Card.

Fix: "about:config"

gfx.direct2d.disabled set to "true"

gfx.use_text_smoothing_setting set to "true"

I had to close ALL of my FireFox windows to see the updated results. Fonts are now smooth.

Modified by advgmni

wildcard1974 0 solutions 3 answers

I was able to correct this and still have hardware acceleration without the Anti-aliasing addon. The issue seems to be that during an upgrade from 3.x, the 'key' that controls DirectWrite may not be added.

To see if this is your problem type in 'about:support' (without the quotes) in the Firefox address bar. You will get info about the browser. Under the section labeled Graphics, confirm that you have the following:

Direct2D enabled=true DirectWrite enabled=true

If DirectWrite enabled=false, you will need to type 'about:config' (without the quotes into the address bar. This will take you to the Firefox config window. Look for the following key: mozilla.widget.render-mode

That key is probably not present. To add it, right-click on an empty section of that window, choose New, and then Integer. Type in 'mozilla.widget.render-mode' (without the quotes) and assign it a value of 6. If you have this key and the value is anything other than 6, right click on the key and choose Modify, and change the value to 6

Close and reopen your browser, and your fonts should look better. You may want to type in 'about:support' again and confirm that DirectWrite enabled changed from false to true.

This worked on Windows 7; it's worth trying for other operating systems and *shouldn't* break anything regardless of whether it works or not.

Question owner

That key is definitely present and set to true for me at least. (You can see all of my about:support information by clicking "More system details..." to the right of my original post)

Musafir_86 1 solutions 4 answers

-Hmm, besides tuning Windows' ClearType configuration, maybe you could also try to use Anti-aliasing Tuner for Firefox 4 here: https://addons.mozilla.org/en-US/firefox/addon/anti-aliasing-tuner/ .

-FWIW, in my case, I put both "Enhanced Contrast" and "ClearType Level" to 100% and other settings to "Default", for both "Small Font" and "Large Font".

-BTW, you may want to tweak your monitor brightness & contrast too. Hope this helps.

ADDENDUM: You need to restart your browser each time you make a change.


Regards.

Modified by Musafir_86

andri0173 0 solutions 3 answers

here [https://bugzilla.mozilla.org/show_bug.cgi?id=635490#c76] another settings for firefox anti-aliasing-tuner. Fonts look better, almost like FF3. But I still want the developers make fonts look as good as they were in FF3.

wildcard1974 0 solutions 3 answers

I have an NVIDIA chipset; that may be a factor. Did you also have the mozilla.widget.render-mode key set to 6 in your about:config? It normally defaults to -1. I didn't see that listed in your original system details.

Question owner

The mozilla.widget.render-mode key isn't present in current builds, as it was removed in resolving Bug 596494 - Update render mode on device removal I believe. Still, I added the key and set the value to 6 just in case, but did not see a difference.

gwmbox 1 solutions 12 answers

Having the same issues as most above, in particular the font I am having issue with is Trebuchet MS, but many other fonts too. Clear type has been adjusted, turned off and on and even re-installed FF4 but to no avail. This is a VERY poor result for what was supposed to be a 'better' browser, it makes it next to useless to use.

GW