X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Blurry/ugly font-rendering in Firefox 4 RC

Posted

The font-rendering in Firefox 4 RC doesn't look quite right; the fonts are too light and seem a bit blurry. With hardware acceleration disabled, they look much better, but I'd rather not disable hardware acceleration if possible since I would lose out on the benefits of it. Here are some comparisons: Internet explorer and Firefox 4 RC font-rendering and Firefox 3.6.15 and Firefox 4 RC font-rendering You can also see how the spacing is a bit odd with Firefox 4 RC.

This is on Windows 7 SP1 64-bit with a Radeon HD5850 (latest drivers) if it makes any difference.

Is my only option to disable hardware acceleration?

Modified by misfeasor

Chosen solution

Reset the page zoom on pages that cause problems.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
NoScript
2.0.9.8
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
TinEye Reverse Image Search
1.1
true
tineye@ideeinc.com
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110303194838
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
192992
places.last_vacuum
1298747263
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5800 Series
Vendor ID
1002
Device ID
6899
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.821.0.0
Driver Date
1-26-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563, font cache 1.55 MB)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10741 solutions 96657 answers

Chosen Solution

Reset the page zoom on pages that cause problems.

Wolf 0 solutions 2 answers

Did turning off hardware acceleration help you? Either the rendering has gotten better, or I've gotten used to it, but to me with hardware acceleration turned off, it seems like it looks normal now, at least as of Firefox 8.

It's annoying to have to turn it off, since hey, hardware acceleration always seems like a good thing, but I guess most browsers don't have that anyway.

At any rate, I'm finally using the new versions instead of 3.6 thanks to that setting, and whatever tweaks they may have done. But yeah, your picture looks like the type of thing I was seeing too.

Amaury 0 solutions 2 answers

Hi, Corel! Thanks for the response.

The weird thing about this is that my mom also has Windows 7 and also has Mozilla with the same QSQ theme, and it's not happening on hers.

One thing I noticed is that it's only when it's maximized. For example, if I click the the square and make the window smaller, the text is normal.

Even if I have it stretched out across the screen as if it were maximized, but not, everything's normal, but when it's maximized, it does that.

Also, on forums, if I'm adding BB code to things, such as bold, then the text kind of turns to a highlighted green-ish color, even though I have nothing highlighted -- plus, the highlighted color is white.

Again, though, for the above, if the window is not maximized, it's normal.

EDIT: Scratch that. Same thing happens with Mozilla on my mom's PC. However, it's the same as mine. If it's not maximized...

Modified by Amaury