X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Blurry/ugly font-rendering in Firefox 4 RC

Posted

The font-rendering in Firefox 4 RC doesn't look quite right; the fonts are too light and seem a bit blurry. With hardware acceleration disabled, they look much better, but I'd rather not disable hardware acceleration if possible since I would lose out on the benefits of it. Here are some comparisons: Internet explorer and Firefox 4 RC font-rendering and Firefox 3.6.15 and Firefox 4 RC font-rendering You can also see how the spacing is a bit odd with Firefox 4 RC.

This is on Windows 7 SP1 64-bit with a Radeon HD5850 (latest drivers) if it makes any difference.

Is my only option to disable hardware acceleration?

Modified by misfeasor

Chosen solution

Reset the page zoom on pages that cause problems.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
NoScript
2.0.9.8
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
TinEye Reverse Image Search
1.1
true
tineye@ideeinc.com
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110303194838
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
192992
places.last_vacuum
1298747263
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5800 Series
Vendor ID
1002
Device ID
6899
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.821.0.0
Driver Date
1-26-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563, font cache 1.55 MB)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try to toggle some of the gfx and layers prefs on the about:config page to enable or disable some features.
Filter: /gfx|layers/

Modified by cor-el

Question owner

Only setting gfx.direct2d.disabled to true helped but I believe this is the same as disabling 2d acceleration, which is what I want to avoid.

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Well, it usually means that you have an unsupported driver or a problem with directwrite.

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

The other thing is that you can try tuning cleartype: http://www.microsoft.com/typography/cleartype/tuner/tune.aspx

Question owner

Using the configuration options for cleartype, I was finally able to get the fonts to display okay. They still aren't nearly as crisp or nice as without hardware acceleration on, but they are at least good enough to not warrant disabling hardware acceleration.

I think the fonts not looking as nice using cleartype would be a different question/bug, so I'm marking this solved.

Edit: I can't seem to remove marking it solved, unfortunately. ClearType tuner did indeed make fonts appear slightly better and less blurry, but having now compared the results to IE9 with hw acceleration on, it is clear that Firefox 4 still has significantly worse font-rendering.

Modified by misfeasor

num_num 0 solutions 6 answers

Helpful Reply

Just installed FF 4 RC. It is unsolved and unacceptable! Fonts should not look uglier than version three!

Compared to version 3.X, the current font rendering(4 RC, under Windows 7) is unacceptable. Turning off "GPU hardware acceleration" is not an option, since this is a browser feature and you're gonna fall behind IE and Opera. If this a driver issue, put pressure on AMD, Nvidia or Microsoft to fix this until the final release of FF 4!

I care about my favorite browser. This is the reason of my post. Please fix this in the final 4th release! You're going to lose a lot of users, including myself.

Modified by num_num

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Make sure that you have updated the graphics display card driver to the latest version.

num_num 0 solutions 6 answers

Thanks for your reply, cor-el!

I'm using the latest stable catalyst(11.2) on an ATI hd5700 series under Windows 7. Fonts look even worse than in the screens provided by misfeasor. Just switched back to 3.X version. I just hope that the developers are not going to screw these release up.

chal 0 solutions 1 answers

I have same configuration and same driver and same problem... Once I try new 11.4 preview driver and still have problem with fonts.

It s looks great only with acceleration off :( Hope that will be improved in final ff4...

lulzchicken 0 solutions 7 answers

I also have this problem, and the only way to get back decent fonts is to set "gfx.direct2d.disabled" to "true". However, that basically disables Hardware Acceleration. Which, is one of the best improvements in this new version of the browser. Can Firefox/Mozilla PLEASE work this out with Microsoft/ATi? I think that is there the problem lays. It's simply unacceptable.

Nayden Gochev 0 solutions 2 answers

yeah this fonts thing is crap.. if you didnt fix this this will mean that noone will use GPU acceleration because it basically brakes the fonts. Actually this is broken even in IE9.. check https://picasaweb.google.com/lh/photo/5Rf1kaJFL1yg9QYUOgrT1A?feat=directlink yes you have to zoom on max to see the difference. So I dont think even microsoft can help .. please fix this otherwise I will start using chrome the only browser with GPU acc and nice fonts. or you can click on the uploaded image. Please fix this lets dont make it UGLY as microsoft did.

Nayden Gochev 0 solutions 2 answers

actually I found that this is an issue in DirectWrite so.... dont know what can be done...

aszr 0 solutions 1 answers

Same problem here. What is the point of adding GPU acceleration as one of the big new features of the browser if it is going to make all of the font rendering look like this.

This is making me want to switch to Chrome which I really don't want to do because I enjoy Firefox so much.

lulzchicken 0 solutions 7 answers

I agree, I also have this issue. I've tried every fix/remedy there is on the internet. However, NOTHING works. The ONLY way I can keep Hardware Acceleration enabled while enjoying crisp fonts is while in Safe Mode. That's the ONLY way. Once I get back on my home computer I'll upload an image to show you. I'm currently browsing with HA turned off, which blows. This may not be a VERY widespread issue, but it still is an issue! Someone needs to work this out with Microsoft, or whoever is responsible. Just for the record, my windows is up to date (SP1) and all the DirectWrite patches say they are already installed. Same with video card drivers. They're up to date as well. wtf?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If layers.acceleration.disabled is false then you should still have hardware acceleration.

andri0173 0 solutions 3 answers

Helpful Reply

Same here. Firefox 4.0 final release (not RC). Ugly font rendering. GF GTX570 with 266.58 driver version on Windows 7 x64.

Why it is marked as solved? Its NOT SOLVED!

Tuning ClearType does not bring clear fonts, as they were in FF 3

Modified by andri0173

Kyplor 0 solutions 1 answers

I decided to go back to 3.6.15 until this is resolved. I'll keep following this thread, though.

Nemolus 0 solutions 1 answers

Unfortunately gfx.direct2d.disabled setting to true did not work for me, not in RC1 or RC2 or the final version. Please fix it.

Tried on Thinkpad x301, Intel GMA4500, win7 sp1 x64bit ultimate.

Rodpad 0 solutions 2 answers

Same issue on 4.0 Final. Plus as you can see from my attatched image, it doesn't to it to all text. Very confusing, difficult to read and annoying.

This was was in the test versions and I assumed fixed in the Final. If this isn't resolved soon I'll roll back to 3.6.

codeworks 0 solutions 1 answers

Just to add my voice, I have the same ugly font problem, and none of the settings changes etc have solved it. I may have to revert to 3.6 as it is hurting my eyes!