X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

mailto links are not working. How do I set mailto: links to open in Outlook?

Posted

mailto: links used to open in Outlook. Then they began opening Gmail, so I uninstalled the Google Toolbar. Now mailto: links do nothing when I click on them. I've tried deleting the mimeTypes.rdf as recommended by File types and download actions. I also see that my mailto: is set to Outlook as shown by my Applications setting, but the links are still not working, even though they work in IE. Ideas?

Modified by Noah_SUMO

Additional System Details

This happened

Every time Firefox opened

This started when...

Within the past couple days.

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • np-mswmp
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • AlternaTIFF v1.9.3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • PDF-XChange Viewer Netscape Gecko Plugin
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Live Update v1.4
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 AlexaToolbar/alxf-1.54 Firefox/3.6.15

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96704 answers

Helpful Reply

You can look at the network.protocol-handler.external.mailto prefs on the about:config page.

If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

You can also try to change the network.protocol-handler.warn-external.mailto pref to true.


Question owner

Hallelujah!

Maybe I should have figured that out on my own, so extra Thank You!

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96704 answers

You're welcome

kathleen.corum@gmail.com 0 solutions 2 answers

I'm trying to get it to open in gmail. The about:config setting is correct, I believe, at false ... gmail is not external. And in the tools>options, gmail is set. But I get that error message

Will_T 0 solutions 3 answers

I had this problem too and it was driving me crazy. I then opened aboutconfig and searched for anything to do with mail. I found entries having to do with the Google Toolbar which I no longer have. I guess the entries are left even after the Toolbar is uninstalled?

One of these entries was: google.toolbar.mailto.gmail.configured;true

I toggled that to false and all was fixed. I suppose I could delete all the entries having to do with the Google toolbar, but this toggle was all that was necessary to get the mailto working with Outlook again.

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

Helpful Reply

I found entries having to do with the Google Toolbar which I no longer have. I guess the entries are left even after the Toolbar is uninstalled?

Will_T, You are correct. See http://kb.mozillazine.org/Changing_the_mail_program_used_in_Firefox#Extension_issues

The Google Toolbar for Firefox includes a "Send with Gmail" feature that changes the mail program used in Firefox to Gmail, regardless of what is set in Firefox options or your system default mail program. It is recommended that you do not select the "Send with Gmail" option in the Google Toolbar. Firefox already has a "Use Gmail" option available by default in the Applications listing for mailto actions. More importantly, uninstalling the Google Toolbar extension with the "Send with Gmail" feature enabled may leave you with Firefox opening nothing at all for mailto links. You can resolve this issue by resetting the Firefox user preference network.protocol-handler.external.mailto to the default "true" value in [[about:config]]. See Reset Firefox preferences to troubleshoot and fix problems for details.
Note: the Google Toolbar is no longer supported by Google for Firefox 5 and up.

fgordis 0 solutions 4 answers

where is the network.protocol-handler.external.mailto?

fgordis 0 solutions 4 answers

I also want it to open gmail, and it does not open mailto links. Firefox is becoming too much trouble. I plan to switch to Google Chrome. My mailto links work there.

Modified by fgordis