X
Tap here to go to the mobile version of the site.

Support Forum

Firefox displays strange characters instead of normal text in certain sites.

Posted

Every time I go to Wikia or Wikipedia or even signing in to my AIM mailbox OR even type the code in reCaptcha. I always encounter the strange characters issues instead. I tried to follow all the so called solutions provided but none ever work. I had to rely on Chrome to go to these websites because FF can't. I even hard-reset on my profile.

Every time I go to Wikia or Wikipedia or even signing in to my AIM mailbox OR even type the code in reCaptcha. I always encounter the strange characters issues instead. I tried to follow all the so called solutions provided but none ever work. I had to rely on Chrome to go to these websites because FF can't. I even hard-reset on my profile.

Chosen solution

Use this test to see if the Helvetica font is causing it (Copy & Paste the code in the location bar and press Enter):

data:text/html,
Helvetica<br><font face="Helvetica" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font><br>
Helvetica Neue<br><font face="Helvetica Neue" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font>


The text should also display correctly if you disable the website fonts.

Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"

Read this answer in context 13

Additional System Details

Sites Affected

http://bleach.wikia.com/wiki/Rukia_Kuchiki

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • npunagi2
  • 6.0.12.69
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 1.9.0009.1
  • ijji Auto Install Plugin for Mozilla
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • 4.0.51204.0
  • Office Live Update v1.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Nexon Game Controller
  • Nexon Game Controller 1.0.1.0
  • Version 1.1.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.13
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Java Console
6.0.23
true
{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
Microsoft .NET Framework Assistant
1.1
true
{20a82645-c095-46ed-80e3-08825760534b}
Default Manager
2.2
true
{3252b9ae-c69a-4eaf-9502-dc9c1f6c009e}
Download Statusbar
0.9.7.2
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
LastPass
1.70.0
true
support@lastpass.com
Modified Preferences
Name
Value
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.13
extensions.lastAppVersion
3.6.13
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true

T89 0 solutions 1 answers

Hi there,

The only thing I can really suggest is:

1. Uninstall firefox, and re-install the latest version.

Alternatively, switch off any addons you have downloaded and revisit the site, if it appears normal, enable each addon one-by-one and when the problem occurs again, that last addon you enabled was causing the issue.

Let me know if this helped.

T

Hi there, The only thing I can really suggest is: 1. Uninstall firefox, and re-install the latest version. Alternatively, switch off any addons you have downloaded and revisit the site, if it appears normal, enable each addon one-by-one and when the problem occurs again, that last addon you enabled was causing the issue. Let me know if this helped. T
cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149455 answers

This issue can be caused by an old bitmap version of the Helvetica or Geneva font or (bitmap) fonts that Firefox can't display in that size.
Firefox can't display some old bitmap fonts in a larger size and displays gibberish instead.
You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.

Uninstall (remove) all variants of that not working font to make Firefox use another font or see if you can find a True type version that doesn't show the problem.
There have also been fonts with a Chinese name reported that identify themselves as Helvetica, so check that as well.


Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

This issue can be caused by an old bitmap version of the Helvetica or Geneva font or (bitmap) fonts that Firefox can't display in that size.<br /> Firefox can't display some old bitmap fonts in a larger size and displays gibberish instead.<br /> You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.<br /> <br /> Uninstall (remove) all variants of that not working font to make Firefox use another font or see if you can find a True type version that doesn't show the problem.<br /> There have also been fonts with a Chinese name reported that identify themselves as Helvetica, so check that as well. ---- Can you attach a [http://en.wikipedia.org/wiki/Screenshot screenshot]? Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Question owner

I uploaded a screenshot. It's not the typical box with numbers thing though I DO encounter it occasionally. It's more like that, *pokes screenshot* I tried your trick cor-el. It didn't work.

@Tom: Since I really don't have time to clean uninstall, reinstall my FireFox I'll do it in couple of days and if it doesn't work, I'm gonna kill something.

I uploaded a screenshot. It's not the typical box with numbers thing though I DO encounter it occasionally. It's more like that, *pokes screenshot* I tried your trick cor-el. It didn't work. @Tom: Since I really don't have time to clean uninstall, reinstall my FireFox I'll do it in couple of days and if it doesn't work, I'm gonna kill something.
cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149455 answers

You may need to look harder for that Helvetica font.
The top part of that text specifies: font-family: Helvetica,Arial,sans-serif;

I've seen a lot of similar screenshots like yours and they were all caused by an older version of Helvetica being installed.

Some had a version with a Chinese looking name.

Rukia Kuchiki (朽木 ルキア, Kuchiki Rukia) is an unseated Shinigami in the 13th Division under Captain Jūshirō Ukitake. Rukia is the younger sister of Hisana Kuchiki and the adoptive sister of Byakuya Kuchiki, as well as a friend of Ichigo Kurosaki.
You may need to look harder for that Helvetica font.<br /> The top part of that text specifies: font-family: Helvetica,Arial,sans-serif; I've seen a lot of similar screenshots like yours and they were all caused by an older version of Helvetica being installed. Some had a version with a Chinese looking name. <blockquote>Rukia Kuchiki (朽木 ルキア, Kuchiki Rukia) is an unseated Shinigami in the 13th Division under Captain Jūshirō Ukitake. Rukia is the younger sister of Hisana Kuchiki and the adoptive sister of Byakuya Kuchiki, as well as a friend of Ichigo Kurosaki. </blockquote>

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149455 answers

Chosen Solution

Use this test to see if the Helvetica font is causing it (Copy & Paste the code in the location bar and press Enter):

data:text/html,
Helvetica<br><font face="Helvetica" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font><br>
Helvetica Neue<br><font face="Helvetica Neue" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font>


The text should also display correctly if you disable the website fonts.

Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"

Use this test to see if the Helvetica font is causing it (Copy & Paste the code in the location bar and press Enter): <pre><nowiki>data:text/html, Helvetica<br><font face="Helvetica" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font><br> Helvetica Neue<br><font face="Helvetica Neue" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font></nowiki></pre> The text should also display correctly if you disable the website fonts. Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"

Modified by cor-el

Question owner

FIXED. Thanks for sticking with me. And thank you for the specific method to fix the problem I've been suffered for a year.

FIXED. Thanks for sticking with me. And thank you for the specific method to fix the problem I've been suffered for a year.
cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149455 answers

You're very welcome. It can be hard to fix such an issue, so thanks for reporting that you were able to fix it.

Can you tell which font you found?

You're very welcome. It can be hard to fix such an issue, so thanks for reporting that you were able to fix it. Can you tell which font you found?
safialex83 0 solutions 1 answers

Helpful Reply

Hi, I had the same problem until today for a while I removed all Helvetica fonts installed but it didn't work, if I used my own font choices it does work but this is not ok for me because I'm a Web Designer. I found a couple of Chinese fonts installed, I deleted them and YES everything worked nice for a while then the problem appeared again and this time is worse eveb in small text not only headers :( Plz c the pic. attached any help ??

Hi, I had the same problem until today for a while I removed all Helvetica fonts installed but it didn't work, if I used my own font choices it does work but this is not ok for me because I'm a Web Designer. I found a couple of Chinese fonts installed, I deleted them and YES everything worked nice for a while then the problem appeared again and this time is worse eveb in small text not only headers :( Plz c the pic. attached any help ??
Gordon 0 solutions 2 answers

I'm in the same boat as safialex83. I need to see the fonts as they are displayed by the site. I don't have Helvetica on my system. I may have the confusing Chinese fonts, but I don't know which ones I'd try. I run the Adobe Master Suite so there are a lot of fonts to fool with. Running cor-el's test the first row of Helvetica gives odd characters for the first half of the set.

Other than turning off website fonts or removing any font I don't recognize, is there a more nuanced approach to this problem I could try?

I'm in the same boat as safialex83. I need to see the fonts as they are displayed by the site. I don't have Helvetica on my system. I may have the confusing Chinese fonts, but I don't know which ones I'd try. I run the Adobe Master Suite so there are a lot of fonts to fool with. Running cor-el's test the first row of Helvetica gives odd characters for the first half of the set. Other than turning off website fonts or removing any font I don't recognize, is there a more nuanced approach to this problem I could try?
Gordon 0 solutions 2 answers

With help from folks at SpiceWorks I got this to work for me.

I looked in the registry and discovered that all the font references were correctly pointing Helvetica to Arial. However when I looked at HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Fonts it said that Helvetica was using Helvetica.ttf. Since I knew that was bogus, I deleted that reference. After a reboot of the machine I have recognizable English back on webpages everywhere.

With help from folks at SpiceWorks I got this to work for me. I looked in the registry and discovered that all the font references were correctly pointing Helvetica to Arial. However when I looked at HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Fonts it said that Helvetica was using Helvetica.ttf. Since I knew that was bogus, I deleted that reference. After a reboot of the machine I have recognizable English back on webpages everywhere.
Tabaski 0 solutions 1 answers

I am having a similar issue running on a MAC OS 10.5.8 and firefox 4.0.1. Most sites work well, but e.g. signing in to gmail.com shows strange characters - sometimes more, sometimes less. I added a screenshot. See e.g. the 'Reply' at the end which is displayed as Re/ ly or the sentence next to 'Privacy'. Either it displays strange characters or erases them. Help would be most appreciated. Things work ok with e.g. Safari.

I am having a similar issue running on a MAC OS 10.5.8 and firefox 4.0.1. Most sites work well, but e.g. signing in to gmail.com shows strange characters - sometimes more, sometimes less. I added a screenshot. See e.g. the 'Reply' at the end which is displayed as Re/ ly or the sentence next to 'Privacy'. Either it displays strange characters or erases them. Help would be most appreciated. Things work ok with e.g. Safari.
cor-el
  • Top 10 Contributor
  • Moderator
16553 solutions 149455 answers

On a Mac you can do a check for corrupted fonts and other font issues:

On a Mac you can do a check for corrupted fonts and other font issues: * http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html - CreativeTechs Tips: Garbled Fonts Troubleshooting Guide * http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts