Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search displays strange characters before search, firefox 3.6.7, ubuntu 10.04

more options

I get these strange characters when I go to Google search using Firefox 3.6.7 and Ubuntu 10.04.......see below ᎢᏳᏍᏗ ᎨᏒ ᎣᏲᎲᎢᎠᏑᏰᏍᏗ ᏳᏍᏗ ᎠᏁᎵᏔᏅ (These characters are on the Google search page before I search and below search bar. strange characters below: ᎾᏍᎩᏯᎢ Directory ᏚᎾᏓᏡᎬ What is going on....It reads OK using Chromium. I can't read anything. I am using Firefox 3.6.7. My View....character encoding is set to : Western(ISO-8859-1) and auto detect "on"

== ?

All Replies (13)

more options

I am having the same issue as roy gavilan. I am using Ubuntu 10.04 (x64) with Firefox 3.6.7. See screenshot for a better idea.

more options
more options

Maybe you should go to Google's front page, and at the bottom, it says "show in English" or something of the sort.

more options

I checked preferences and it was not set to American. I changed it to American and then I still got a bunch of weird characters. I went back and changed it to French and them went back and changed it to englaise and I'm now OK.....go figure. I have never had to set the language in Google before. I thought your solution was too simple and would not work. Thanks

more options

Should be I set it anglais....typo

more options

I installed updates to Ubuntu this morning and now I have the same problem again....I believe they were java and icedtea updates. English or USA are not even listed as a language choice.

more options

I decided to run "firefox -safe-mode" (Alt+F2).

Then I checked "Reset all user preferences to Firefox defaults". Things look OK now.

more options

I solved it by entering the google page configuration (right top corner), then search configuration. In the interface language menu was setted afrikaans. I couldn't find spanish (my language) or english, so i choose portuguese. Then, from the google main page (in portuguese, you can translate if don't understand) repeat the process and now there were all the languages, choose spanish, and problem solved.

more options

This worked for me as well. In my case, the dialog to reset preferences to defaults did not appear unless I closed all Firefox windows before executing 'firefox -safe-mode' .

There must be something funny going on in the about:config page Ubuntu released.

more options

I've just had this same problem. Resetting user preferences works fine.

This may not be true for everyone but the issue for me is being caused by Firefox Sync. I'm guessing (haven't had time to properly test) this is due to the fact that I'm syncing between Ubuntu (10.04) and Windows (XP and 7).

I can still use Firefox Sync but just have to disable preferences syncing on Ubuntu. If I get time I'll test it the other way (i.e. initial sync on Ubuntu and then sync those prefs to Windows).

On another note, the fix mentioned above about changing Google preferences is no good if you clear cookies etc. when closing Firefox as this removes any changes you make to the Google preferences and it defaults back to the incorrect settings.

more options

Just to update this topic if anyone else has the issue. I've fixed it by manually amending the following setting in about:config -

Preference name: intl.accept_languages

Value: en-gb, en

If you're in the US you'd use en-us, en instead.

I then re-ran Firefox Sync and now on the Windows machines this value shows up as User Defined instead of default and this is now kept when syncing (I'm assuming the default values are not included when syncing preferences, for obvious reasons).

Modified by nakor

more options

This fixes it all for me. No point fiddling with about:config, etc

Edit->Preferences->Content->"Choose..." (under Languages)

Remove the language that's there (or languages) Select your language and click "add" , "OK"

Restart Firefox - that should work.

Modified by crypto

more options

I'm running wattOS Linux R3 which is Ubuntu and Debian based. I'm using Firefox 4.0.1 and the problem only appears on the Dutch iGoogle page, not on the English version. You can see picture of the problem.