X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why do over 90% of YouTube functions no longer work on Firefox?

Posted

For the past week everything I try to do on YouTube with Firefox has been extremely slow, sometimes near that of a dial-up connection. I've tried using all three browsers--IE8, Firefox, and Chrome--and the problem appears to be ONLY with Firefox. In fact, with Firefox over 90% of YouTube features will not work at all, including playback on "My Channel".

All three browsers function perfectly at all other web sites.

My videos are being inundated with SPAM promoting several different illegal download sites, yet when I try to report these as SPAM I repeatedly get a "500 Internal Server Error" with all three browsers. Please keep in mind that these messages are sent to me by YouTube, NOT the spammers. The only browser that will actually allow me to delete the message itself from the video is Chrome...both IE8 and Firefox are totally unresponsive to all options.

When trying to access my channel page (or ANY channel page) on Firefox (and ONLY Firefox), I repeatedly get the message: "Hello, you either have JavaScript turned off or an old version of Adobe's Flash Player. Get the latest Flash player. " However, playing videos in a separate tab is not a problem with any of the 3 browsers. Accessing my channel page or any other channel page is not a problem with either IE8 or Google Chrome.

I have verified that the latest versions of Flash Player and JavaScript have been installed and are functioning properly, and everything on YouTube operates properly on both IE8 and the lastest version of Google Chrome.

I have updated McAfee and run a deep, full-system scan. I've swept my registry with three different cleaners, and Secunia PSI shows no problems.

This is the second time in the past two months that YouTube has shut out Firefox almost totally.

What is going on?

Paige

Additional System Details

Sites Affected

http://www.youtube.com/user/texpaco?feature=mhsn

Installed Plug-ins

  • Cooliris embedded in a tab
  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • Default Plug-in
  • 12.0.1.599
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.1 r102
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Chosen Solution

Try https://support.mozilla.com/en-US/questions/761826

Question owner

The problem appears to be getting worse--not better.

Now whenever I access YouTube with Firefox, the same problems as reported before still exist. I can then still navigate to other websites with no problems. However, once I have accessed YouTube, now I cannot shut down Firefox in ANY fashion other that with the Windows Task Manager (CTRL,ALT,DEL); I cannot check status of plug-ins or add-ons; I cannot even check the status of Firefox itself.

I did a complete uninstall of Firefox, swept the registry with two different programs plus a manual sweep (regedit), then reinstalled the lasted Firefox download. The same problems still persist.

Is there anyone actively working on a solution for this?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check the pref dom.storage.enabled on the about:config page and make sure that the pref is set to true.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Create a new profile as a test to check if your current profile is causing the problems.
See Basic Troubleshooting: Make a new profile
There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"
If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

That was it !!!! I went into "about:config", checked the status of dom.storage.enabled on the about:config page and the pref was set to "false". I reset to "true" and now everything appears to be working properly.

Many, many thanks for the help.

Paige

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You're welcome Paige.

tired77 0 solutions 3 answers

Do you mind translating that fix into normal English?

Not all of us here are computer whizzes.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can start with this part:

  • type about:config in the location bar, where you also type the address of a website, and press the Enter key.
  • You can accept the warning that you will be careful and click the button.

Now you see a page with a lot of preferences that has a Filter bar at the top.

  • In the Filter bar type: dom.storage.enabled

If the pref is bold (user set) with the value false then double-click the line to toggle the value to true.
If the value is already true then you have a different problem.

Stacy222 0 solutions 2 answers

Helpful Reply

I even tried the RAM extension trick..MUST be YouTube..

Stacy222 0 solutions 2 answers

I even tried the Random Access Memory trick..Must be YouTube..

GaiaSmith 0 solutions 22 answers

Stacy said..."I even tried the Random Access Memory trick"...

What trick is that? 'Course, you said it didn't work, so maybe I don't NEED to know? Time to go start a new thread, me thinks...

Thanx, Sam

RonQ 0 solutions 80 answers

Cor-els link to a supposed solution was a NON-solution.

Didn't help. I already had that value selected.

So, like hundreds of others on these boards have indicated, I still have this problem, too, and NO FIX IN SIGHT.

Where is Mozilla????