X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get the error console to quit popping up?

Posted

My error console keeps popping up when I open Firefox or when a pop-up occurs but its getting really annoying because it has never done that before. Please tell me how do i get it to quit popping up.

Chosen solution

Do you have any mouse gesture extensions installed?

You can see the installed Firefox extensions in "Tools > Add-ons > Extensions".

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Read this answer in context 14

Additional System Details

This happened

Every time Firefox opened

This started when...

A few weeks ago

Installed Plug-ins

  • Runs 3-D games and interactive applets
  • Office Plugin for Netscape Navigator
  • MFireLauncher
  • npdivxplayerplugin
  • Hotbar Firefox Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • Default Plug-in
  • Pando Web Plugin
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.3.4
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50917.0
  • Office Live Update v1.5
  • NPWLPG
  • Version 1.0.1, copyright 1996-2009 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.12) Gecko/20101026 AskTbPSI/3.9.1.14019 YFF35 Firefox/3.6.12 PBSTB/1.2

More Information

nothing that i know of.

the-edmeister
  • Top 10 Contributor
  • Moderator
3193 solutions 24375 answers

That is usually caused by a setting in the Web Developer Toolbar. Do you have the Web Developer extension installed?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Some mouse gesture extensions have also been reported to cause this issue.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Question owner

where can i find the wed devoloper toolbar?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Chosen Solution

Do you have any mouse gesture extensions installed?

You can see the installed Firefox extensions in "Tools > Add-ons > Extensions".

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
strat5459 0 solutions 2 answers

If you have the Web Developer Toolbar installed, do the following to prevent the Error Console from popping up:

(If the Web Developer toolbar is not visible, you can also access the same parameters via the Tools/Web Developer/Options/Options menus in the Firefox menu bar).

1. Click on the "Options" icon in the Web Developer toolbar.

2. Click on "Options" in the drop-down menu.

3. Click on the "Miscellaneous" icon

4. Make sure that all the boxes are unchecked in the "Warnings and Errors" menu box.

Now the Error console will stop popping up when you go to a site. You can always check the boxes to display the Error Console later if needed.

Modified by strat5459

Snozzwanger 0 solutions 1 answers

Helpful Reply

I disabled All-in-One mouse gestures (use FireGestures instead) and this annoying error console pop-up problem is solved.

Tomc50 0 solutions 1 answers

Thanks, strat5459! This is the answer to this issue... at least it was for me. Many thanks!

There should be a disclaimer or warning with the Web Developer Toolbar about this happening. It is baffling, completely counter-intuitive, and renders Firefox almost unusable until you figure it out. (or come here.... : )

TC

Modified by Tomc50

B52GUNS 0 solutions 1 answers

Had this problem of "error console" popping up. Through process of elimination, the add on "FoxLocation", vrs 0.0.0.6 with the "Enable Debug" checked was causing the problem. Unchecked the "Enable Debug", and all was fine. Sounds strange, but it is true.

TSgt R.M. Johnson