X
Tap here to go to the mobile version of the site.

Support Forum

Trouble editing text fields since upgrading to FF 3.5+

Posted

Ever since I upgraded to Firefox 3.5, I've had trouble editing text fields, both in some websites and in FF itself. I first noticed this when I went to edit the name of a website I was bookmarking. Clicking in the blocked-out title should (and used to) clear the block and position the cursor, but now the only way to edit it is to use the keyboard keys (End, Home, arrow, etc.).

Now I'm also finding a similar problem in the Facebook status update field, where it doesn't always respond to clicking or double-clicking my mouse to highlight a word or reposition the cursor.

I just upgraded to the latest 3.6 and was hoping this would be fixed, but it's the same or worse. Is anyone else having this problem?

Ever since I upgraded to Firefox 3.5, I've had trouble editing text fields, both in some websites and in FF itself. I first noticed this when I went to edit the name of a website I was bookmarking. Clicking in the blocked-out title should (and used to) clear the block and position the cursor, but now the only way to edit it is to use the keyboard keys (End, Home, arrow, etc.). Now I'm also finding a similar problem in the Facebook status update field, where it doesn't always respond to clicking or double-clicking my mouse to highlight a word or reposition the cursor. I just upgraded to the latest 3.6 and was hoping this would be fixed, but it's the same or worse. Is anyone else having this problem?

Chosen solution

  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Two upgrades ago, which I think was 3.5

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Yahoo! activeX Plug-in Bridge
  • np-mswmp
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Winamp Application Detector
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0C)

More Information

??

cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157934 answers

Chosen Solution

  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
* "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" * "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). * Don't make any changes on the Safe mode start window. See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]] If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. * Use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions. * Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Question owner

Thanks very much cor-el. It turns out to be the theme that's the problem. I've posted a review of the theme and reported the problem. Hopefully the problem can be fixed soon. Many thanks for your help. :-)

I'm clicking that your advice solved the problem, inasmuch as it allowed me to diagnose it.

Thanks very much cor-el. It turns out to be the theme that's the problem. I've posted a review of the theme and reported the problem. Hopefully the problem can be fixed soon. Many thanks for your help. :-) I'm clicking that your advice solved the problem, inasmuch as it allowed me to diagnose it.

Modified by starhugger

kayo 0 solutions 2 answers

Hi!

I am having the identical problem EXCEPT none of these suggestions work and I AM using the default Firefox theme. I recently upgraded to 3.6 and had no problem prior to this.

PLEASE help—anyone!

Hi! I am having the identical problem EXCEPT none of these suggestions work and I AM using the default Firefox theme. I recently upgraded to 3.6 and had no problem prior to this. PLEASE help—anyone!
cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157934 answers

You can try to check the pref dom.storage.enabled on the about:config page and make sure that the pref is set to true.

See also:

You can try to check the pref dom.storage.enabled on the about:config page and make sure that the pref is set to true. * http://kb.mozillazine.org/Dom.storage.enabled See also: * http://kb.mozillazine.org/Resetting_preferences * http://kb.mozillazine.org/Preferences_not_saved