X
Tap here to go to the mobile version of the site.

Support Forum

How do I remove certain smart keywords?

Posted

http://support.mozilla.com/en-US/kb/Smart+keywords I want to know how to remove the smart keywords that this article tells you only how to create.

I have the smart keyword 'ford' set to search the Ford website. I never use it, and when I want to simply Google 'ford escort' and type 'ford escort' into my location bar, it searches ford.com for 'escort' instead, because of that smart keyword. Long story short: I want to remove that smart keyword and all my troubles will be solved.

http://johnbokma.com/firefox/keymarks-explained.html I looked at this site and I do not have the 'quick searches' folder in my bookmarks menu.

This happened

Every time Firefox opened

http://support.mozilla.com/en-US/kb/Smart+keywords I want to know how to remove the smart keywords that this article tells you only how to create. I have the smart keyword 'ford' set to search the Ford website. I never use it, and when I want to simply Google 'ford escort' and type 'ford escort' into my location bar, it searches ford.com for 'escort' instead, because of that smart keyword. Long story short: I want to remove that smart keyword and all my troubles will be solved. http://johnbokma.com/firefox/keymarks-explained.html I looked at this site and I do not have the 'quick searches' folder in my bookmarks menu. == This happened == Every time Firefox opened

Chosen solution

Try :dialog searchengines.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • -IDM FlashPlugin Firefox W32
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Google Update
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • 4.0.50524.0
  • NPWLPG
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

More Information

rjohnson19 39 solutions 240 answers

A smart keyword is stored as a bookmark, so you just need to delete it.

Go to the Library (Bookmarks -> Organize Bookmarks or Ctrl+Shift+B)

In the Search Bookmarks textbox, enter in the title of the keyword search bookmark. You can see the title in the location bar if you use the keyword.

Then, just delete it with the Delete key or right click and choosing Delete.

A smart keyword is stored as a bookmark, so you just need to delete it. Go to the Library (Bookmarks -> Organize Bookmarks or Ctrl+Shift+B) In the Search Bookmarks textbox, enter in the title of the keyword search bookmark. You can see the title in the location bar if you use the keyword. Then, just delete it with the Delete key or right click and choosing Delete.

Question owner

Thanks for the reply.

However there are certain keywords that do not appear when I type them into the location bar. But when I hit enter, they still take me to a search page. They don't appear to be in my bookmarks anywhere either.

Here's a screenshot of the only way I know of being able to see them all, which is with the Vimperator add-on.

I have no idea how 'bugmenot1' and 'urban1' got there, and I can't find them in the Library.

Thanks for the reply. However there are certain keywords that do not appear when I type them into the location bar. But when I hit enter, they still take me to a search page. They don't appear to be in my bookmarks anywhere either. Here's a screenshot of the only way I know of being able to see them all, which is with the Vimperator add-on. I have no idea how 'bugmenot1' and 'urban1' got there, and I can't find them in the Library.
bielawski 1 solutions 1 answers

Chosen Solution

Try :dialog searchengines.

Try <code>:dialog searchengines</code>.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit")

Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]] If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the [[Safe mode]] start window to disable all extensions. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit")