X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This weird symbol-font started showing up in text boxes and headlines.

Posted

This weird illegible symbol-font is being used for some headlines, and also inside of some text boxes. It just started appearing maybe two months ago in place of a normal readable font. I checked the "Content" tab under Options, and the default font is still Times New Roman... When I find a webpage where the font shows up, if I check the same webpage in either Internet Explorer or Chrome, the text/font is normal and legible... So basically how do I change this weird font back to something normal? And why did it suddenly start showing up?

Here are some examples where the font show up. This is a screenshot from the website Lala in FireFox. http://farm5.static.flickr.com/4018/4675193123_707f7c65eb_b.jpg

Here's a screenshot of the same webpage in Google Chrome. The font is all normal. http://farm5.static.flickr.com/4010/4675815604_0f7da3cdf1_b.jpg

And here is an example of a text box where the font shows up. http://farm5.static.flickr.com/4057/4656705391_ec63846f9d.jpg

This happened

Every time Firefox opened

== About 2 months ago.

Additional System Details

Installed Plug-ins

  • -getplusadobe15229
  • npmnqmp 989898989877
  • np-mswmp
  • npdnu
  • npdivxplayerplugin
  • Default Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Delivery Network Acceleration by BitTorrentâ„¢
  • DivX Web Player version 2.0.2.40
  • Garmin Communicator Plug-In 2.7.3.0
  • GEPlugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Rhapsody Player Engine Plugin
  • NPVeohVersion4 plugin
  • Veoh Web Video Player Browser Plugin
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 AskTbMYC-QBD/3.7.1.11118 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

This issue can be caused by the bitmap version of the Helvetica or Geneva font or another (bitmap) font that can't be displayed by Firefox in that font size. Firefox can't display that font in the specified size and displays gibberish instead. You can test that by zooming out (View > Zoom > Zoom Out, Ctrl -) to make the text smaller.

Uninstall (remove) all variants of that not working font to make Firefox use another font or find a True type version of that font that doesn't have the problem.

Question owner

That worked! Thank you! But I had to remove Helvetica, which is a shame because it was a font I used regularly. And I'm afraid to install it again because I imagine it would trigger the same problem again.... Oh well, I guess I'm better off without it, and having FireFox working properly!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

You're welcome

Question owner

I'm having a similar problem, but not sure it's exactly the same. Again, it only happens on one site (at this time). Not happening in Firefox on my computer at work though. I tried the Zoom out, and the weird symbol font just got smaller. Please let me know how to fix. Thanks!!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96858 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (200 KB) and do not click Preview after you have attached the image. --- If you see something similar like in the screenshots from the first post then it is highly likely that you have the same issue. See also /forum/1/566006

Question owner

I'll see if a .pdf file works. I didn't think it was the same issue as the user above, b/c the font didn't become legible when I zoomed out. It stayed the same, except got smaller.

Question owner

Okay...going to try this again...

file:///C:/Users/Owner/Desktop/Firefox%20Screen%20Shot.htm

Question owner

I'm having the same problem. I had installed the helvetica font, so I think the same solution would work for me. I deleted the text file for the font, but it is still showing up as a font in Microsoft Word and I'm still having the problem. Is there another part of the file that I am suppose to delete?