Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why is it so difficult to get spell check to work?

  • 12 replies
  • 0 have this problem
  • 27 views
  • Last reply by cor-el

more options

I went into setting and made sure spellcheck is enabled and it is, but there are no other options there. I did exactly what it said on your help article and right clicked in the text box on multiple different web pages and there is NO OPTION. It should not be this complicated.

I went into setting and made sure spellcheck is enabled and it is, but there are no other options there. I did exactly what it said on your help article and right clicked in the text box on multiple different web pages and there is NO OPTION. It should not be this complicated.
Attached screenshots

All Replies (12)

more options

Can you see it in the reply box of this website, or is it the same as above?

Helpful?

more options

Sites can disable the browser's spellchecker, often done for rich text editors that have their own implementation.

https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/spellcheck

Helpful?

more options

You can try modifying this preference in about:config

layout.spellcheckDefault = 1 [0:disable; 1:multi-line; 2:single-line]

Also make sure you have a Dictionary installed as only a few locales like en-US comes with a dictionary due to license reasons. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Helpful?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Did you install a dictionary yourself or do you use a locale like en-US that comes with a dictionary ? Dictionaries you install appear under "Settings -> Dictionaries", so possibly check that and make sure they are enabled.

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

Helpful?

more options

TyDraniu said

Can you see it in the reply box of this website, or is it the same as above?

No I didn't. It didn't appear anywhere. the dictionaries section of the addons menu did not appear either. I eventually found the place to install dictionary and I did so and now I can see the spellsheck, but it was not present before that and this whole process is utterly bamboozling, even for someone with computer experience. I have never installed firefox and found spellcheck to be working (I've been doing this since the 90s). I have always had to go through a bloody rigmarole to get it working. It is just badly done. the help page says we can access the languages thing in the right click menu to download a dictionary but that is patently untrue. if there are no dictionaries installed, then we are left with no hint of it's existence. Everysingle time, I have to go hunting for a damn instruction guide to how to get teh darn spellcheck working again and find that the firefox help pages are just plain wrong.

Helpful?

more options

If you download the "en-US" version it comes with a US dictionary.

Not all locales come with a dictionary installed due to licensing reasons.

How do I use the Firefox spell checker?

Helpful?

more options

The en-GB version that you may have doesn't come with a dictionary for license reasons like a lot of other locales and you need to install a dictionary yourself.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

Helpful?

more options

Thank you for explaining this here. It needs to be in the firefox interface. The link to the dictionaries needs to be present in the context menu in text boxes and the dictionaries section of the addons menu needs to be visible by default. There needs to be a way for people to see there is no dictionary installed and to access the download page from within firefox UI just like other add-ons. There needs to be an indication in the settings menu that there is no dictionary.

Helpful?

more options

tremault said

Thank you for explaining this here. It needs to be in the firefox interface. The link to the dictionaries needs to be present in the context menu in text boxes and the dictionaries section of the addons menu needs to be visible by default. There needs to be a way for people to see there is no dictionary installed and to access the download page from within firefox UI just like other add-ons.

It is as you can see in the article. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker#w_adding-dictionaries

Helpful?

more options

It is not visible when no dictionaries are installed (Bug 1385688).

Helpful?

more options

James said

tremault said

Thank you for explaining this here. It needs to be in the firefox interface. The link to the dictionaries needs to be present in the context menu in text boxes and the dictionaries section of the addons menu needs to be visible by default. There needs to be a way for people to see there is no dictionary installed and to access the download page from within firefox UI just like other add-ons.

It is as you can see in the article. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker#w_adding-dictionaries

I find this extremely rude. I posted a very clear screenshot.

zeroknight said

It is not visible when no dictionaries are installed (Bug 1385688).

Thank you. I can't click on that bug link, but I appreciate that this is going to be addressed.

Helpful?

more options

Note that there is also bug1387450 as the main pref for designing the about:addons page.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.