Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

[SOLVED] Keyword in bookmark caused Firefox to redirect all searches starting with the word "amazon" to Amazon

  • 18 replies
  • 0 have this problem
  • 146 views
  • Last reply by James

more options

Whenever I type something in the URL bar that starts with the word "amazon," instead of getting a Google search for what I typed, I get redirected to Amazon.com with whatever I typed as a product search. For example, if I type "amazon sucks" in Firefox's URL bar, instead of getting a Google search for the phrase "amazon sucks," I get an Amazon page with the word "sucks" pre-filled in Amazon's product search (and a screen full of socks).

I don't have a search keyword for "amazon" in my Firefox settings. As far as I can tell, no other magic word does the same thing. (For example, if I type "yahoo sucks" or "walmart sucks," I get the desired Google searches. I don't get redirected to a Yahoo or Walmart page.

How do I turn this behavior off?

Whenever I type something in the URL bar that starts with the word "amazon," instead of getting a Google search for what I typed, I get redirected to Amazon.com with whatever I typed as a product search. For example, if I type "amazon sucks" in Firefox's URL bar, instead of getting a Google search for the phrase "amazon sucks," I get an Amazon page with the word "sucks" pre-filled in Amazon's product search (and a screen full of socks). I don't have a search keyword for "amazon" in my Firefox settings. As far as I can tell, no other magic word does the same thing. (For example, if I type "yahoo sucks" or "walmart sucks," I get the desired Google searches. I don't get redirected to a Yahoo or Walmart page. How do I turn this behavior off?

Modified by Jon9

Chosen solution

By the way, your Amazon results URL has:

s?k=help&ref=nb_ss_gw

For comparison, a search sent through the bundled Amazon search engine in Firefox has these parameters:

s?k=help&link_code=qs&sourceid=Mozilla-search&tag=moz-us-20

So I don't think typing amazon is calling up the bundled search engine.


Two things to check would be:

(1) Any add-on that could possibly relate to Amazon.

This could be difficult to determine unless it is apparent from its name.

(2) Any bookmark that has amazon as a keyword.

Typically a keyworded search bookmark has a %s parameter in its URL, so you could pop up the Library window (Ctrl+Shift+O) and type %s in the tiny search box upper right and then arrow down through the results list watching the panel at the bottom to see if any of them has amazon as its keyword.

For more background on these: How to search IMDB, Wikipedia and more from the address bar

Read this answer in context 👍 1

All Replies (18)

more options

To stop Firefox from redirecting searches starting with the word "amazon" to Amazon, you can follow these steps:

Open a new tab in Firefox and type "about:config" in the URL bar.

You may see a warning message about the risks involved in making changes. Proceed by clicking on the "Accept the Risk and Continue" button.

In the search bar at the top of the page, type "keyword.URL".

You should see a preference named "keyword.URL" in the list of results. Double-click on it to modify its value.

Delete the existing value and replace it with the following:

arduino Copy code https://www.google.com/search?q= This change will ensure that searches starting with "amazon" will go to a Google search instead of redirecting to Amazon.

Press Enter or click outside the preference value box to save the changes.

After making this modification, searches starting with "amazon" in the Firefox URL bar should now perform a Google search instead of redirecting to Amazon.

Note: Modifying preferences in about:config can impact Firefox's behavior, so it's important to be cautious and make changes only if you understand the consequences.

more options

suram080 said

In the search bar at the top of the page, type "keyword.URL". You should see a preference named "keyword.URL" in the list of results. Double-click on it to modify its value.

Thanks for trying, but I don't have any about:config entries for keyword.URL.

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can do a malware scan just to be sure.

more options

cor-el said

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.


No change in Troubleshoot Mode. Typing "amazon bites" in the Firefox URL bar still takes me to Amazon.com with "bites" in Amazon's product search box.

No malware.

It's a mystery!

Modified by Jon9

more options

[duplicate posting]

Modified by Jon9

more options

Go to Settings -> Search and scroll down to the Search Shortcuts section. There you can remove search shortcuts from Amazon search engine.

more options

suram080 said

You should see a preference named "keyword.URL" in the list of results.

As mentioned in a previous thread, it is essential that you TEST your suggestions on the current release of Firefox. The keyword.URL preference was removed in Firefox 23, TEN years ago.

Please, please, do not waste peoples' time with untested suggestions. Or stop posting here.

more options

TyDraniu said

Go to Settings -> Search and scroll down to the Search Shortcuts section. There you can remove search shortcuts from Amazon search engine.

As I wrote in my original posting (first sentence of the second paragraph): "I don't have a search keyword for 'amazon' in my Firefox settings."


jscher2000 - Support Volunteer said

Please, please, do not waste peoples' time with untested suggestions. Or stop posting here.

Please, please, don't bicker in my thread. I'm happy to welcome any suggestions, tested or not, as long as they're well intentioned. If the suggestions don't work or don't make sense, I'll graciously let you know. My goal here isn't to reinforce forum etiquette. My goal is to learn how to do a Google search for "amazon contact" from the Firefox URL bar without getting a search for contact lenses on Amazon. Thank you.

Modified by Jon9

more options

Let me try to illustrate the problem.

I've restarted FF in Troubleshooting Mode.

The first picture is my FF Search settings page, after I've removed the search shortcut entries for Amazon, Bing, and eBay.

The second picture shows what happens when I type "amazon help" in the FF URL bar. I expect to get a Google search for the phrase "amazon help," but instead I get an Amazon search for the product "help."

In contrast, the third picture shows what happens when I type "ebay help" in the FF URL bar. I expect to get a Google search for the phrase "ebay help," and that's exactly what happens.

So this is not an extension or chrome.css issue (because I'm running in Troubleshooting Mode). This is not a search shortcut issue (because I've removed the shortcut for Amazon, and also because it doesn't happen for eBay or Bing). This is not a keyword.URL about:config issue (because that entry doesn't exist in my version of FF).

This is a mystery! Something is redirecting FF searches that start with the word "amazon" -- and ONLY the word "amazon."

more options

Did you remove the entries in the Keyword column as well (@amazon) before removing this search engine (not sure if this is possible for built-in search engines)?

You can append a question mark to force a search: amazon help?

Modified by cor-el

more options

Thank you for the screenshots.

Your second and third screenshots do not show the address bar drop-down that normally appears as you are typing a query. The top line of the drop-down typically tells you what Firefox intends to do with your address bar input if you submit it at that moment. Does yours say

amazon help – Search with Google

or does it say that Firefox will take some other action?

For example:

more options

jscher2000 - Support Volunteer said

Your second and third screenshots do not show the address bar drop-down that normally appears as you are typing a query.

The screenshot shows exactly what I see. There is no drop-down.

more options

Chosen Solution

By the way, your Amazon results URL has:

s?k=help&ref=nb_ss_gw

For comparison, a search sent through the bundled Amazon search engine in Firefox has these parameters:

s?k=help&link_code=qs&sourceid=Mozilla-search&tag=moz-us-20

So I don't think typing amazon is calling up the bundled search engine.


Two things to check would be:

(1) Any add-on that could possibly relate to Amazon.

This could be difficult to determine unless it is apparent from its name.

(2) Any bookmark that has amazon as a keyword.

Typically a keyworded search bookmark has a %s parameter in its URL, so you could pop up the Library window (Ctrl+Shift+O) and type %s in the tiny search box upper right and then arrow down through the results list watching the panel at the bottom to see if any of them has amazon as its keyword.

For more background on these: How to search IMDB, Wikipedia and more from the address bar

more options

Jon9 said

jscher2000 - Support Volunteer said

Your second and third screenshots do not show the address bar drop-down that normally appears as you are typing a query.

The screenshot shows exactly what I see. There is no drop-down.

Hmm, did you set browser.urlbar.maxRichResults to zero in about:config? If so, try increasing that to 1 for troubleshooting purposes.

more options

JScher2000 figured it out!

jscher2000 - Support Volunteer said

Any bookmark that has amazon as a keyword. Typically a keyworded search bookmark has a %s parameter in its URL, so you could pop up the Library window (Ctrl+Shift+O) and type %s in the tiny search box upper right and then arrow down through the results list watching the panel at the bottom to see if any of them has amazon as its keyword.

That was it! Mystery solved!

I had an evil bookmark that was assigned a keyword "amazon", pointing to the URL http://www.amazon.com/s/ref=nb_ss_gw?url=search-alias%3Daps&field-keywords=%s. That was catching up anything I typed in the URL bar starting with "amazon" and feeding the rest of the search term to www.amazon.com as a search string.

I have no idea where I picked that up! I deleted the bookmark, and the problem went away. Computers do what they're told to do (and let's hope it stays that way).

Thank you, JScher2000!

Modified by Jon9

more options

(I thought I posted a "thank you" to JScher2000, who solved this issue with his suggestion that I had a bookmark with the keyword "amazon," but my posting seems to have gotten lost. So again, THANK YOU, JSCHER2000. I'm also re-attaching a screenshot of the bookmark that caused this problem. Once I deleted this bookmark, the problem went away.)

more options

Great, if it wasn't one of those things, we'd definitely have a head-scratcher.

Your missing post should appear eventually. Posts with links to non-Mozilla sites go into a spam link moderation queue for review. I think there is a notice on screen about it right after you post, but it blends in with the other text and is hard to see.

more options

Jon9 said

(I thought I posted a "thank you" to JScher2000, who solved this issue with his suggestion that I had a bookmark with the keyword "amazon," but my posting seems to have gotten lost.

Not lost, the post was flagged due to having links not whitelisted in the reply. Unfortunately this forum does get the occasional spam threads and replies with hidden or visible spam links. The spam threads are usually easy to spot, however the spam replies can potentially get missed if not for automated flagging.