Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Limited Tabs

  • 28 replies
  • 0 have this problem
  • 91 views
  • Last reply by Steve09

more options

When you open a web site, a tab is created up top under the "File," "Edit," "View," etc. tabs. And, obviously, if you have more then one site open, they're all there. But this week I noticed that with the fourth tab, they stop being visible, and there's arrows on the far left and right. So if you have five or six pages open and you want to go back to the first tab/web site, you have to hit the arrow on the far left to make that tab visible, and then click on the tab.

So they went from one step/click to two, or three, or four! Sometimes I have to click around to find the tab I want. Also, there's times I just want to see if a site/tab is there. Now, I have to click the darn arrow and find it!

Why do they do this? If it aint broke, don't fix it!

I don't want it like this. At all. I want all the tabs there, without any arrows. Just like it always was. How do I get it back to what it was?

When you open a web site, a tab is created up top under the "File," "Edit," "View," etc. tabs. And, obviously, if you have more then one site open, they're all there. But this week I noticed that with the fourth tab, they stop being visible, and there's arrows on the far left and right. So if you have five or six pages open and you want to go back to the first tab/web site, you have to hit the arrow on the far left to make that tab visible, and then click on the tab. So they went from one step/click to two, or three, or four! Sometimes I have to click around to find the tab I want. Also, there's times I just want to see if a site/tab is there. Now, I have to click the darn arrow and find it! Why do they do this? If it aint broke, don't fix it! I don't want it like this. At all. I want all the tabs there, without any arrows. Just like it always was. How do I get it back to what it was?

All Replies (20)

more options

If you have placed other toolbar buttons or the search bar on the Tab bar then try to remove them (move them to another toolbar or to the '>>' overflow area).

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

1. I didn't add anything to the tool bar.

2. I only have three extensions and disabled them, manually. Closed FF and reopened, didn't work, the arrows are still there.

3. Can't find "hardware acceleration" setting.

4. There is no "default" for Themes. The top one, "Auto," is enabled.

more options

I went to about:config - browser.tabs.tabMinWidth - lowered the number (that squishes the tab) but that didn't work either.

I don't know how or why this happened, all by itself, this week. I figured the new update did this. If so, what the heck are they thinking?

more options

Can you attach a screenshot?

more options

A screen shot of what?

I'm not talking about the backward and forward arrows that allow you to go back to the previous page or forward a page.

Under the "File," "Edit," "View," etc. tabs at the very top, and above the bar with the address field, is where the rectangle web site tabs are. Every time you go to a web site, that tab appears. Once you get to the fifth web site/tab, arrows appear - a left facing one to the left of the first tab on the far left, and a rightward facing one to the right of the far right one. So if you want to go to the first web site/tab, you have to click the leftward arrow to get to it.

I want it back to what it was, before this week. Didn't matter how many tabs I had open, they were all there. No arrows.

more options

A screenshot might help if we can see how the Tab behaves for you of you open a new tab, i.e. in what way the tabs resize and how buttons like the newtab (+) and the tab manager (down arrow) button shows. There have been a lot of reports about how the Tab bar (mis)behaves in 108 under various conditions.

more options

The screenshot is attached. There's four Google.com pages open, but there is a fifth - this message board post/page. I'd have to click that left arrow to see it.

FWIW the aboutconfig - browser.tabs.tabMinWidth setting is set to 76, which is what it always was.

more options

This is possibly a problem with your userChrome.css file in case you use this file to style the user interface. You will have to check whether there is an update available from its creator for Firefox 108.

more options

I have no idea what Chrome.css file is. I don't use this file to style the user interface, whatever that means. I wouldn't even know how to do that.

Besides, I didn't change anything this week. These arrows appeared, on their own, apparently right after a FF update. So I doubt this has anything to do with the Chrome.css file, and everything to do with the update.

more options

Did you try to start Firefox in Troubleshoot Mode like I posted above ?

Try to start Firefox in Troubleshoot Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox
more options

No, because I was afraid I'd lose my settings. But troubleshooting mode sounds like it disables add-ons, so I did that myself. I only have three. It didn't fix the problem.

Can't be because of them anyway, because, again, this happened suddenly, on it's own. So Troubleshooting mode won't do any good. So why bother? There is nothing wrong with anything on my end. Either FF changed this on their own - why, I have no idea - or there was something wrong with the update.

more options

The screenshot shows that the tabs aren't expanding to fill the full window width like they should, so something is wrong here. Running Firefox in Troubleshoot Mode does more than disabling extensions, so it doesn't hurt to try this. If you close and restart Firefox when you run in Troubleshoot Mode then Firefox will startup in regular mode.


If it works in Troubleshoot Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
more options

The tabs never did fully expand, I always only saw part of the tab. It was always like that. So, no, that's not the problem (after seeing what about config - browser.tabs.tabMinWidth, is, if this is ever fixed I'll go back in there and raise the number so I can see the entire tab. Didn't know you could do that.).

I tried Troubleshooting Mode, didn't work. Arrows still there.

This isn't happening on anyone else's end? Either this has to be their (crazy) doing, on purpose, or there was something wrong with the update.

There's no about config setting where I can add the number of tabs I want before it puts in the arrows?

more options

browser.tabs.tabMinWidth is only about to what width a tab can be reduced when you keep opening more tabs. Tabs should always expand automatically the fill the available width of the tab bar or at least to the maximum width of a tab (225px). It sounds weird that this has never worked for you.

Did you check whether you have a chrome folder in the profile folder and a userChrome.css in this folder?

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).


.tabbrowser-tab:not([pinned]) {
  -moz-box-flex: 100;
  max-width: 225px;
  min-width: var(--tab-min-width);
  width: 0;
  transition: min-width 100ms ease-out,
              max-width 100ms ease-out;
}

more options

I went to the about:profile page, to the right of "Profile Folder" I clicked "open folder," but, no, there is no userChrome.css folder. I searched for it, but it's not found. So no, it's not there.

To clarify, my tabs are longer and fill out more for the first couple. But beginning with the third one, they get smaller. And with the fourth one, they get smaller, and the arrows appear, with the first tab disappearing to the left.

more options

You can try "Restore Default" on the customize page and rename/remove xulstore.json in the Firefox profile folder.

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I restored default, put my settings back, and it worked. To a point. Instead of getting those arrows with the fifth tab, I get the arrows with the eighth tab. Over the years, I must have had more then eight tabs open at one point, and would have noticed the arrows. So something is still wrong.

I cleared the start up cache, didn't work. Creating a new profile sounds not only too complicated, but since this isn't a major hard-to-find bug, it's too much for something this small, and stupid.

I don't understand why these arrows are appearing. Am I the only one that is getting them?

I went back into about:config - browser.tabs.tabMinWidth and lowered the number. First to 65 and then 50. The lower it goes the more tabs I get before the arrows appear. I guess I can live with that. But the problem, is that once the arrows appear, even if I x out of some of the tabs, the arrows remain until a couple are left.

I just want it back to what it was. Maybe one day I'll uninstall and do a reinstall. But only if I knew that had a chance of working.

Is there a way to contact someone inside FF? Or do I have a better chance of hitting the lottery?

more options

Do in the new profile the tabs fill the entire Tab bar or it this still filled partially ? Note that the minimum for browser.tabs.tabMinWidth is 50.

more options

The tabs fill out all the way until the the fifth one, when they start to shrink. Before this started they started to shrink, maybe after three or four. I don't remember exactly. But I think they're starting to shrink after more tabs now - maybe because I got the browser.tabs.tabMinWidth settting to 44. And at 44, I'm not getting the arrows until the 10th tab. But by then the tabs are so small, all you see of Google.com is the icon and barely part of the "G".

more options

Steve09 said

I restored default, put my settings back, and it worked. To a point. Instead of getting those arrows with the fifth tab, I get the arrows with the eighth tab. Over the years, I must have had more then eight tabs open at one point, and would have noticed the arrows. So something is still wrong.

It's normal to get left and right scroll buttons on the tab bar when there are too many tabs to show the default minimum width of 76 pixels for all of them. The number that fit could be well over a dozen, depending on your screen resolution and scaling.

When your tab bar overflows (scroll buttons appear), has the gap between the + button and the "List All Tabs" (Tab manager) button disappeared? There's normally nothing between those buttons in Customize, allowing the tabs and + button to use all the available space before overflowing.

  1. 1
  2. 2